Nothing contained herein may be reproduced, copied, modified or adapted, without the prior written consent of SDL Group. SDL Group means SDL PLC. and its subsidiaries. All intellectual property rights contained herein are the sole and exclusive rights of SDL Group. All references to SDL or SDL Group shall mean SDL PLC. and/or its subsidiaries details of which can be obtained upon written request.

All rights reserved. Unless explicitly stated otherwise, all intellectual property rights including those in copyright in the content of this documentation are owned by or controlled for these purposes by SDL Group. Except as otherwise expressly permitted hereunder or in accordance with copyright legislation, the content of this site, and/or the documentation may not be copied, reproduced, republished, downloaded, posted, broadcast or transmitted in any way without the express written permission of SDL.

SDL Trados Studio, SDL MultiTerm, SDL MultiTerm Online, SDL Studio GroupShare, PerfectMatch, SDLX, Passolo, TranslationZone, Translator’s Workbench, TagEditor, QuickPlace, AutoSuggest, BeGlobal and GlobalConnect are registered trademarks of SDL Group. All other trademarks are the property of their respective owners. The names of other companies and products mentioned herein may be the trademarks of their respective owners. Unless stated to the contrary, no association with any other company or product is intended or should be inferred. This product may include open source or similar third-party software, details of which can be found by clicking the Acknowledgments section. Although SDL Group takes all reasonable measures to provide accurate and comprehensive information about the product, this information is provided as-is and all warranties, conditions or other terms concerning the documentation whether express or implied by statute, common law or otherwise (including those relating to satisfactory quality and fitness for purposes) are excluded to the extent permitted by law.

To the maximum extent permitted by law, SDL Group shall not be liable in contract, tort (including negligence or breach of statutory duty) or otherwise for any loss, injury, claim liability or damage of any kind or arising out of, or in connection with, the use or performance of the Software Documentation even if such losses and/or damages were foreseen, foreseeable or known, for: (a) loss of, damage to or corruption of data, (b) economic loss, (c) loss of actual or anticipated profits, (d) loss of business revenue, (e) loss of anticipated savings, (f) loss of business, (g) loss of opportunity, (h) loss of goodwill, or (i) any indirect, special, incidental or consequential loss or damage howsoever caused. Information in this documentation, including any URL and other Internet Web site references, is subject to change without notice.

Without limiting the rights under copyright, no part of this may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of SDL Group.

Acknowledgments

SDL Trados Studio includes open source or similar third-party software:
- Sharpziplib and Spring.net distributed under GNU General Public License version 3 with restrictions
- Hunspell distributed under GNU Lesser General Public License version 3
- ICU distributed under IBM ICU License
- Log4Net, Xalan and Xerces distributed under Apache License version 2.0
- Wix distributed under Common Public License version 1.0
- SQLite which is public domain and requires no license for this distribution
- Nalpeiron Licensing Services distributed under license

This guide ships with SDL Trados Studio 2014 SP2

November 2014
## TABLE OF CONTENTS

### Chapter 1  About SDL Trados Studio

- About this Guide .......................................................... 1-2
- Related Documentation ................................................. 1-3
- Introducing SDL Trados Studio ....................................... 1-4
- Profiles ................................................................. 1-5
- Terminology ............................................................ 1-6
- SDL Trados Studio Actions ............................................. 1-9

### Chapter 2  Introduction to SDL Trados Studio for SDL Trados 2007 Users

- Overview ........................................................................ 2-2
  - Workflows .............................................................. 2-2
  - Single-File Translation Workflow ................................. 2-3
  - Project Package Translation: Offline Workflow ............ 2-4
  - GroupShare Project Translation: Online Workflow ...... 2-6
  - Views ....................................................................... 2-7
- Defining Default Settings .............................................. 2-11
  - SDL Trados Profile Settings ........................................ 2-11
- Creating and Managing Projects .................................... 2-13
  - Packages .................................................................. 2-16
- Translating Files .......................................................... 2-17
  - Opening a File for Translation .................................... 2-18
  - TTX Files, Bilingual Microsoft Word Files vs. SDL XLIFF Files 2-24
  - Translating Environment ........................................... 2-25
  - Translating in SDL Trados Translator’s Workbench vs. Translating in SDL Trados Studio 2-28
- Working with Translation Memories ................................. 2-28
- Working with Terminology ............................................. 2-32
- Working with Tags ....................................................... 2-35
- Working with Recognized Tokens ................................... 2-39
- Previewing a Document ................................................. 2-40
Chapter 3  Introduction to SDL Trados Studio for SDLX Users

Overview ........................................................................... 3-2
   Workflows .................................................................. 3-2
   Single-File Translation Lifecycle ............................... 3-3
   Project Package Translation: Offline Workflow .......... 3-4
   GroupShare Project Translation: Online Workflow ...... 3-6
   Switchboard vs. Views .................................................. 3-7

Defining Default Settings .................................................. 3-11
   SDLX Profile Settings .................................................. 3-11

Creating and Managing Projects ........................................ 3-13
   Create Project Translation Memory ............................ 3-17
   Assigning Work to Project Participants ...................... 3-19

Translating Files .............................................................. 3-20
   Opening a File for Translation .................................... 3-21
   ITD Files vs. SDL XLIFF Files .................................... 3-26
   Translating Environment .............................................. 3-27
   Translating in SDLX vs. Translating in SDL Trados Studio 3-30
   Working with Translation Memories ......................... 3-30
   Working with Terminology ........................................... 3-35
   Working with Tags ....................................................... 3-37
   Working with Recognized Tokens ............................. 3-42
   Previewing a Document .............................................. 3-44
   Open a File for Review ............................................... 3-47
   Verification .................................................................. 3-48
   Create Translation vs. Finalize ................................. 3-51

Creating and Managing Translation Memories .................... 3-53
   Creating a Translation Memory .................................. 3-54
   Editing a Translation Memory Setup ......................... 3-56
   Translation Memory Segmentation ............................ 3-58
   Importing and Exporting ............................................ 3-59
Translation Memory Maintenance ..................................................... 3-61

Chapter 4  About Data Migration

Overview ................................................................. 4-2
  About Upgrading Translation Memories ......................... 4-2
  Method 1: Upgrade Translation Memories ...................... 4-2
  Method 2: Upgrade using TMX Files ......................... 4-3
  Method 3: Upgrade Using Bilingual Files ................... 4-3
  Method 4: Upgrade Using Alignment tools .................. 4-3
  Supported Upgrade Translation Memory File Formats ........ 4-3
  About Reusing Translations from Bilingual Files in PerfectMatch 4-4
  About Migrating INI and ANL Files to SDL Trados Studio ........ 4-5

Chapter 5  Upgrading Legacy Translation Memories

Overview ................................................................. 5-2
  Why Upgrade your Translation Memories? ...................... 5-3
  Hints and Tips ...................................................... 5-4
  Upgrade Translation Memory Process .......................... 5-5
  Software Required for Upgrade ................................ 5-6
  Upgrading Segmentation Rules .................................. 5-6
  Compatibility with SDL Trados 2007 and SDLX 2007 Data ..... 5-11
  Upgrading Fields .................................................... 5-12

  Upgrading your Legacy Translation Memories ................. 5-14
  Before you Start ................................................... 5-14
  How to Upgrade your Legacy Translation Memories ........... 5-15

Chapter 6  Populating Translation Memories from TMX Files

Overview ................................................................. 6-2
  Who Should do this? ................................................. 6-2
  Hints and Tips ...................................................... 6-3
  Benefits and Limitations ........................................ 6-4
  Two Methods ......................................................... 6-5
  Upgrading Fields .................................................... 6-8
  Tag Information ..................................................... 6-8

  Upgrading the TMX Files Using the Upgrade Translation Memories Wizard . 6-9
  Before you Start ................................................... 6-9
Chapter 7  Populating Translation Memories from Bilingual Documents

Overview ................................................................. 7-2
  Why do this? ......................................................... 7-2
  Benefits and Limitations ........................................ 7-3
  Two Methods ....................................................... 7-4

Importing Bilingual Files to an Existing Translation memory ..................... 7-6
  Before you Start .................................................. 7-6
  How to Import Bilingual Files to an Existing Translation Memory ........... 7-7

Importing Bilingual Files to a Legacy Translation Memory and Upgrading the
  Translation Memory .............................................. 7-13
  How to Import Bilingual Files to a Legacy Translation Memory and Upgrade
  the Translation Memory ........................................ 7-13

Chapter 8  Populating Translation Memories from Alignment Result Files

Overview ................................................................. 8-2
  About Populating Translation Memories using SDL Trados WinAlign
  Alignment Results .................................................. 8-2
     About Populating Translation Memories using SDLX Alignment Results ... 8-2
     Software Required for Upgrading Alignment Result Files ................. 8-3
  How to Populate your Translation Memories from SDL Trados WinAlign
  Export TXT Files .................................................. 8-5
     Populating your Translation Memories from SDLX Alignment Results .... 8-7

Chapter 9  Reuse Translations From Bilingual Documents in PerfectMatch

Overview ................................................................. 9-2
  About PerfectMatch ................................................ 9-2
Chapter 10 Migrating INI and ANL Tag Settings Files

Overview .................................................................................. 10-2
Why Migrate your Tag Settings and Analysis Files? .................. 10-2
What Types of Files can you Migrate? ...................................... 10-2
What is Migrated? ................................................................. 10-3
Migrating INI and ANL Files for XML ...................................... 10-6
How to Migrate INI and ANL Files for XML ......................... 10-6
Migrating INI Files for HTML .................................................. 10-16
How to Migrate INI Files for HTML ........................................ 10-16

Chapter 11 How to work with the Translation Supply Chain with Studio 2014 SP2 (TTX and Bilingual Doc Files)

Overview .................................................................................. 11-2
TTX Files, Bilingual Microsoft Word Files vs. SDL XLIFF Files .... 11-2
Before You Start: Options for TTX Support .............................. 11-3
Compatibility Setting for TTX .................................................. 11-3
Tag Verification Settings .......................................................... 11-7
Scenarios ................................................................................... 11-8
Scenario 1: Client Sends TTX Files and Wants TTX Files Back .... 11-8
Scenario 2: Client Sends New Source Files and Wants Translated Files and TTX Files Back ........................................ 11-11
Scenario 3: Client Wants Bilingual TTX for Review Purposes ..... 11-15
Scenario 4: Client Wants Bilingual TTX Files to Update Their TM . 11-18
Scenario 5: Client Sends Sources File in Word Format (.doc) and Wants Bilingual .doc and Target.doc Files Back .......................... 11-19
Tip: Keeping Both Studio (.sdltm) and Legacy SDL Trados (.tmw) Translation Memories Up-to-Date ........................................ 11-23
Chapter 1 introduces the SDL Trados Studio product. Topics include:

- About this Guide
- Related Documentation
- Introducing SDL Trados Studio
- Terminology
- SDL Trados Studio Actions
ABOUT THIS GUIDE

Welcome to the SDL Trados Studio 2014 SP2 Migration Guide for the SDL Trados Studio 2014 SP2 release. SDL Trados Studio is made up of two main components:

- SDL Trados Studio
- SDL GroupShare - This is the server component of Studio. It includes SDL TM Server, MultiTerm Server and Project Server.

This guide describes the differences between the way that SDL Trados Studio works compared to SDL Trados 2007 and SDLX. The purpose of this guide is to help the experienced SDL Trados 2007 and SDLX 2007 users understand the differences and adapt to them quickly. For a more complete introduction to working with SDL Trados Studio, see the online Help installed with SDL Trados Studio.

This guide is split into two sections. The first half of the guide describes the differences between conceptual information and standard user procedure in SDL Trados Studio compared to SDL Trados 2007 and SDLX 2007. The second half of the guide provides instructions on how to migrate data from SDL Trados 2007 and SDLX 2007 to SDL Trados Studio 2014.

NOTE

- For information on how to upgrade server-based translation memories from SDL Trados Studio 2009 to SDL Trados Studio 2014 format, refer to the SDL GroupShare Installation Guide.
- File-based translation memories from SDL Trados Studio 2009 do not need upgrading and are the same format as translation memories in SDL Trados Studio 2014.

| Part 1: User Tasks | Chapter 2 - Introduction to SDL Trados Studio for SDL Trados 2007 Users  
Chapter 3 - Introduction to SDL Trados Studio for SDLX Users |
|-------------------|---------------------------------------------------------------------|
| Part 2: Data Migration | Chapter 4 - About Data Migration  
Chapter 5 - Upgrading Legacy Translation Memories  
Chapter 6 - Populating Translation Memories from TMX Files  
Chapter 7 - Populating Translation Memories from Bilingual Documents  
Chapter 8 - Populating Translation Memories from Alignment Result Files  
Chapter 9 - Reuse Translations From Bilingual Documents in PerfectMatch  
Chapter 10 - Migrating INI and ANL Tag Settings Files  
Chapter 11 - How to work with the Translation Supply Chain with Studio 2014 SP2 (TTX and Bilingual Doc Files) |
Related Documentation


- **SDL Trados Studio Help** - contains information about using SDL Trados Studio 2014 SP2.

- **Translating and Reviewing Documents Quick Start Guide** - contains information for translators and reviewers. It focuses on how to translate and review files.

- **Project Management Quick Start Guide** - contains information for project managers. It focuses on the project lifecycle.

- **Translation Memory Management Quick Start Guide** - contains information for users who create and maintain translation memories.
INTRODUCING SDL TRADOS STUDIO

SDL Trados Studio provides one integrated environment for all your translation, review and project management needs. It is a project-based translation management system and translation editor tool. It enables you to create projects, centralize data management, manage and create translation memories, and translate and review documents. SDL Trados Studio also enables translation teams to share translation tools, translation memories and project files across an organization. This setup enables both individual and team working. The audience for this tool are project managers, translators and reviewers. Using SDL Trados Studio you can:

- Translate a single file.
- Automate the process of project creation.
- Apply translation memories to project files and produce translation analysis figures.
- Allow translators to connect directly to translation memories and termbases using the intranet or Internet, ensuring maximum leverage and consistency.
- Manage and create translation memories. (Local and Server-based).
- Translate and review documents.
- Align existing translated documents to generate translation memory content.

SDL Trados Studio can also be a single-user tool. In this setup the SDL Trados Studio application and translation memories are located on your computer and there is no interaction with translation memories or projects over an intranet or the Internet. You can translate and manage files as part of a project or you can perform a single file translation where a project is automatically created when you open the file for translation. A project may contain a single file or many files for translation into one language or several languages. It may also contain reference material, translation memories and instructions for translators.
Profiles

Preferences are stored in your user profile. You can export your user profile to a file for sharing with other users or for you to take with you when you use SDL Trados Studio on a different computer. You could also create profiles for use with different customers. There are three types of profiles that are shipped with SDL Trados Studio:

<table>
<thead>
<tr>
<th>Profile</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>SDL recommends that new users select this profile.</td>
</tr>
<tr>
<td>SDL Trados</td>
<td>SDL recommends that users upgrading from SDL Trados 2007 select this profile. This profile contains keyboard shortcuts and translation settings from SDL Trados 2007 software. For more information, see Defining Default Settings on page 2-11.</td>
</tr>
<tr>
<td>SDLX</td>
<td>SDL recommends that users migrating from SDLX select this profile. This profile contains keyboard shortcuts and translation settings from SDLX software. For more information, see Defining Default Settings on page 3-11.</td>
</tr>
</tbody>
</table>

You are prompted to select which user profile you want to use when you first open the application. You can also select a different profile by selecting File Menu > Setup > Manage User Profiles.
### Terminology

Some terminology may differ from the terminology used in SDL Trados 2007 and SDLX:

<table>
<thead>
<tr>
<th>SDL Trados Studio</th>
<th>SDL Trados 2007</th>
<th>SDLX</th>
<th>SDL Trados Studio Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td>Project</td>
<td>Project</td>
<td>All files in SDL Trados Studio are translated and managed as part of a project. A project can contain a single file or many files for translation into one language or several languages. It may also contain reference material, translation memories, termbases and instructions for translators.</td>
</tr>
<tr>
<td>Packages</td>
<td>Packages</td>
<td>n/a</td>
<td>A project package contains all of the files that need to be sent to a project team member in order for them to commence work on the project. A project package is a simple file structure containing:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Project files: target language files and reference files</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- The project translation memory</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Project settings.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Once the project package is created, you send it by email or another transport method to the team member who will be working on the project files.</td>
</tr>
<tr>
<td>Views</td>
<td>Synergy Views</td>
<td>n/a</td>
<td>Each view represents a different area of functionality in the application.</td>
</tr>
<tr>
<td>SDL Trados Studio</td>
<td>SDL Trados 2007</td>
<td>SDLX</td>
<td>SDL Trados Studio Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------</td>
<td>------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Analyze</td>
<td>Analyze</td>
<td>SDL Analyse</td>
<td>Analyzes files against the translation memory, producing statistics on the leverage to be expected during translation. This task works with project translation memories if they are available.</td>
</tr>
<tr>
<td>Pre-translate</td>
<td>Translate</td>
<td>SDL Apply</td>
<td>When you create a project, it pre-translates project files by applying translations from translation memories, terminology databases (termbases) and previously translated files. Pre-translation refers to the automatic translation of segments in the source file(s).</td>
</tr>
<tr>
<td>Finalize</td>
<td>Clean Up</td>
<td>Create Translations Wizard</td>
<td>Update Translation Memory Convert to Generated Format</td>
</tr>
<tr>
<td>Structure Tags</td>
<td>External Tags</td>
<td>Tags</td>
<td>They typically represent structural information. These tags and their content are completely ignored during translation and can only appear outside sentences. You rarely need to move or delete structure tags during translation.</td>
</tr>
<tr>
<td>Inline Tags</td>
<td>Internal Tags</td>
<td>Tags</td>
<td>These tags may represent formatting information (such as bold), surround hyperlinks or other markers, and may appear inside the text.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Bilingual Preview</td>
<td>n/a</td>
<td>Previews the source and target segments of the document side-by-side in a web browser.</td>
</tr>
<tr>
<td>SDL Trados Studio</td>
<td>SDL Trados 2007</td>
<td>SDLX</td>
<td>SDL Trados Studio Description</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------</td>
<td>------------</td>
<td>------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>External Preview</td>
<td>n/a</td>
<td>View Source Translation Preview</td>
<td>Previews the document in its native application.</td>
</tr>
<tr>
<td>Real-time Preview</td>
<td>n/a</td>
<td>n/a</td>
<td>The translation preview is updated to reflect the changes as you type. This update occurs every time you confirm a segment.</td>
</tr>
</tbody>
</table>
## SDL TRADOS STUDIO ACTIONS

The following actions can be performed in SDL Trados Studio. If you have selected a SDLX or SDL Trados user profile, you can continue to use SDLX and SDL Trados 2007 keyboard shortcuts for these actions. The keyboard shortcuts listed below are for the default user profile.

<table>
<thead>
<tr>
<th>Action</th>
<th>Ribbon Command</th>
<th>Default User Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Translating Documents (Editor View)</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Translate Single Document" /></td>
<td>File &gt; Open &gt; Translate Single Document</td>
<td>[CTRL]+[SHIFT]+[O]</td>
</tr>
<tr>
<td><img src="image" alt="Project Settings" /></td>
<td>Home tab &gt; Project Settings</td>
<td>n/a</td>
</tr>
<tr>
<td><img src="image" alt="Apply a Translation" /></td>
<td>Home tab &gt; Translation Memory group &gt; Apply Translation</td>
<td>[CTRL]+[T]</td>
</tr>
<tr>
<td><img src="image" alt="Concordance Search" /></td>
<td>Home tab &gt; Translation Memory &gt; Concordance Search</td>
<td>[F3]</td>
</tr>
<tr>
<td><img src="image" alt="Open a Termbase" /></td>
<td>Home tab &gt; Project Settings &gt; Termbases</td>
<td>n/a</td>
</tr>
<tr>
<td><img src="image" alt="Insert Term Translation" /></td>
<td>Term Recognition window or Termbase Search window &gt; Insert term translation</td>
<td>n/a</td>
</tr>
<tr>
<td><img src="image" alt="Confirm a Translation" /></td>
<td>Home tab &gt; Segment Actions group &gt; Confirm</td>
<td>[CTRL]+[ENTER]</td>
</tr>
<tr>
<td>Action</td>
<td>Ribbon Command</td>
<td>Default User Keyboard Shortcut</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------------------------------------------------------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Approve a Translation</td>
<td><strong>Home tab &gt; Segment Actions group &gt; Confirm and Move to Next Unconfirmed Segment</strong></td>
<td>[CTRL] +[ENTER]</td>
</tr>
<tr>
<td>Sign-off a Translation</td>
<td><strong>Home tab &gt; Segment Actions group &gt; Confirm and Move to Next Unconfirmed Segment</strong></td>
<td>[CTRL] +[ENTER]</td>
</tr>
<tr>
<td>Insert Tags</td>
<td><strong>Home tab &gt; Formatting or QuickInsert group</strong></td>
<td>[CTRL]+[,]</td>
</tr>
<tr>
<td>Preview Translation in Preview Window</td>
<td>n/a</td>
<td>[CTRL]+[K]</td>
</tr>
<tr>
<td>Preview Translation in its Native Application</td>
<td>File &gt; Print &amp; View In</td>
<td>n/a</td>
</tr>
<tr>
<td>Add Comment</td>
<td><strong>Review tab &gt; Comments group &gt; Add Comment</strong></td>
<td>[CTRL]+[SHIFT]+[N]</td>
</tr>
<tr>
<td>Verify Document</td>
<td><strong>Review tab &gt; Quality Assurance group &gt; Verify</strong></td>
<td>[F8]</td>
</tr>
<tr>
<td>Generate Translated Document</td>
<td><strong>File &gt; Save Target As</strong></td>
<td>[SHIFT]+[F12]</td>
</tr>
</tbody>
</table>
### Creating and Managing TMs (Translation Memories View)

<table>
<thead>
<tr>
<th>Action</th>
<th>Ribbon Command</th>
<th>Default User Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a New File-based Translation Memory</td>
<td>[Home tab &gt; Tasks group &gt; New &gt; New Translation Memory]</td>
<td>[ALT]+[SHIFT]+[N]</td>
</tr>
<tr>
<td>Create a New Server-based Translation Memory</td>
<td>[Home tab &gt; Tasks group &gt; New &gt; New Server-based Translation Memory]</td>
<td>n/a</td>
</tr>
<tr>
<td>Open a Translation Memory for Maintenance</td>
<td>[Home tab &gt; Tasks group &gt; Open Translation Memory]</td>
<td>[ALT]+[SHIFT]+[O]</td>
</tr>
<tr>
<td>Edit Translation Memory Settings</td>
<td>[Home tab &gt; Tasks group &gt; Settings]</td>
<td>n/a</td>
</tr>
<tr>
<td>Import Data into a Translation Memory</td>
<td>[Home tab &gt; Tasks group &gt; Import]</td>
<td>n/a</td>
</tr>
<tr>
<td>Export Data from a Translation Memory</td>
<td>[Home tab &gt; Tasks group &gt; Export]</td>
<td>n/a</td>
</tr>
<tr>
<td>Action</td>
<td>Ribbon Command</td>
<td>Default User Keyboard Shortcut</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>--------------------------------------------------------------------------------</td>
<td>--------------------------------</td>
</tr>
<tr>
<td><strong>Creating and Managing Projects</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>New Project</td>
<td>File &gt; New &gt; New Project</td>
<td>[CTRL]+[N]</td>
</tr>
<tr>
<td>Open Project</td>
<td>File &gt; Open &gt; Open Project</td>
<td>[CTRL]+[O]</td>
</tr>
<tr>
<td>Open Package</td>
<td>File &gt; Open &gt; Open Package</td>
<td>n/a</td>
</tr>
<tr>
<td>Create Package</td>
<td>Projects view &gt; Home tab &gt; Packages group &gt; Create Package</td>
<td>n/a</td>
</tr>
<tr>
<td>Create Return Package</td>
<td>Projects view &gt; Home tab &gt; Packages group &gt; Create Return Package</td>
<td>n/a</td>
</tr>
<tr>
<td><strong>Align Existing Translated Documents</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Align Single File Pair</td>
<td>Welcome or Translation Memories view &gt; Home tab &gt; Align Documents &gt; Align Single File Pair</td>
<td>[CTRL]+SHIFT+[M]</td>
</tr>
<tr>
<td>Align Multiple Files</td>
<td>Welcome or Translation Memories view &gt; Home tab &gt; Align Documents &gt; Align Multiple Files</td>
<td>n/a</td>
</tr>
</tbody>
</table>
PART 1: USER TASKS
INTRODUCTION TO SDL TRADOS STUDIO FOR SDL TRADOS 2007 USERS

This chapter gives an introduction of SDL Trados Studio to SDL Trados 2007 users. Topics include:

- Overview
- Defining Default Settings
- Creating and Managing Projects
- Translating Files
- Creating and Managing Translation Memories
OVERVIEW

There are some differences between the way SDL Trados Studio works compared with SDL Trados 2007. The purpose of this chapter is to help experienced SDL Trados 2007 users understand the differences and adapt to them quickly. For a more complete introduction to working with SDL Trados Studio, see the online help installed with SDL Trados Studio.

NOTE

The chapter is based on settings in the SDL Trados profile. If you have not selected the SDL Trados profile, the behavior described in this chapter may vary.

SDL Trados 2007 was made up of several components:

SDL Trados Synergy was the project management tool for people using SDL Trados 2007. It enabled you to automate project creation, centralize data management and track projects.

SDL Trados Translator’s Workbench was a translation memory management system in SDL Trados 2007. It also supported interactive translation through the interface with Microsoft Word and SDL Trados TagEditor. This interface provided direct access to the translation memory database whilst translation was in progress.

SDL Trados Studio has incorporated the translation memory management system, project management and both editor tools into one application. It enables you to create projects, centralize data management, manage and create translation memories, and translate and review documents.

NOTE

For the purposes of this guide, users of SDL Trados 2007 will be referred to as SDL Trados Translator’s Workbench users.

This chapter goes through the difference between projects in SDL Trados Translator’s Workbench and SDL Trados Studio, how the translating environment has changed and where to go to perform translation memory maintenance.

Workflows

These are some of the potential workflows that you can follow in SDL Trados Studio. These are workflows that you control and can be changed to suit your needs.

- Single-File Translation Workflow
- Project Package Translation: Offline Workflow
- GroupShare Project Translation: Online Workflow
Single-File Translation Workflow

The following diagram shows a typical workflow if you are translating a single file in SDL Trados Studio:
Project Package Translation: Offline Workflow

This is an example of one way in which you can work with projects through the use of project packages:
Recommended Package Use

There are two recommendations about how you work with packages in your workflow:

- Always create a package for every task you want to be completed.
- Always create a return package for every task you have completed and send to the person who gave you the task.

For detailed information about what a package is, see Packages on page 2-16.

Alternative Workflows

Alternative Package Workflow

This is another way in which you can work with packages in a workflow.

- The project manager creates a project.
- The project manager creates a project package and sends to the translator for translation.
- The translator opens the package and translates the files.
- The translator creates a return package and sends it to the project manager.
- The project manager creates a project package and sends it to the reviewer.
- The reviewer opens the package and reviews the files.
- The reviewer creates a return package and sends it to the project manager.

Alternative Project Workflow

This workflow example shows how an individual translator can benefit from using projects.

- The translator creates a project for each customer and never runs the Finalize batch task.
- When the translator receives new files for a project, they add the new files to the project source language then prepare them with the Prepare batch task.
- The translator saves the finished target files using the File > Save Target As instead of running the Finalize batch task on the files.
- If the translator is using a project TM, they can run the Update Main Translation Memories batch task.
GroupShare Project Translation: Online Workflow

This workflow stores the GroupShare project on the Project Server (This is part of the server component of Studio called SDL GroupShare) and assumes that all team members in the workflow have access to the Project Server. It eliminates the need for using project packages as all team members can simply open the GroupShare server-based project to access their work from the server.

NOTE
For more information about using Studio in an SDL GroupShare environment, see the SDL Trados Studio Help.
Views

The layout of SDL Trados Synergy was similar to SDL Trados Studio with the functionality being accessed through views. To display a view, you clicked the button that bears the name of the view or the icon for that view. The view navigation buttons appeared at the bottom of the navigation pane.

Like SDL Trados Synergy, SDL Trados Studio also has a Projects, Reports and Files view. In addition, SDL Trados Studio has a Welcome, Editor and Translation Memories view. After aligning existing translated documents, Studio opens an extra Alignment view where you can review and correct the alignment result file (*.sdlalign).
Figure 2.2 - SDL Trados Studio Views
The SDL Trados Studio views function in the following way:

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>This is where you can:</td>
</tr>
<tr>
<td></td>
<td>- Access popular Help videos and documentation</td>
</tr>
<tr>
<td></td>
<td>- Read the latest SDL Trados Studio news</td>
</tr>
<tr>
<td></td>
<td>You can also access commands to do the following:</td>
</tr>
<tr>
<td></td>
<td>- New Project</td>
</tr>
<tr>
<td></td>
<td>- Translate Single Document</td>
</tr>
<tr>
<td></td>
<td>- Open Package</td>
</tr>
<tr>
<td></td>
<td>- Open GroupShare Project</td>
</tr>
<tr>
<td></td>
<td>- Access your SDL Language Cloud account information and manage subscriptions to Language Cloud machine translation engines</td>
</tr>
<tr>
<td></td>
<td>Selecting any of these commands will switch you to the appropriate view in SDL Trados Studio or open another application where you can perform the action.</td>
</tr>
<tr>
<td>Projects</td>
<td>This is where you view and work with projects. You can select a project to view detailed project and file information and track project and file status.</td>
</tr>
<tr>
<td>View</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Files</strong></td>
<td>This is where you work with project files. From here you can:</td>
</tr>
<tr>
<td></td>
<td>- Open files for translation, review or sign-off</td>
</tr>
<tr>
<td></td>
<td>- Perform batch processing on files.</td>
</tr>
<tr>
<td></td>
<td>- Create packages from the project files.</td>
</tr>
<tr>
<td></td>
<td>You can also view word counts and translation progress for these files.</td>
</tr>
<tr>
<td><strong>Reports</strong></td>
<td>This is where you view project reports. The reports provide detailed</td>
</tr>
<tr>
<td></td>
<td>translation analysis figures which feed directly into the project planning</td>
</tr>
<tr>
<td></td>
<td>and budgeting process.</td>
</tr>
<tr>
<td><strong>Editor</strong></td>
<td>This is where documents are translated and reviewed.</td>
</tr>
<tr>
<td><strong>Translation Memories</strong></td>
<td>This is where you create and manage translation memories.</td>
</tr>
<tr>
<td><strong>Alignment</strong></td>
<td>This is where you review and correct the result of the alignment that</td>
</tr>
<tr>
<td></td>
<td>Studio performs automatically when you align existing translated</td>
</tr>
<tr>
<td></td>
<td>documents. This view is only available when you open an alignment result</td>
</tr>
<tr>
<td></td>
<td>file (*.sdlalign).</td>
</tr>
</tbody>
</table>
DEFINING DEFAULT SETTINGS

You can define default settings for use in your translation in the Options dialog box. These settings are used if you open a single file for translation and are stored in the default project template when you create a project. Select File > Options to display the Options dialog box.

**Figure 2.3 - Options Settings in SDL Trados Studio**

SDL Trados Profile Settings

If you selected the SDL Trados profile, similar settings that were selected by default in SDL Trados are selected in SDL Trados Studio. These are some of the settings.

Select Language Pairs > All Language Pairs > Batch Processing > Pre-translate Files from the navigation tree in the Options dialog box.

- The **Minimum Match Score** is set to 100%. This means that only 100% matches will be pre-translated.
- The **Copy source to target if no match found** check box is not selected. This means that the source segment text is not automatically copied into the target segments if no translation memory match was found.
These settings allow you to see 100% matches and work interactively through the remainder of the document, pulling fuzzy matches from the translation memory as required during the interactive translation process.
CREATING AND MANAGING PROJECTS

Like SDL Trados 2007 projects, SDL Trados Studio is also a project-based translation management system. All files are translated and managed as part of a project. A project may contain a single file or many files for translation into one language or several languages. It may also contain reference material, translation memories, termbases and instructions for translators.

Click the **New Project** button in any view in SDL Trados Studio to create a new project. This is the same button that you use in SDL Trados Synergy to create projects.

**Figure 2.4 - SDL Trados Synergy and SDL Trados Studio**

SDL Trados Synergy gave you an option to create a project from scratch with default settings. SDL Trados Studio however, provides you with a default template on which to base your project. This can significantly speed up the time it takes to create a project. The default template stores your default settings specified in the application. You can specify these default settings and file filters in the **Options** dialog box. The default template is automatically selected when you create a new project. These settings can be modified as required when you create a project.
SDL Trados Studio provides you with the same ability to specify translation memory, pre-translation and batch processing settings that SDL Trados Synergy provided when you create a project.

**NOTE**

In SDL Trados Studio, you can modify the project settings you specified after the project is created. You modify these settings in the **Project Settings** dialog box.
Figure 2.6 - Project Settings in SDL Trados Studio
Packages

SDL Trados Studio packages follow a similar approach to SDL Trados Synergy packages. A project package is a single zipped file that contains all of the files that need to be sent to a project team member in order for them to commence work on the project. It can contain:

- Project files: target language files and reference files
- The project translation memory
- Connection details for a server-based translation memory
- Project settings.

Once the project package is created, you can click the **Send Packages by Email** button at the end of the **Create Project Package** wizard to email to the team member who will be working on the project files. You can create packages in the **Projects** and **Files** view by selecting the **Create Project Package** option from the **Packages** group.

**NOTE**

If you are working with a GroupShare project, you can access work that is assigned to you by opening the project in Studio. For more information, see the online help.

*Figure 2.7 - Create Project Package Wizard in SDL Trados Studio*
TRANSLATING FILES

There are some major differences in how you translate a file in SDL Trados Translator’s Workbench to how you translate a file in SDL Trados Studio. However, some of the basic actions have stayed the same. For example, you still confirm a translation once it is complete. The following are the areas of functionality in which the differences between SDL Trados Translator’s Workbench and SDL Trados Studio are described:

- Open a File for Translation. See “Opening a File for Translation” on page 2-18.
- Bilingual Files. See “TTX Files, Bilingual Microsoft Word Files vs. SDL XLIFF Files” on page 2-24.
- Retrieving translations from the translation memory. See “Working with Translation Memories” on page 2-28.
- Working with Tags. See “Working with Tags” on page 2-35.
- Preview translations. See “Previewing a Document” on page 2-40.
- Confirming translations. See “Confirming a Segment” on page 2-42.
Opening a File for Translation

When using SDL Trados Translator’s Workbench, you opened a file for translation in SDL Trados TagEditor or Microsoft Word. Alternatively, you could have opened a file from a project in SDL Trados Synergy for translation in SDL Trados TagEditor or Microsoft Word.

In SDL Trados Studio, you can open a single file for translation or open a file for translation from within a project.

Figure 2.8 - Open a file for Translation in SDL Trados Studio

Open a single file for translation

Open a file from a project for translation
Alternatively, you can open a file for translation by drag-and-dropping it from your computer into the Editor Navigation Pane or into the Editor Window.

**Figure 2.9 - Quickly Open a File for Translation in SDL Trados Studio**

Drag-and-drop a file here to quickly open it for translation
Single-File Translation

Before you open a single file for translation in SDL Trados Studio, SDL recommends that you define your default:

- Translation Memories and Termbases
- Settings

**NOTE**

You can also connect to automated translation providers (Machine Translation) and add AutoSuggest dictionaries which offer text suggestions while you translate. For more information, refer to the online help in SDL Trados Studio.

Translation memories, termbases and settings are defined in the Language Pairs section of the Options dialog box.

**Figure 2.10 - SDL Trados Studio Default Settings**

All Language Pairs Level

Individual Language Pairs Level
Typically, you edit settings, and select translation memories and termbases at the All Language Pairs level. These settings apply to all of the language pairs and then individual exceptions to these settings can be defined for each language pair.

For example, you can change the default fuzzy matching threshold setting to 65% at the All Language Pairs level and it will apply to all translation memories for all language pairs. However, if you want English to German to use a different fuzzy matching threshold, you can change it at the individual language pairs level to 75%.

The default translation memories and termbases that you define here are automatically opened and your default settings applied when you start a new translation.

To set up your translation defaults:

For example, if you want to set up default translation memories, termbases and translation settings for English (United States) to German (Germany) follow these instructions:

1. Select File > Options. The Options dialog box is displayed.
2. To set up your default translation memory:
   - Select Language Pairs > All Language Pairs > Translation Memory and Automated Translation from the navigation tree. The Translation Memory and Automated Translation page is displayed on the right.
   - Click Add and select File-based Translation Memory from the drop-down list to add a local translation memory. The Open Translation Memory dialog box is displayed.
   - Select an English (United States) - German (Germany) translation memory and click Open. The translation memory is added to the list. Only .sdltm translation memories are supported.

   **NOTE**

   For information on migrating your translation memories to .sdltm format, see Chapter 5 - Upgrading Legacy Translation Memories.

   - If your setup does not include the language pairs specified in the selected translation memory, English (United States) - German (Germany), the Add Supported Language Pairs dialog box is displayed where you can select the language pair and click OK to add it to the setup.
3 To set up your default termbase:

- Select **Language Pairs > All Language Pairs > Termbases** from the navigation tree. The **Termbases** page is displayed on the right.

- Click **Add**. The **Select Termbases** dialog box is displayed. If the termbase that you want to use is not displayed, click **Browse** to locate a local termbase. The termbase is added to the list in the **Select Termbases** dialog box.

- Click **OK**. The termbase is added to the list.

**To open a single file for translation:**

1 Click the **File > Translate Single Document** icon in any view. The **Open Document** dialog box is displayed.

2 Select the file which you want to translate and click **Open**. The **Open Document** dialog box is displayed.

3 Select **English (United States)** as your **Source Language** and **German (Germany)** as your **Target Language**.

4 If you already defined your default translation memories for this language pair in the previous section, the default translation memories are displayed under **Translation Memory and Automated Translation**. Add and remove translation memories as required.
5 Click **OK**. The translatable content of the source language document is identified, segmented and placed in an SDL XLIFF file. The file is opened in the Editor window in the **Editor** view for translating.

When you use the **Translate Single Document** command, a project is automatically created for the opened file. Your default translation memories and termbases (that you defined in the **Options** dialog box) are automatically opened. Any settings that you specified in the **Options** dialog box are also automatically applied. If you want to change these settings for this file, select **Project Settings** from the **Home** tab of any view to display the **Project Settings** dialog box.

**Open a File for Translation from a Project**

If you are working with projects in SDL Trados Studio, you can open a file for translation from the **Files** view. In the **Files** view, right-click on a file and select **Open for Translation** from the shortcut menu. The file is opened in the **Editor** view. The translation memories and termbases defined in the project are automatically opened. Any settings that you specified in the project are also automatically applied.

If you want to change the settings, select **Project Settings** from the **Home** tab of any view to display the **Project Settings** dialog box.
TTX Files, Bilingual Microsoft Word Files vs. SDL XLIFF Files

When you created a project in SDL Trados Synergy or when you opened a file for translation in SDL Trados TagEditor, the file was converted to a bilingual format TTX for translation. If you were using SDL Trados Translator’s Workbench with Microsoft Word, files were converted to a Bilingual Rich Text Format (RTF).

In SDL Trados Studio when you create a project or open a document for translation it is converted to SDL XLIFF, a bilingual format used by SDL Trados Studio. SDL XLIFF stands for SDL XML Localization Interchange File Format. It is an XML based bilingual file format, specially developed for use in localization. It is bilingual because it contains both the source document and the document translation in a single file. When an SDL XLIFF file is displayed in the Editor window in the Editor view, the source document text is displayed on the left of the editor window and the target version of the text is displayed on the right.

When you save an SDL XLIFF file, the .sdlxliff extension is added to the name of the source language document being translated. For example, a source document named Sample.doc would be saved as Sample.doc.sdlxliff. For more information on XLIFF files, refer to http://xml.coverpages.org/xliff.html

NOTE

Bilingual Rich Text Format (RTF) files created when translating in Microsoft Word with SDL Trados Translator’s Workbench and cannot be processed or opened in SDL Trados Studio. To leverage information from these files, they must first be cleaned up in SDL Trados Translator’s Workbench to create a legacy translation memory and then upgraded to the new translation memory format. For more information, see Importing Bilingual Files to a Legacy Translation Memory and Upgrading the Translation Memory on page 7-13.
Translating Environment

In SDL Trados Translator’s Workbench the editing environment was made up of two applications. The translatable content was displayed within the file in bilingual mode in SDL Trados TagEditor. SDL Trados Translator’s Workbench was displayed on the top and showed the match from the translation memory.

If you had terminology recognition enabled, SDL Trados Translator’s Workbench displayed recognized terms from the currently selected segment.

Figure 2.11 - Translating Environment in SDL Trados 2007
In SDL Trados Studio, documents are reviewed and translated in the **Editor** view. This view contains the following components:

- **Navigation pane**, where you can see the documents that are currently open and navigate between them.
- **Tabs and groups on the Ribbon**.
- **Editor window** where you perform translation or review.
- A set of tabbed windows that appear above the Editor window. These include a translation results window, a term recognition window, a concordance window, a comments window and a messages window.

**Figure 2.12 - Translating Environment in SDL Trados Studio**
Editor Window

The Editor window in the Editor view is where you translate documents. The bilingual SDL XLIFF document containing the text to be translated and the translation are displayed in the window, side by side. The source language text appears on the left and the target language version on the right. The content of the document is broken down into segments (typically sentences). The target language segments can be edited.

- The first column displays segment numbers. Only one number is displayed for each segment pair as the source and target segments are aligned with each other by default. You can choose not to display segment numbers. The source and target segments can also be worked with as two separate lists.

- Between the source and target segment columns is the segment status column. This column indicates the current translation status of the segment and its translation origin. For example, if the translation is approved and if a 100% match was found in the translation memory for this segment.

- To the right of the target language segments is the document structure column. It displays a code that tells you where in the original document the segment text appears. Hover over the code or click on the code in this column to display a description telling you where the segment appears in the source document.

Figure 2.13 - Translating in SDL Trados Studio
Translating in SDL Trados Translator’s Workbench vs. Translating in SDL Trados Studio

In SDL Trados Translator’s Workbench, to start translating a segment you first clicked the Open/Get button to edit the target segment.

To start translating in SDL Trados Studio, click inside one of the target segments in the document and simply start typing. You can use standard windows text editing functionality when working in SDL Trados Studio.

When you place your cursor in a segment, it automatically becomes the active segment which allows you to edit that segment. You can choose to turn off the option that makes it the active segment automatically and instead manually make it the active segment by selecting Home tab > Navigation group > Activate Row.

Working with Translation Memories

When you worked with a translation memory in SDL Trados Translator’s Workbench, you could retrieve translations from your translation memory and update the translation memory. In SDL Trados Studio, the process of retrieving the translations works in a similar way, however, updating the translation memory uses different logic.

Retrieving Translations from the Translation Memory

When you clicked the Open/Get button in SDL Trados Translator’s Workbench, a lookup in the translation memory was performed.

Figure 2.14 - SDL Trados Translator’s Workbench Translation Memory Match
In SDL Trados Studio, translations found by the lookup are displayed in the **Translation Results** window where you can then choose one to apply to the current segment. Lookups are performed on source language segments only.

A translation memory lookup is performed when a segment becomes the active segment. This happens when you place your cursor in a new segment or when your cursor is automatically placed in a segment after confirming a previous segment. If you have automatic row activation turned off, select **Home tab > Navigation group > Activate Row** to make it the active segment. When a lookup is performed:

- The best translation memory match is automatically placed in the target segment and the match is also displayed in the **Translation Results** window.
- In the example below, a 100% translation memory match has been found and automatically confirmed. The percentage match [100%] is displayed in the segment status column and the ![green checkmark](symbol indicates that the segment is confirmed.

**Figure 2.15 - SDL Trados Studio Translation Memory Match**
Updating the Translation Memory

In SDL Trados Translator’s Workbench, the **Project and Filter Settings** dialog box was where you could specify how to filter your translation memory matches and specify what field values would be assigned to the new translation units when updating the translation memory.

The logic used to update the translation memory was based on metadata. If you changed a translation in the document that was from the translation memory, the translation unit was not updated but instead a new translation unit was created.

**Figure 2.16 - SDL Trados Translator’s Workbench - Project and Filter Settings**
In SDL Trados Studio, you specify your project and filter settings for the active document in the **Project Settings** dialog box on the following two pages:

- **Filters** - These settings determine what filters applied to the contents of the translation memory. These filters are applied to translations retrieved from the translation memory when lookups are performed.

- **Update** - These settings determine what field values are assigned to new translation units when updating the translation memory.

By default, a new translation is automatically added to the translation memory and assigned the field values specified in your **Update** settings when you confirm a translation during editing. If you change a translation in your document that was taken from the translation memory and then confirm the translation, the translation unit in the document replaces the translation unit in the translation memory. The values that are assigned to the translation unit are merged with the new ones specified in your **Update** settings. If you want to add the changed translation as a new translation unit, before you confirm the segment select **Advanced** tab > **Translation Memory** group > **Add as New Translation** from the Ribbon.

**Figure 2.17 - SDL Trados Studio - Filter and Update Settings**
Working with Terminology

How you work with terminology in SDL Trados Studio is similar to the way you worked with terminology in SDL Trados Translator’s Workbench. Like SDL Trados Translator’s Workbench, you can only work with SDL MultiTerm termbases in SDL Trados Studio, and you can perform the following actions:

- Retrieve terms from the termbase
- Browse the termbase
- Add terms to the termbase.

Retrieving Terms from the SDL MultiTerm Termbase

When you clicked the Open/Get button in SDL Trados Translator’s Workbench, a search in the SDL MultiTerm termbase was performed.

Figure 2.18 - SDL Trados Translator’s Workbench Termbase Match

In SDL Trados Studio, terms found by the search are displayed in the Term Recognition window where you can then choose which one to insert into the current segment. Searches are performed on source language terms only.

A search in the termbase is performed when a segment becomes the active segment. This happens when you place your cursor in a new segment or when your cursor is automatically placed in a segment after confirming a previous segment. If you have automatic row activation turned off, select Home tab > Navigation group > Activate Row to make it the active segment. When a search is performed:

- The term that has been found is highlighted by a red bracket in the source segment and the term translations are displayed in the Term Recognition window.
In the example below, the term, *Road Safety* has been found in the termbase with one translation. To insert the term translation into the target segment, select the translation, *Verkehrssicherheit*, in the **Term Recognition** window and click **Save**.

**Figure 2.19 - .SDL Trados Studio Termbase Match**

You can also manually search for a term in the **Termbase Search** window.

1. Click the **Termbase Search** tab to display the **Termbase Search** window.

**Figure 2.20 - SDL Trados Studio Termbase Search**

2. Type the term you want to search for in the box at the top of the window and press [ENTER]. In the example above, *photo printer* was entered and one translation has been found.
You can then do the following:

- Select the term translation, Fotodrucker and click to insert the term into the source segment.

- Click and the term entry is displayed in the Termbase Viewer window.

Browsing and Adding Terms

You can browse terms and add terms in the Termbase Viewer window. To display this window, do one of the following:

- Select View tab > Information group > Termbase Viewer. The terms from the default termbase are listed here in alphabetical order.

- Select a term in the Term Recognition or Termbase Search window and click .

- Highlight a term in the Editor window and right-click and select Add Term from the shortcut menu. A new entry is displayed in the Termbase Viewer window.

Figure 2.21 - SDL Trados Studio Termbase Viewer Window

Choose a layout for the Entry Pane
Choose an input model adding terms
Edit and save termbase entries

Browse Pane
Entry Pane
Working with Tags

In SDL Trados TagEditor, you were able to choose whether tag text was displayed fully, partially or not at all by clicking the tag text buttons on the TagEditor toolbar.

*Figure 2.22 - Change Tag Display in SDL Trados TagEditor*

By default, SDL Trados Studio settings specify that recognized formatting tags are hidden, therefore when you insert commonly used tags from the QuickInsert group on the Home tab or by another method, the tags remain hidden and instead the text is formatted in the style in the Editor window. For example, text that is tagged as bold is displayed in bold with no tags.

*Figure 2.23 - Recognized Tag Display in SDL Trados Studio*

You can set the Formatting display style option in the Options dialog box to show or hide commonly recognized tags, such as bold and italics, for example.

The same tag display options that were in SDL Trados TagEditor are available from the Editor view > View tab > Options group. By default, tag text is only partially displayed.

*Figure 2.24 - Change Tag Display in SDL Trados Studio*
Translatable Attribute Tags

The way that translatable attribute tags are treated in SDL Trados Studio is different than how they were treated in SDL Trados TagEditor. In SDL Trados TagEditor, a translatable attribute tag was split into three parts and was displayed in a segment that contained other text. For example, an image with tooltip text (ALT Attribute) appeared in the following way.

Figure 2.25 - SDL Trados TagEditor - Translatable Attribute

Part 1: Tag
Part 2: Translatable Text (Tooltip)
Part 3: Tag

In SDL Trados Studio, a translatable attribute tag is split into a separate segment from other text in the document. The new way of segmenting this tag allows you to reuse the translation no matter where it occurs. This has an impact on leverage against upgraded translation memories because it segments differently. For more information on segmentation, see Upgrading Segmentation Rules on page 5-6.

Figure 2.26 - SDL Trados Studio

Part 2: Translatable Text (Tooltip)
Inserting Tags

In SDL Trados TagEditor, tags were classified as placeables. You inserted them from the Tags toolbar or used the placeable buttons on the Workbench toolbar.

![Figure 2.27 - Placeables Buttons in SDL Trados TagEditor](image)

In SDL Trados Studio tags are classified as a type of recognized tokens. There are a variety of ways to apply the correct tag formatting to your translations in SDL Trados Studio. You can insert tags using your mouse or your keyboard. The following instructions describe how to apply italic formatting to text in your target language segment using your mouse or by using keyboard shortcuts.

**To Insert italic tags using your mouse:**

1. Click inside the target segment where you want the italics formatting to be applied.
2. Place the cursor over the source segment text that has the italics formatting and press [CTRL]. The formatted text is highlighted in gold.

   ![Italic text](image)

3. With the [CTRL] key depressed, mouse-click on the formatted text in the source segment text. The formatting tag pair is inserted into the target segment at the point where the cursor is located. Click inside the tag pair and start typing.

**NOTE**

You can also insert tags from the QuickInsert group in the Home tab of the Editor view and copy and paste tags from the source and target segments. In addition, you can create custom QuickInsert tags.

![Figure 2.29 - QuickInsert group in SDL Trados Studio](image)
To insert italic tags using your keyboard and the QuickPlace drop-down list:

1. When the cursor is at the point where you want to type text formatted in italics in the target segment, press [CTRL]+[.]. The QuickPlace drop-down list is displayed below the target segment. Depending on your settings, this list shows sample text with formatting applied or a list of tags from the source segment.

   The example of the QuickPlace drop-down list on the left shows sample text formatted in italics and in bold. The second example of the QuickPlace drop-down list on the right, shows how the bold and italic tags may display if you change your default tag display settings. There is more than one choice on the lists because the source segment has text formatted in both of these styles.

2. Press [ENTER] or [TAB] to start applying the formatting or to insert the italics tag into the target segment. If you selected an italics tag, a ghost tag is also inserted.

   TIP
   A ghost tag is a marker tag that is automatically added to a segment when the segment contains an incomplete tag pair. For example, if you delete a tag that is one half of a pair, the system will automatically display a ghost tag until you replace the missing tag. Ghost tags only occur in tag pairs, as only tag pairs require a beginning and an end tag to function correctly. A ghost tag looks like a grayed-out version of an ordinary tag. You cannot edit ghost tags but you can restore a ghost tag to a real tag.

3. Continue typing. The italics formatting is applied to the text.

4. When you want the formatting to stop being applied, click [CTRL]+[.] to select the formatted text from the drop-down list again or insert the closing tag of the pair.

For more information on working with tags, refer to the online help in SDL Trados Studio.
Working with Recognized Tokens

Recognized tokens are source document content that has been recognized as:

- content not requiring translation, or
- content which can be automatically localized by applying a translation memory. For example, some dates can automatically be converted to the correct format by applying a translation memory.

In SDL Trados Translator’s Workbench recognized tokens were called placeables and were identified by a blue square-bracket underline. In SDL Trados Studio, recognized tokens are also identified by a blue square-bracket underline in the Translation Memory window.

The previous section described how to insert tags which are a type of recognized tokens. To insert other recognized tokens, such as numbers, variables and dates you can follow the same procedure. The following instructions describe how to insert 20% in to your target segment by using your mouse or by using keyboard shortcuts.

To Insert recognized tokens using your mouse:

1. Click inside the target segment where you want to insert 20%.
2. Place the cursor over 20% in the source segment text and press [CTRL]. The 20% text is highlighted in gold.
3. With the [CTRL] key depressed, mouse-click the 20% in the source segment text. 20% is inserted into the target segment at the point where the cursor is located.

To insert recognized tokens using your keyboard and the QuickPlace drop-down list:

1. When the cursor is at the point where you want to insert 20% in the target segment, press [CTRL]+[.]. The QuickPlace drop-down list of the recognized token from the source segment is displayed below the target segment.
2. Press [ENTER] or [TAB] to insert the 20% into the target segment.
Previewing a Document

In SDL Trados TagEditor there are various previews available that allow you to look at how the text will appear when you generate the translated document. You have three preview modes: bilingual, source and target.

![Bilingual Preview in SDL Trados TagEditor](image)

There are three types of preview in SDL Trados Studio:

- Preview in the **Preview Window** - Displays the document in the **Preview** window in the **Editor** view.

- Preview in the Native Application - Displays the document in the application in which it was originally created. The applications available to preview the document depend on what settings are specified in your file filters and what applications are installed on your machine.

- Print Preview - Displays the document as a bilingual SDL XLIFF file in a web browser. The source and target text is displayed side-by-side. When you preview the document you can also print it from your web browser.

Like SDL Trados TagEditor, you can choose to preview the document source or target text or you can display source and target text side-by-side.
Real-time Preview

You can also select to preview in real time. If you select this option, the translation preview is updated to reflect the changes as you type. This update occurs every time you confirm a segment. The currently active segment is highlighted in the Preview window. If you click on the active segment in the preview, your cursor is automatically placed in the active segment in the document. For more information, refer to the online help in SDL Trados Studio.

NOTE

Real-time preview may not be available for all file types.

Figure 2.32 - Real-time Preview in SDL Trados Studio
Confirming a Segment

When you have finished translating a segment you should confirm the segment to indicate that the translation is complete. To confirm the translation, place your cursor in the translated segment and click the Confirm (Translated) button from the Home tab > Segment Actions group or press [CTRL] + [ENTER]. When you confirm a translation:

- The segment status is changed to Translated and the following icon is displayed in the segment status column: 🍃
- The translation is automatically added to the translation memory. If you are using a project translation memory, the translation is added to the project translation memory and not the main translation memory.
- The translation can be viewed in the Preview window.
- Segment verification is performed. Segment verification errors are displayed in the Messages window.
- Studio automatically places your cursor in the next segment, skipping all locked segments.

**NOTE**

By default, when the system applies a 100% translation memory match to a segment, the segment is automatically confirmed. This is an optional setting which is controlled from the Options dialog box.

When the status of every segment in a document is changed to Translated, the status of the document changes to Translated.
Open a File for Review

In SDL Trados Studio you can also open a file for review. When you open a file for review the screen layout in the **Editor** view changes to the review layout and the list of statuses available to apply to segments changes to show review statuses only.

In the Editor window, the source language segments are displayed on the left and target language segments on the right. The segment status column in between the source and target segments contains information about the target segment status, for example whether the translation has been confirmed.

**Figure 2.33 - Open a File for Review in SDL Trados Studio**
Verification

SDL Trados Translator’s Workbench had a series of verification plug-ins that allowed you to verify or validate the tag content of your target files and run quality assurance checks. These verifications have been enhanced for SDL Trados Studio. In addition, some of the verifiers can now be configured for each individual file type.

To perform verification on:

- a segment, confirm the segment.
- an individual file when you have finished translating a file, go to Review tab > Quality Assurance group > Verify in the Editor view.
- a group of project files, select Home tab > Batch Tasks in the Projects or the Files view and click Verify Files from the Batch Tasks drop-down menu.

Verification errors for segments or individual files are displayed in the Messages window in the Editor view of SDL Trados Studio.

The following verification types are included in SDL Trados Studio:

<table>
<thead>
<tr>
<th>Verifier</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tag Verification</td>
<td>Tag verification compares the tag content of target material with the tag content of the original source material and identifies any changes that were made. Changes in the target material are acceptable provided that the syntax of tags remains intact and that the translated document can be converted back to its original format. Tag verification helps to ensure that only acceptable changes are made. The settings for this verifier are defined for each individual file type.</td>
</tr>
</tbody>
</table>
Settings for verification are defined under **File > Options > Verification**.

**Figure 2.35 - Verify Settings in SDL Trados Studio**

<table>
<thead>
<tr>
<th>Verifier</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>QA Check 3.0</td>
<td>QA Checker 3.0 incorporates a suite of quality assurance checks. The checks are broken down into the following areas: Segment Verification, Segments to Exclude, Punctuation, Numbers, Regular Expressions, Word List, Inconsistencies, Trademark Check and Advanced.</td>
</tr>
<tr>
<td>Terminology Verifier</td>
<td>Terminology Verifier checks your current document to ensure that the target terms contained in the SDL MultiTerm termbase have been used during translation or to verify whether forbidden terms have been used.</td>
</tr>
</tbody>
</table>
Clean Up vs. Finalize

When you have finished translating a document, the source and target segments are still stored together in the document. In SDL Trados Translator’s Workbench you used the Clean Up command to generate target translation of the files in their native format and to update the translation memory. Alternatively, you could have used the Save Target As command in SDL Trados TagEditor which does not update the translation memory.

In SDL Trados Synergy, you used the Finalize command to generate the target translations and update the translation memory for one or more files at the same time.

In SDL Trados Studio, you can:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Finalize</strong></td>
<td>Generates the target translations and updates the translation memory for one or more files at the same time. Right-click on the project in Projects or right-click on the selected files in Files view select Batch Tasks &gt; Finalize from the shortcut menu.</td>
</tr>
<tr>
<td><strong>Save Target As</strong></td>
<td>Generates a target translation for a single file in the Editor view. Select File &gt; Save Target As from the menu.</td>
</tr>
<tr>
<td><strong>Export Files</strong></td>
<td>Generates a target translation for a group of files at any point in the project lifecycle. Right-click on the project in Projects or right-click on the selected files in Files view select Batch Tasks &gt; Finalize from the shortcut menu.</td>
</tr>
</tbody>
</table>
Figure 2.36 - Finalize or Export Files
CREATING AND MANAGING TRANSLATION MEMORIES

In SDL Trados Translator’s Workbench, you created and maintained translation memories. In SDL Trados Studio, you create and maintain translation memories in the Translation Memories view. This view contains the following components:

- Navigation pane, where you can see the file and server-based translation memories that are currently open and navigate between them. You also see language resource templates.
- Tabs and groups containing maintenance tools.
- TM side-by-side editor window, where you perform maintenance on your translation memories.
- Search Details window, where you create and apply filters to your translation memories.
- Field Values window, where you view and edit field values for the selected translation unit.
Creating a Translation Memory

In SDL Trados Translator’s Workbench when you created translation memories, you specified the language, system fields and general details.

Figure 2.37 - Creating a Translation Memory in SDL Trados Translator’s Workbench
In SDL Trados Studio, to create a translation memory in the Translation Memories view:

- Select File > New > Translation Memory or click Create and select File-based Translation Memory on the Translation Memory and Automated Translation page to create a file-based translation memory. The New Translation Memory wizard is displayed.

- Select File > New > Server-based Translation Memory or click Create and select Server-based Translation Memory on the Translation Memory and Automated Translation page to create a server-based translation memory. The New Server-based Translation Memory wizard is displayed.

Figure 2.38 - New File-based Translation Memory Wizard in SDL Trados Studio

Settings that you defined after creating a translation memory in SDL Trados Translator’s Workbench are now included in the creation process in SDL Trados Studio. You can specify the following in the New Translation Memory/New Server-based Translation Memory wizard:

- The name, location and languages of the translation memory.

- The fields for the translation units in the translation memory, and translation memory settings.

- The language resource template. You can create or modify language resource lists. These lists are used in conjunction with the segmentation rules in translation memory processing and to identify untranslatable content.
Editing a Translation Memory Setup

In SDL Trados Translator’s Workbench you edited translation memory settings in the **Setup** dialog box:

**Figure 2.39 - Translation Memory Setup in SDL Trados Translator’s Workbench**

In SDL Trados Studio you edit translation memory settings in the **Translation Memory Settings** dialog box. To display this dialog box, select the translation memory that you want to edit settings for from the navigation tree in the **Translation Memories** view and then select **Home** tab > **Tasks** group > **Settings**.
You can edit and view the following sections:

- **[TM Name]** - This is where you can view general details of the translation memory, for example, name and source language. You can also modify the translation memory description.

- **Language Pairs** - This is where you can view which language pairs are in the translation memory. This page is only displayed for server-based translation memories that are multilingual and can contain more than one language pair.

- **Fields and Settings** - This is where you can view existing fields and create additional fields in the translation memory. You can also specify translation memory settings.

- **Language Resources** - This is where you can modify language resource lists in your translation memory. These lists are used in conjunction with the segmentation rules in translation memory processing and are also used to identify untranslatable content.

- **Access Rights** - This is where you can protect file-based translation memories by defining passwords that are linked to translation memory maintenance or a users rights.
Performance and Tuning - This is where you can use different tools to improve the performance of server-based translation memories searches (on the selected translation memory). This does not apply to file-based translation memories.
Importing and Exporting

In SDL Trados Translator’s Workbench you imported and exported translation memory data from the File menu.

In SDL Trados Studio, you can import translation memory data using the Import wizard. To display this wizard, select the translation memory for which you want to import data from the navigation tree in the Translation Memories view and then selecting Home tab > Tasks group > Import.

You can assign field values to newly imported translation units. For example, you may want to indicate the type of document the imported translations are for, such as, Software or Online Help.
Depending on the source you import data from, you can apply a filter so that only translation units that match the conditions of the filter are imported. Filters are based on the field values assigned to the translation units that are being imported.

If imported translation units have fields associated with them that are not part of the translation memory, there are several different options on how to import those translation units. For example, you could specify to only import translation units that contain the same fields as the translation memory you are importing into or you could add the fields from the imported translation units to the translation memory.
## Translation Memory Maintenance

In SDL Trados Translator’s Workbench you performed maintenance on your translation units in your translation memory in the following ways:

- A spot-editing feature allowed you to edit and delete individual translation units. You accessed this feature from the maintenance, concordance and translation memory windows in SDL Trados Translator’s Workbench.

- The **Maintenance** command provided access to the **Translation Memory Maintenance** dialog box where you edited and deleted the contents of your translation memory at translation unit and global level.

*Figure 2.44 - Translation Memory Maintenance Window in SDL Trados Translator’s Workbench*
In SDL Trados Studio, you can perform maintenance directly in the **Translation Memories** view. You can use the **Search Details** window to find the translation units that you want to edit. The translation units are displayed in the TM side-by-side editor.

**Figure 2.45 - TM Side-by-side Editor in SDL Trados Studio**

To change the segment text, simply click in the segment and start typing. Use the **Save** group on the **Home** tab in the **Translation Memories** view to:

- Mark a translation unit for deletion.
- Save (Commit) changes to the translation memory or discard or undo your changes as required.

Use the **Field Values** window to assign custom field values to the translation unit selected in the TM side-by-side Editor.
This chapter gives an introduction of SDL Trados Studio to SDLX users. Topics include:

- Overview
- Defining Default Settings
- Creating and Managing Projects
- Translating Files
- Creating and Managing Translation Memories
OVERVIEW

There are some differences between the way that SDLX worked compared to SDL Trados Studio. The purpose of this chapter is to help the experienced SDLX users understand the differences and adapt to them quickly. For a more complete introduction to working with SDL Trados Studio, see the online help installed with SDL Trados Studio.

SDLX is a translation management tool. It is made up of multiple modules which allow you to translate a document, create a project, align files, analyze files, track projects, split files and create and manage termbases.

SDL Trados Studio is an integrated project-based translation management system and translation editor tool. It enables you to create projects, centralize data management, manage and create translation memories, and translate and review documents.

This chapter goes through the difference between projects in SDLX and SDL Trados Studio, how the translating environment has changed and where to go to perform translation memory maintenance.

NOTE

This chapter is based on settings in the SDLX profile. If you have not selected the SDLX profile, the behavior described in this chapter may vary. For more information about the default settings selected in the SDLX profile, see SDLX Profile Settings on page 3-11.

Workflows

These are some of the potential workflows that you can follow in SDL Trados Studio. These are workflows that you control and can be changed to suit your needs.

- Single-file Translation Workflow
- Project Package Translation: Offline Workflow
- GroupShare Project Translation: Online Workflow
Single-File Translation Lifecycle

The following diagram shows a typical workflow if you are translating a single file in SDL Trados Studio:
Project Package Translation: Offline Workflow

This is an example of one way in which you can work with projects through the use of project packages:
Recommended Package Use

There are two recommendations about how you work with packages in your workflow:

- Always create a package for every task you want to be completed.
- Always create a return package for every task you have completed and send to the person who gave you the task.

See Assigning Work to Project Participants on page 3-19 for detailed information about packages.

Alternative Workflows

**Alternative Package Workflow**

This is another way in which you can work with packages in a workflow.

- The Project Manager creates a project.
- The Project Manager creates a project package and sends to the translator for translation.
- The Translator opens the package and translates the files.
- The Translator creates a return package and sends it to the Project Manager.
- The Project Manager creates a project package and sends it to the Reviewer.
- The Reviewer opens the package and reviews the files.
- The Reviewer creates a return package and sends it to the Project Manager.

**Alternative Project Workflow**

This workflow example shows how an individual Translator can benefit from using projects.

- The Translator creates a project for each customer and never runs the Finalize batch task.
- When the Translator receives new files, they switch to the source language, add the new files and then prepare with the Prepare batch task.
- The Translator switches back to the target language and translates the files.
- The Translator saves the finished target files using the File > Save Target As instead of running the Finalize batch task on the files.
- If the Translator is using a Project TM, they can run the Update Main Translation Memories batch task.
**GroupShare Project Translation: Online Workflow**

This workflow stores the GroupShare project on the Project Server (This is part of the server component of Studio called SDL GroupShare) and assumes that all team members in the workflow have access to the Project Server. It eliminates the need for using project packages as all team members can simply open the GroupShare project to access their work from the server.

**NOTE**

For more information about using Studio in an SDL GroupShare environment, see the SDL Trados Studio Help.
Switchboard vs. Views

SDLX was split into different areas of functionality that were accessed through the SDLX Switchboard. To display an area of functionality, you clicked a button on the Switchboard.

In SDL Trados Studio the functionality is accessed through views. To display a view, click the button that bears the name of the view or the icon for that view. The view navigation buttons appear at the bottom of the navigation pane.

SDL Trados Studio has a Welcome, Projects, Files, Editor and Translation Memories view.
Figure 3.2 - SDL Trados Studio Views
The SDL Trados Studio views function in the following way:

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
</table>
| Welcome    | This is where you can:  
  - Access popular Help videos and documentation  
  - Read the latest SDL Trados Studio news.  
You can also access commands to do the following:  
  - New Project  
  - Translate Single Document  
  - Open Package  
  - Open GroupShare Project  
  - Access your SDL Language Cloud account information and manage subscriptions to Language Cloud machine translation engines  
Selecting any of these commands will switch you to the appropriate view in SDL Trados Studio or open another application where you can perform the action. |
| Projects   | This is where you view and work with projects. You can select a project to view detailed project and file information and track project and file status. |
| Files      | This is where you work with project files. From here you can:  
  - Open files for translation, review or sign-off  
  - Perform batch processing on files.  
  - Create packages from the project files.  
You can also view word counts and translation progress for these files. |
<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reports</td>
<td>This is where you view project reports. The reports provide detailed translation analysis figures which feed directly into the project planning and budgeting process.</td>
</tr>
<tr>
<td>Editor</td>
<td>This is where documents are translated and reviewed.</td>
</tr>
<tr>
<td>Translation Memories</td>
<td>This is where you create and manage translation memories.</td>
</tr>
<tr>
<td>Alignment</td>
<td>This is where you review and correct the result of the alignment that Studio performs automatically when you align existing translated documents. This view is only available when you open an alignment result file (*.sdlalign).</td>
</tr>
</tbody>
</table>
DEFINING DEFAULT SETTINGS

You can define default settings for use in your translation in the Options dialog box. These settings are used if you open a single file for translation and are stored in the default project template when you create a project. Select File > Options to display the Options dialog box.

Figure 3.3 - Options Settings in SDL Trados Studio

SDLX Profile Settings

If you selected the SDLX profile, similar settings that were selected by default in SDLX are selected in SDL Trados Studio. Below are some of the key settings included in the profile. If you prefer to manually define these settings, complete the steps below:

1. Select File > Options from the Ribbon. The Options dialog box is displayed.
2. Select Editor from the navigation tree.
Under **Opening Files**, select **Automatically copy source content to target cells when opening document**. When this option is selected, the content of source segments is automatically copied to target segments when you open a document for the first time. This is useful if you are performing a single file translation and have not pre-translated the file.

3 Select **Language Pairs > All Language Pairs > Batch Processing > Pre-translate Files** from the navigation tree.

Under **After Applying Translations**, select **Copy source to target if no match found**. This is useful if you have pre-translated a document and want the source text where matches were not found to be copied to the target cells.

4 Click **OK** to save your changes and close the **Options** dialog box.

**NOTE**

For information on how to set up your default translation memories and termbases before starting a new translation, see **Single File Translation** on page 3-22.
CREATING AND MANAGING PROJECTS

In SDLX you could create a project with a group of files. The action of creating a project was used primarily to pre-translate files and convert them to ITDs in a batch. The project was also used for creating project translation memories and merging translations.

SDL Trados Studio is a project-based translation management system. All files in SDL Trados Studio are translated and managed as part of a project. A project may contain a single file or many files for translation into one language or several languages. It may also contain reference material, translation memories, termbases and instructions for translators.

**NOTE**

When you open a single file for translation using the **Translate Single Document** command in SDL Trados Studio, a project is automatically created.

In SDLX you clicked the **Project Wizard** button on the SDLX switchboard to create a new project. In SDL Trados Studio click the **New Project** button in any view to create a new project.

*Figure 3.4 - SDLX and SDL Trados Studio*

SDLX Project Wizard Button

SDL Trados Studio New Project Button
SDLX gave you an option to automate the process of creating projects using a template called a Project Profile.

Figure 3.5 - Project Profiles in SDLX

SDL Trados Studio however, provides you with a default template on which to base your project. This can significantly speed up the time it takes to create a project. The default template stores your default settings specified in the application. You can specify these default settings and file filters in the Options dialog box. The default template is automatically selected when you create a new project. These settings can be modified as required when you create a project.
SDL Trados Studio provides you with the same ability to specify translation memory, pre-translation and batch processing settings that SDLX provided when you created a project. In SDLX this information was specified in the **SDL Project Wizard**. In SDL Trados Studio this information is specified in the **New Project** wizard.

**NOTE**

In SDL Trados Studio, you can modify project settings you specified after the project is created. You modify these settings in the **Project Settings** dialog box.
Figure 3.7 - Project Settings in SDL Trados Studio
Create Project Translation Memory

In SDLX you could create a project translation memory using the Create Project TM wizard. The project translation memory contains only the translation memory entries that are relevant to the project ITD files in SDLX.

![Create Project TM in SDLX](image)

In SDL Trados Studio the process of creating a project translation memory is included in the New Project wizard.

**NOTE**

When a translator updates the translation memory during translation, the project translation memory is updated when a segment is confirmed. The project manager can then decide if those translations are updated to the main translation memory at the end of the project.
Figure 3.9 - Creating a Project TM in SDL Trados Studio
Assigning Work to Project Participants

In SDLX if you wanted to send files to another person in the workflow, you had to email the files and associated information. In SDL Trados Studio you can send project packages to exchange this information. A project package is a single zipped file that contains all of the files that need to be sent to a project team member in order for them to commence work on the project. It can contain:

- Project files: target language files and reference files
- The project translation memory
- Connection details for a server-based translation memory
- Project settings.

Once the project package is created, you can click the **Send Packages by Email** button at the end of the **Create Project Package** wizard to email to the team member who will be working on the project files. You can create packages in the **Projects** and **Files** view by selecting the **Create Project Package** option from the **Packages** group.

**NOTE**

If you are working with a GroupShare project, you can access work that is assigned to you by opening the project in Studio. For more information, refer to the online Help in Studio.

**Figure 3.10 - Create Project Package Wizard in SDL Trados Studio**
TRANSLATING FILES

There are some major differences in how you translated a file in SDLX to how you translate a file in SDL Trados Studio. However, some of the basic actions have stayed the same. For example, you still confirm a translation once it is complete. The following are the areas of functionality in which the differences between SDLX and SDL Trados Studio are described:

- Open a File for Translation. See “Opening a File for Translation” on page 3-21.
- Bilingual Files. See “ITD Files vs. SDL XLIFF Files” on page 3-26.
- Retrieving translations from the translation memory. See “Working with Translation Memories” on page 3-30.
- Looking up Terminology. See “Working with Terminology” on page 3-35.
- Working with Tags. See “Working with Tags” on page 3-38.
- Preview translations. See “Previewing a Document” on page 3-44.
- Confirming translations. See “Confirming a Segment” on page 3-46.
Opening a File for Translation

When using SDLX, you opened a file from a project in SDL Edit or started a new translation.

In SDL Trados Studio, you can open a single file for translation or open a file for translation from within a project.

Alternatively, you can open a file for translation by drag-and-dropping it from your computer into the Editor Navigation Pane.

**NOTE**

In SDL Trados Studio, the rules used to segment your document are stored in the translation memory that you selected when opening your document or when creating your project. For more information, see *Translation Memory Segmentation* on page 3-58.
Single File Translation

Before you open a single file for translation in SDL Trados Studio, SDL recommends that you can define your default:

- Translation Memories and Termbases
- Settings

**NOTE**
- In SDL Trados Studio, you can have more than one translation memory open at a time during translation.
- You can also connect to automated translation providers (Machine Translation) and add AutoSuggest dictionaries which offer text suggestions while you translate. For more information, refer to the online help in SDL Trados Studio.

Translation memories, termbases and settings are defined in the Language Pairs section of the Options dialog box.

**Figure 3.12 - SDL Trados Studio Default Settings**
Typically, you edit settings, and select translation memories and termbases at the **All Language Pairs** level. These settings apply to all of the language pairs and then individual exceptions to these settings can be defined for each language pair.

For example, you can change the default fuzzy matching threshold setting to 65% at the **All Language Pairs** level and it will apply to all translation memories for all language pairs. However, if you want English to German to use a different fuzzy matching threshold, you can change it at the individual language pairs level to 75%.

The default translation memories and termbases that you define here are automatically opened and your default settings applied when you start a new translation.

**To set up your translation defaults:**

For example, if you want to set up default translation memories, termbases and translation settings for **English (United States) to German (Germany)** follow these instructions:

1. Select **File > Options** from the Ribbon. The **Options** dialog box is displayed.

2. To set up your default translation memory:

   - Select **Language Pairs > All Language Pairs > Translation Memory and Automated Translation** from the navigation tree. The **Translation Memory and Automated Translation** page is displayed on the right.

   - Click **Add** and select **File-based Translation Memory** from the drop-down list to add a local translation memory. The **Open Translation Memory** dialog box is displayed.

   - Select an **English (United States) - German (Germany)** translation memory and click **Open**. The translation memory is added to the list. Only .sdltm translation memories are supported.

   - **NOTE**

     For information on migrating your translation memories to .sdltm format, see Chapter 5 - Upgrading Legacy Translation Memories.

   - If your setup does not include the language pairs specified in the selected translation memory, **English (United States) - German (Germany)**, the **Add Supported Language Pairs** dialog box is displayed where you can select the language pair and click **OK** to add it to the setup.
To set up your default termbase:

1. Select Language Pairs > All Language Pairs > Termbases from the navigation tree. The Termbases page is displayed on the right.
2. Click Add. The Select Termbases dialog box is displayed. If the termbase that you want to use if not displayed, click Browse to locate a local termbase. The termbases is added to the list in the Select Termbases dialog box.
3. Click OK. The termbase is added to the list.

To open a single file for translation:

1. Click File > Open > Translate Single Document in any view. The Open Document dialog box is displayed.
2. Select the file which you want to translate and click Open.

The Open Document dialog box is displayed.

Select English (United States) as your Source Language and German (Germany) as your Target Language.

If you already defined your default translation memories for this language pair in the previous section, the default translation memories are displayed under Translation Memory and Automated Translation. Add and remove translation memories as required.
5 Click OK. The translatable content of the source language document is identified, segmented and placed in an SDL XLIFF file. The file is opened in the Editor window in the Editor view for translating.

When you use the Translate Single Document command, a project is automatically created for the opened file. Your default translation memories and termbases (that you defined in the Options dialog box) are automatically opened. Any settings that you specified in the Options dialog box are also automatically applied. If you want to change these settings for this file, select Home tab > Configuration tab > Project Settings in any view to display the Project Settings dialog box.

Open a File for Translation from a Project

If you are working with projects in SDL Trados Studio, you can open a file for translation from the Files view. In the Files view, right-click on a file and select Open for Translation from the shortcut menu. The file is opened in the Editor view. The translation memories and termbases defined in the project are automatically opened. Any settings that you specified in the project are also automatically applied.

If you want to change the settings, select Project Settings from the Home tab of any view to display the Project Settings dialog box.
ITD Files vs. SDL XLIFF Files

When you created a project in SDLX or when you started a new translation, the file was converted to a bilingual format ITD for translation.

In SDL Trados Studio when you create a project or open a document for translation it is converted to SDL XLIFF, a bilingual format used by SDL Trados Studio. SDL XLIFF stands for SDL XML Localization Interchange File Format. It is an XML based bilingual file format, specially developed for use in localization. It is bilingual because it contains both the source document and the document translation in a single file. When an SDL XLIFF file is displayed in the Editor window in the Editor view, the source document text is displayed on the left of the editor window and the target version of the text is displayed on the right.

When you save an SDL XLIFF file, the .sdlxliff extension is added to the name of the source language document being translated. For example, a source document named Sample.doc would be saved as Sample.doc.sdlxliff. For more information on XLIFF files, refer to http://xml.coverpages.org/xliff.html

**NOTE**

You can also translate ITD files in SDL Trados Studio. For more information, refer to the online help in SDL Trados Studio.
Translating Environment

To translate or review documents in SDLX you used SDL Edit which you accessed by clicking Edit on the SDLX switchboard. When you opened the document in SDL Edit:

- The translatable document was displayed in the top portion of the application.
- The match for of the translation memory was displayed in the bottom half of the application.
- Recognized terms from the currently selected segment are displayed in the TermBase Results window.

Figure 3.13 - Translating Environment in SDLX
In SDL Trados Studio, documents are reviewed and translated in the **Editor** view. This view contains the following components:

- **Navigation pane**, where you can see the documents that are currently open and navigate between them.
- **Tabs and groups containing editing tools.**
- **Editor window** where you perform translation or review.
- **A set of tabbed windows** that appear above the Editor window. These include a translation results window, a term recognition window, a concordance window, a comments window and a messages window.

![Figure 3.14 - Translating Environment in SDL Trados Studio](image-url)
Editor Window

The Editor window in the Editor view is where you translate documents. The bilingual SDL XLIFF document containing the text to be translated and the translation are displayed in the window, side by side. The source language text appears on the left and the target language version on the right. The content of the document is broken down into segments (typically sentences). The target language segments can be edited.

- The first column displays segment numbers. Only one number is displayed for each segment pair as the source and target segments are aligned with each other by default. You can choose not to display segment numbers. The source and target segments can also be worked with as two separate lists.

- Between the source and target segment columns is the segment status column. This column indicates the current translation status of the segment and its translation origin. For example, if the translation is approved and if a 100% match was found in the translation memory for this segment.

- To the right of the target language segments is the document structure column. It displays a code that tells you where in the original document the segment text appears. Hover over the code or click on the code in this column to display a description telling you where the segment appears in the source document.

Figure 3.15 - Translating in SDL Trados Studio
Translating in SDLX vs. Translating in SDL Trados Studio

In SDLX, you clicked in a segment and started to type to start translating a segment.

To start translating in SDL Trados Studio, click inside one of the target segments in the document and simply start typing. This segment becomes the active segment. You can use standard windows text editing functionality when working in SDL Trados Studio.

Working with Translation Memories

When you worked with a translation memory in SDLX, you could retrieve translations from the translation memory and update the translation memory. In SDL Trados Studio, the process of retrieving the translations and updating the translation memory works in a similar way.

Retrieving Translations from the Translation Memory

When you clicked in a segment in SDLX, a lookup in the translation memory was optionally performed. The translation memory match for the segment was displayed in the bottom pane of the application.

Figure 3.16 - SDL Trados Translator's Workbench Translation Memory Match
In SDL Trados Studio, translations found by the lookup are displayed in the **Translation Results** window where you can then choose one to apply to the current segment. Lookups are performed on source language segments only.

A translation memory lookup is performed when a segment becomes the active segment. This happens when you place your cursor in a new segment or when your cursor is automatically placed in a segment after confirming a previous segment. If you have automatic row activation turned off, select **Home** tab > **Navigation** group > **Activate Row** to make it the active segment. When a lookup is performed:

- The best translation memory match is automatically placed in the target segment and the match is also displayed in the **Translation Results** window.

- In the example below, a 100% translation memory match has been found and automatically confirmed. The percentage match **100%** is displayed in the segment status column and the ✅ symbol indicates that the segment is confirmed.

**Figure 3.17 - SDL Trados Studio Translation Memory Match**
Updating the Translation Memory

In SDLX, the **TM Filters** dialog box was where you could specify how to filter your translation memory matches.

*Figure 3.18 - SDLX - Filter Settings*

In SDLX, the **TM Default Field Values** dialog box was where you could specify what field values would be assigned to the new translation units when updating the translation memory.

*Figure 3.19 - SDLX - Update Settings*
In SDL Trados Studio, you specify your project and filter settings for the active document in the **Project Settings** dialog box on the following two pages:

- **Filters** - These settings determine what filters are applied to the contents of the translation memory. These filters are applied to translations retrieved from the translation memory when lookups are performed.

- **Update** - These settings determine what field values are assigned to new translation units when updating the translation memory.

By default, a new translation is automatically added to the translation memory and assigned the field values specified in your **Update** settings when you confirm a translation during editing.

In SDL Trados Studio, updating a translation memory uses the same method that was used in SDLX. If you change a translation in your document that was taken from the translation memory and then confirm the translation, the translation unit in the document replaces the translation unit in the translation memory. The values that are assigned to the translation unit are merged with the new ones specified in your **Update** settings in SDL Trados Studio.

However, in SDL Trados Studio, you can also choose to add a changed translation as a new translation unit. Before you confirm the changed translation segment, select **Advanced** tab > **Translation Memory** group > **Add as New Translation** from the Ribbon to add it as a new translation unit.

**Figure 3.20 - SDL Trados Studio - Filter and Update Settings**
Viewing Differences in the Source Segments

In SDLX if you wanted to view the differences between the source segment text in the document and the source segment match in the translation memory, you had to display the **TM Difference View** window.

**Figure 3.21 - Source Difference in SDLX**

In SDL Trados Studio the difference between source segments is automatically displayed in the **Translation Memory** window along with the translation memory match. The blue font indicates that the text appears in the document and not in the translation memory match. The red font indicates that the text appears in the translation memory source segment and not in the source segment of the document.

**Figure 3.22 - Source Difference in SDL Trados Studio**
Working with Terminology

How you work with terminology in SDL Trados Studio is similar to the way you worked with terminology in SDLX. However in SDL Trados Studio, you can only work with SDL MultiTerm termbases. You can perform the following actions in SDL Trados Studio:

- Retrieve terms from the termbase
- Browse the termbase
- Add terms to the termbase.

Retrieving Terms from the SDL MultiTerm Termbase

When you clicked the Open/Get button in SDL Trados Translator's Workbench, a search in the SDL MultiTerm termbase was performed.

*Figure 3.23 - SDL Trados Translator's Workbench Termbase Match*

In SDL Trados Studio, terms found by the search are displayed in the Term Recognition window where you can then choose which one to insert into the current segment. Searches are performed on source language terms only.

A search in the termbase is performed when a segment becomes the active segment. This happens when you place your cursor in a new segment or when your cursor is automatically placed in a segment after confirming a previous segment. If you have automatic row activation turned off, select Home tab > Navigation group > Activate Row to make it the active segment. When a search is performed:

- The term that has been found is highlighted by a red bracket in the source segment and the term translations are displayed in the Term Recognition window.
In the example below, the term, Road Safety has been found in the termbase with one translation. To insert the term translation into the target segment, select the translation, Verkehrssicherheit, in the Term Recognition window and click .

Figure 3.24 - SDL Trados Studio Termbase Match

You can also manually search for a term in the Termbase Search window.

1. Click the Termbase Search tab to display the Termbase Search window.

Figure 3.25 - SDL Trados Studio Termbase Search

2. Type the term you want to search for in the box at the top of the window and press [ENTER]. In the example above, photo printer was entered and one translation has been found.
You can then do the following:

- Select the term translation, *Fotodrucker* and click to insert the term into the source segment.

- Click and the term entry is displayed in the *Termbase Viewer* window.

### Browsing and Adding Terms

You can browse terms and add terms in the *Termbase Viewer* window. To display this window in the *Editor* view, do one of the following:

- Select *View* tab > *Information* group > *Termbase Viewer* from the Ribbon. The terms from the default termbase are listed here in alphabetical order.

- Select a term in the *Term Recognition* or *Termbase Search* window and click .

- Highlight a term in the Editor window and right-click and select *Add Term* from the shortcut menu. A new entry is displayed in the *Termbase Viewer* window.
Working with Tags

In SDLX, standard recognized formatting tags were hidden. For example, text that was tagged as bold was displayed in bold with no tags. For other types of tags in SDLX, you were able to choose whether text with tags was highlighted or if the tag text was displayed with a marker, partial text or full text. You could change this setting in the Display Tags dialog box.

By default, SDL Trados Studio settings specify that recognized formatting tags are hidden, therefore when you insert commonly used tags from the QuickInsert group on the Home tab or by another method, the tags remain hidden and instead the text is formatted in the style in the Editor window. For example, text that is tagged as bold is displayed in bold with no tags.

In SDL Trados Studio you can choose to show recognized tags, by selecting a different option from the Formatting display style drop-down list in the Options dialog box.

SDL Trados Studio has similar tag display options to the ones that were available in SDLX. In SDL Trados Studio you can change the tag display from the Editor view using the View tab > Options group. By default, tag text is only partially displayed.
Translatable Attribute Tags

The way that translatable attribute tags are treated in SDL Trados Studio is similar to how they were treated in SDLX. In most cases in SDLX, translatable attributes were put into a separate segment to help to reuse the translation of attributes in other segments. However, this varies depending on what filter was used.

In SDL Trados Studio, a translatable attribute tag is split into a separate segment from other text in the document. The new way of segmenting this tag allows you to reuse the translation no matter where it occurs.

For example an image with tooltip text (ALT Attribute) is displayed in the following way in SDL Trados Studio:

![Figure 3.29 - SDL Trados Studio](image)
Inserting Tags

In SDLX, there were three ways to insert tags. You could:

- Select a word in the target segment containing formatting and type over that word,
- Select standard formatting tags from the toolbar, or
- Use format painting to copy formatting from the source segment to the target segment.

Figure 3.30 - Standard Formatting Tags in SDLX

Figure 3.31 - Format Paint Mode in SDLX

In SDL Trados Studio there are a variety of ways to apply the correct tag formatting to your translations. Like SDLX, in SDL Trados Studio you can still select a word in the target segment containing formatting and type over that word.

You can also insert tags using your mouse or your keyboard. The following instructions describe how to apply italic formatting to text in your target language segment using your mouse or by using keyboard shortcuts.

To Insert tags using your mouse:

Inserting tags in SDL Trados Studio using your mouse is similar to format painting in SDLX. However, in SDL Trados Studio you do not need to be in Format Paint Mode.

1. Click inside the target segment where you want the italics formatting to be applied.

2. Place the cursor over the source segment text that has the italics formatting and press [CTRL]. The formatted text is highlighted in gold.

3. With the [CTRL] key depressed, mouse-click on the formatted text in the source segment text. The formatting tag pair is inserted into the target segment at the point where the cursor is located. Click inside the tag pair and start typing.
NOTE

In SDL Trados Studio you can insert tags from the QuickInsert group in the Home tab of the Editor view and copy and paste tags from the source and target segments. In addition, you can create custom QuickInsert tags.

Figure 3.32 - QuickInsert Toolbar in SDL Trados Studio

To insert tags using your keyboard and the QuickPlace drop-down list:

1. When the cursor is at the point where you want to type text formatted in italics in the target segment, press [CTRL]+[,]. The QuickPlace drop-down list is displayed below the target segment. Depending on your settings, this list shows sample text with formatting applied or a list of tags from the source segment.

   The example of the QuickPlace drop-down list on the left shows sample text formatted in italics and in bold. The second example of the QuickPlace drop-down list on the right shows how the bold and italic tags may display if you change your default tag display settings. There is more than one choice on the lists because the source segment has text formatted in both of these styles.

   The first type of formatting from the source segment is selected automatically. In the source segment, the text formatted by the tag is highlighted.

2. Press [ENTER] or [TAB] to start applying the formatting or to insert the italics tag into the target segment. If you selected an italics tag, a ghost tag is also inserted.

TIP

A ghost tag is a marker tag that is automatically added to a segment when the segment contains an incomplete tag pair. For example, if you delete a tag that is one half of a pair, the system will automatically display a ghost tag until you replace the missing tag. Ghost tags only occur in tag pairs, as only tag pairs require a beginning and an end tag to function correctly.
ghost tag looks like a grayed-out version of an ordinary tag. You cannot edit ghost tags but you can restore a ghost tag to a real tag.

3 Continue typing. The italics formatting is applied to the text.

4 When you want the formatting to stop being applied, click [CTRL]+[.] to select the formatted text from the drop-down list again or insert the closing tag of the pair.

For more information on working with tags, refer to the online help in SDL Trados Studio.

Working with Recognized Tokens

Recognized tokens are source document content that has been recognized as:

- content not requiring translation, or
- content which can be automatically localized by applying a translation memory. For example, some dates can automatically be converted to the correct format by applying a translation memory.

In SDLX, recognized tokens were called placeables and were not distinguished from translatable text. However, in SDL Trados Studio, recognized tokens are identified by a blue square-bracket underline in the Translation Memory window.

The previous section described how to insert tags which are a type of recognized tokens. To insert other recognized tokens, such as numbers, variables and dates you can follow the same procedure. The following instructions describe how to insert 20% in to your target segment by using your mouse or by using keyboard shortcuts.

To Insert recognized tokens using your mouse:

1 Click inside the target segment where you want to insert 20%.

2 Place the cursor over 20% in the source segment text and press [CTRL]. The 20% text is highlighted in gold. 20%
3 With the [CTRL] key depressed, mouse-click the 20% in the source segment text. 20% is inserted into the target segment at the point where the cursor is located.

To insert recognized tokens using your keyboard and the QuickPlace drop-down list:

1 When the cursor is at the point where you want insert 20% in the target segment, press [CTRL]+[,] A drop-down list of the recognized tokens from the source segment is displayed below the target segment.

2 Press [ENTER] or [TAB] to insert the 20% into the target segment.
Previewing a Document

In SDLX there were two types of previews available. These previews were accessed by clicking one of the following buttons on the toolbar:

- **View Source** - Preview the source language document.
- **Translation Preview** - Preview how the text will appear when you generate the translated document.

![Figure 3.34 - Translation Preview in SDLX](image)

There are three types of preview in SDL Trados Studio:

- **Preview in the Preview Window** - Displays the document in the Preview window in the Editor view.

- **Preview in the Native Application** - Displays the document in the application in which it was originally created. The applications available to preview the document depend on what settings are specified in your file filters and what applications are installed on your machine.

- **Print Preview** - Displays the document as a bilingual SDL XLIFF file in a web browser. The source and target text is displayed side-by-side. When you preview the document you can also print it from your web browser.

Like SDLX, you can choose to preview the document source or target text or you can display source and target text side-by-side.
Real-time Preview

You can also select to preview in real time. If you select this option, the translation preview is updated to reflect the changes as you type. This update occurs every time you confirm a segment. The currently active segment is highlighted in the Preview window. If you click on the active segment in the preview, your cursor is automatically placed in the active segment in the document. For more information, refer to the online help in SDL Trados Studio.

NOTE

Real-time preview may not be available for all file types.

Figure 3.35 - Real-time Preview in SDL Trados Studio
Confirming a Segment

When you have finished translating a segment you should confirm the segment to indicate that the translation is complete. To confirm the translation, place your cursor in the translated segment and click the **Confirm (Translated) 🍀** button from the **Home** tab > **Segment Actions** group or press [ENTER]. When you confirm a translation:

- The segment status is changed to **Translated** and the following icon is displayed in the segment status column: 🍀

- The translation is automatically added to the translation memory. If you are using a project translation memory, the translation is added to the project translation memory and not the main translation memory.

- The translation can be viewed in the **Preview** window.

- Segment verification is performed. Segment verification errors are displayed in the **Messages** window.

- Studio automatically places your cursor in the next unconfirmed segment, skipping all locked segments.

**NOTE**

By default, when the system applies a 100% translation memory match to a segment, the segment is automatically confirmed. This is an optional setting which is controlled from the **Options** dialog box.

When the status of every segment in a document is changed to **Translated**, the status of the document changes to **Translated**.
Open a File for Review

In SDL Trados Studio you can also open a file for review. When you open a file for review the screen layout in the Editor view changes to the review layout and the list of statuses available to apply to segments changes to show review statuses only.

In the Editor window, the source language segments are displayed on the left and target language segments on the right. The segment status column in between the source and target segments contains information about the target segment status, for example whether the translation has been confirmed.

Figure 3.36 - Open a File for Review in SDL Trados Studio
Verification

SDLX had two types of verification check that allowed you to verify or validate the tag content of your target files, run quality assurance checks and verify the terminology used. Similar verification checks are available in SDL Trados Studio. In addition, some of the verifiers can be configured for each individual file type.

To perform verification on:

- a segment, confirm the segment.
- an individual file when you have finished translating a file, go to Review tab > Quality Assurance group > Verify in the Editor view.
- group of project files, select Home tab > Batch Tasks in the Projects or the Files view and click Verify Files from the Batch Tasks drop-down menu.

Verification errors for segments or individual files are displayed in the Messages window in the Editor view of SDL Trados Studio.
The following verification types are included in SDL Trados Studio:

<table>
<thead>
<tr>
<th>Verifier</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tag Verification</td>
<td>Tag verification compares the tag content of target material with the tag content of the original source material and identifies any changes that were made. Changes in the target material are acceptable provided that the syntax of tags remains intact and that the translated document can be converted back to its original format. Tag verification helps to ensure that only acceptable changes are made. You can define the settings for this verifer under File &gt; Options &gt; Verification &gt; Tag Verifier &gt; Common.</td>
</tr>
<tr>
<td>QA Check 3.0</td>
<td>QA Checker 3.0 incorporates a suite of quality assurance checks. The checks are broken down into the following areas: Segment Verification, Segments to Exclude, Punctuation, Numbers, Regular Expressions, Word List, Inconsistencies, Trademark Check and Advanced.</td>
</tr>
<tr>
<td>Terminology Verifier</td>
<td>Terminology Verifier checks your current document to ensure that the target terms contained in the SDL MultiTerm termbase have been used during translation or to verify whether forbidden terms have been used.</td>
</tr>
</tbody>
</table>

Settings for verification are defined in the Options dialog box under some of the File Types options and under Verification.
Figure 3.38 - Verify Settings in SDL Trados Studio
Create Translation vs. Finalize

When you have finished translating a document, the source and target segments are still stored together in the document. In SDLX you used the:

- **SDL Project Wizard: Create Translations** wizard to generate target translation of the files in their native format for files from a project or individual files.

- **Create Translation** command in SDL Edit for an individual file.

In SDL Trados Studio, there are three different commands you can use to create target translations for one individual file or a group of files. In addition, you can also choose to update the translation memory at the same time.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Finalize</strong></td>
<td>Generates the target translations and updates the translation memory for one or more files at the same time. Right-click on the project in Projects or right-click on the selected files in Files view select <strong>Batch Tasks &gt; Finalize</strong> from the shortcut menu.</td>
</tr>
<tr>
<td><strong>Save Target As</strong></td>
<td>Generates a target translation for a single file in the <strong>Editor</strong> view. Select <strong>File &gt; Save Target As</strong> from the Ribbon in any view.</td>
</tr>
<tr>
<td><strong>Export Files</strong></td>
<td>Generates a target translation for a group of files at any point in the project lifecycle. Right-click on the project in Projects or right-click on the selected files in Files view select <strong>Batch Tasks &gt; Finalize</strong> from the shortcut menu.</td>
</tr>
</tbody>
</table>
Figure 3.39 - Finalize or Export Files

This figure illustrates how to finalize or export files in SDL TRADOS Studio 2014 SP2. The screenshot shows the File Actions menu with options to finalize, analyze, or export files. The highlighted options are 'Finalize', 'Analyze Files', and 'Export Files'.
CREATING AND MANAGING TRANSLATION MEMORIES

In SDLX, you created and maintained translation memories in SDL Maintain. You could also create translation memories in SDL Edit. In SDL Trados Studio, you create and maintain translation memories in the Translation Memories view. This view contains the following components:

- Navigation pane, where you can see the file and server-based translation memories that are currently open and navigate between them. You also see language resource templates.
- Tabs and groups containing maintenance tools.
- TM side-by-side editor window, where you perform maintenance on your translation memories.
- Search Details window, where you create and apply filters to your translation memories.
- Field Values window, where you view and edit field values for the selected translation unit.
Creating a Translation Memory

In SDLX when you created translation memories, you specified the name of the translation memory and which user was creating the translation memory. The languages contained in the translation memory were not specified until it contained translation units. You created translation memories in SDL Edit and SDL Maintain.

**Figure 3.40 - Creating a Translation Memory in SDLX**

In SDL Trados Studio, to create a translation memory in the **Translation Memories** view:

- You can select **File > New > Translation Memory** to create a file-based translation memory. The **New Translation Memory** wizard is displayed.

- You can select **File > New > Server-based Translation Memory** to create a server-based translation memory. The **New Server-based Translation Memory** wizard is displayed.
Figure 3.41 - New File-based Translation Memory Wizard in SDL Trados Studio

Settings that you defined after creating a translation memory in SDLX are now included in the creation process in SDL Trados Studio. You can specify the following in the New Translation Memory/New Server-based Translation Memory wizard:

- The name, location and languages of the translation memory.
- The fields for the translation units in the translation memory, and translation memory settings.
- The language resource template. You can create or modify language resource lists. These lists are used in conjunction with the segmentation rules in translation memory processing and to identify untranslatable content.
Editing a Translation Memory Setup

In SDLX you edited translation memory settings in several different locations. Custom translation memory fields and their values were created and edited in the **TM Fields & Attributes** dialog box which was accessed from SDL Maintain, SDL Edit and SDL Apply.

![Figure 3.42 - Fields Setup in SDLX](image)

Segmentation rules in SDLX were stored in a segmentation file that could be edited from SDL Apply, SDL Edit, SDL Analyse and the Project Wizard.

In SDL Trados Studio the segmentation rules are stored with the translation memory. The segmentation rules used in the translation memory are automatically applied when you open a document and have the default translation memory specified for that language pair.

In SDL Trados Studio, both custom fields and segmentation rules can be edited in the **Translation Memory Settings** dialog box. To display this dialog box, select the translation memory that you want to edit settings for from the navigation tree in the **Translation Memories** view and then select **Home** tab > **Tasks** group > **Settings**.
You can edit and view the following sections:

- **[TM Name]** - This is where you can view general details of the translation memory, for example, name and source language. You can also modify the translation memory description.

- **Language Pairs** - This is where you can view which language pairs are in the translation memory. This page is only displayed for server-based translation memories that are multilingual and can contain more than one language pair.

- **Fields and Settings** - This is where you can view existing fields and create additional fields in the translation memory. You can also specify translation memory settings.

- **Language Resources** - This is where you can modify language resource lists in your translation memory. These lists are used to specify segmentation rules in translation memory processing and are also used to identify untranslatable content. The language resource lists can be shared between multiple users.

- **Access Rights** - This is where you can protect file-based translation memories by defining passwords that are linked to translation memory maintenance or a users rights.

- **Performance and Tuning** - This is where you can use different tools to improve the performance of server-based translation memories searches (on the selected translation memory). This does not apply to file-based translation memories.
Translation Memory Segmentation

In SDLX, the segmentation rules that were used in your document could be specified when you created a new translation.

**Figure 3.44 - SDLX Segmentation Rules**

In SDL Trados Studio, the rules used to segment your document are stored in the translation memory that you selected when opening your document or when creating your project. These rules can be edited in the **Translation Memory Settings** dialog box under **Language Resources** or when you create the translation memory.

**Figure 3.45 - SDL Trados Studio - Segmentation Rules**
Importing and Exporting

In SDLX you imported and exported translation memory data in SDL Maintain.

**Figure 3.46 - Import in SDLX**

In SDL Trados Studio, you can import translation memory data using the **Import** wizard. To display this wizard, select the translation memory for which you want to import data from the navigation tree in the **Translation Memories** view and then select **Home** tab > **Tasks** group > **Import**.

**Figure 3.47 - Import Wizard in SDL Trados Studio**

You can assign field values to newly imported translation units. For example, you may want to indicate the type of document the imported translations are for, such as, **Software** or **Online Help**.
Depending on the source you import data from, you can apply a filter so that only translation units that match the conditions of the filter are imported. Filters are based on the field values assigned to the translation units that are being imported.

If imported translation units have fields associated with them that are not part of the translation memory, there are several different options on how to import those translation units. For example, you could specify to only import translation units that contain the same fields as the translation memory you are importing into or you could add the fields from the imported translation units to the translation memory.
Translation Memory Maintenance

In SDLX you performed maintenance on your translation units in SDL Maintain. You could use filters to search for the translation units you wanted to edit. You could delete and edit the text of a translation unit.

Figure 3.50 - SDL Maintain in SDLX
In SDL Trados Studio, you can perform maintenance directly in the Translation Memories view. You can use the Search Details window to find the translation units that you want to edit. The translation units are displayed in the TM side-by-side editor.

To change the segment text, simply click in the segment and start typing. Use the Save group on the Home tab in the Translation Memories view to:

- Mark a translation unit for deletion.
- Save (Commit) changes to the translation memory or discard or undo your changes as required.

Use the Field Values window to assign custom field values to the translation unit selected in the TM side-by-side Editor.
PART 2: DATA MIGRATION
This chapter gives an overview of what data can be migrated from SDLX 2007 and SDL Trados 2007 to SDL Trados Studio. Topics include:

- Overview
- About Upgrading Translation Memories
- About Reusing Translations from Bilingual Files in PerfectMatch
- About Migrating INI and ANL Files to SDL Trados Studio
OVERVIEW

You can upgrade and migrate the following data from SDL Trados, SDLX and other translation memory software to SDL Trados Studio 2014.

- SDL Trados Studio 2009 Translation Memories (Server-based)
- SDL Trados (2007/Pre-2007) Translation Memories (Server-based)
- SDLX Translation Memories (File and server-based)
- TMX Files (Version 1.4b)
- SDL Trados INI Tag Settings Files (SDL Trados 7.x, SDL Trados 2006 and SDL Trados 2007 versions)
- SDLX ANL Tag Settings Files (SDLX 2007).

Depending on what you are upgrading or migrating different associated data can be also upgraded.

**NOTE**

- For information on how to upgrade server-based translation memories from SDL Trados Studio 2009 to TM Server 2014 format, refer to the *SDL GroupShare Installation Guide*.
- File-based translation memories from SDL Trados Studio 2009 and SDL Trados Studio 2011 do not need upgrading and are the same format as translation memories in SDL Trados Studio 2014.

About Upgrading Translation Memories

You can upgrade translation memories from SDLX, SDL Trados and other translation memory software. There are several upgrade methods from which you can choose. To determine which method to use you should consider the following:

- What files are available to upgrade.
- What files are supported for upgrade.
- What associated data you want to migrate alongside the translation memory.

Method 1: Upgrade Translation Memories

Use this method to upgrade your legacy translation memories from SDL Trados 2007 and SDLX 2007. See *Upgrading Legacy Translation Memories* on page 5-1.
Method 2: Upgrade using TMX Files

Use this method to upgrade or import TMX files from SDL Trados 2007 and SDLX 2007 and other translation memory software. See Populating Translation Memories from TMX Files on page 6-1.

Method 3: Upgrade Using Bilingual Files

Use this method to upgrade using bilingual files TradosTag (TTX) and SDL Edit (ITD) Files from SDL Trados 2007 and SDLX 2007. See Populating Translation Memories from Bilingual Documents on page 7-1.

Method 4: Upgrade Using Alignment tools

Use this method to upgrade using translated files that are aligned with their source in SDL Trados WinAlign or SDL Align. See Populating Translation Memories from Alignment Result Files on page 8-1.

Supported Upgrade Translation Memory File Formats

The following table describes what support is offered for using the different methods of upgrading your translation memories from different products.

- Supported
- Limited Support

<table>
<thead>
<tr>
<th>Product</th>
<th>Upgrade Using Upgrade TMs Wizard</th>
<th>Upgrade Segmentation Rules</th>
<th>Upgrade using TMX (version 1.4b)</th>
<th>Upgrade using TMX (pre 1.4B)</th>
<th>Upgrade using Bilingual TTX</th>
<th>Upgrade Using Bilingual ITD</th>
</tr>
</thead>
<tbody>
<tr>
<td>SDL Trados</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Trados 2007 Suite</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>Trados 2007 SP2</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>Trados 2006</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>Product</td>
<td>Upgrade Using Upgrade TMs Wizard</td>
<td>Upgrade Using Segmentation Rules</td>
<td>Upgrade using TMX (version 1.4b)</td>
<td>Upgrade using TMX (pre 1.4B)</td>
<td>Upgrade using Bilingual TTX</td>
<td>Upgrade Using Bilingual ITD</td>
</tr>
<tr>
<td>------------------------------</td>
<td>----------------------------------</td>
<td>----------------------------------</td>
<td>----------------------------------</td>
<td>-------------------------------</td>
<td>-----------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>SDLX 2007</td>
<td>⚫</td>
<td>⚫</td>
<td>⚫</td>
<td>⚫</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SDLX 2006</td>
<td>⚫</td>
<td>⚫</td>
<td>⚫</td>
<td>⚫</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SDLX 2005</td>
<td>⚫</td>
<td>⚫</td>
<td>⚫</td>
<td>⚫</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Miscellaneous

<table>
<thead>
<tr>
<th>Product</th>
<th>Upgrade Using TMs Wizard</th>
<th>Upgrade Using Segmentation Rules</th>
<th>Upgrade using TMX (version 1.4b)</th>
<th>Upgrade using TMX (pre 1.4B)</th>
<th>Upgrade using Bilingual TTX</th>
<th>Upgrade Using Bilingual ITD</th>
</tr>
</thead>
<tbody>
<tr>
<td>3rd Party Translation Memory Software</td>
<td></td>
<td>⚫</td>
<td>⚫ plain text only</td>
<td>⚫ plain text only</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### About Reusing Translations from Bilingual Files in PerfectMatch

You can extract translations from previously translated bilingual documents from SDL Trados 2007 and SDLX 2007 and transfer them to SDL Trados Studio project files. This is accomplished by applying PerfectMatch to your project in SDL Trados Studio. It allows you to leverage information from previous translations and apply them to new translations. You can do this with the following bilingual formats:

- SDL Trados 2007 TTX
- SDLX 2007 ITD

For more information, see *Reuse Translations From Bilingual Documents in PerfectMatch* on page 9-1.
About Migrating INI and ANL Files to SDL Trados Studio

You can migrate the tag settings you use for XML and HTML translation. The settings identify what content is translatable or not translatable in a file. You can migrate the following tag settings files:

- SDLX (ANL)
- SDL Trados (INI)

For more information, see *Migrating INI and ANL Tag Settings Files* on page 10-1.
This chapter describes how to upgrade your translation memories from SDLX 2007 and SDL Trados 2007 to SDL Trados Studio. Topics include:

- Overview
- Why Upgrade your Translation Memories?
- Hints and Tips
- Software Required for Upgrade
- Upgrading Segmentation Rules
- Compatibility with SDL Trados 2007 and SDLX 2007 Data
- Upgrading your Legacy Translation Memories
OVERVIEW

The purpose of this chapter is to give instructions on how to upgrade your translation memories from SDL Trados 2007 and SDLX 2007 to the SDL Trados Studio 2014 format (*.sdltm) using the Upgrade Translation Memories wizard in SDL Trados Studio.

You can upgrade the following translation memories:

- SDLX 2007, SDLX 2006 and SDLX 2005 File-based Translation Memories (*.mdb)
- SDLX 2007, SDLX 2006 and SDLX 2005 SQL Server-based Translation Memories
- SDL Trados Studio 2009 Translation Memories (Server-based)
- SDL Trados 2007, SDL Trados 2006 and SDL Trados 7.x File-based Translation Memories (*.tmw)
- SDL Trados 2007, SDL Trados 2006 and SDL Trados 7.x Server-based Translation Memories.

NOTE

- For information on how to upgrade server-based translation memories from SDL Trados Studio 2009 to TM Server 2014 format, refer to the SDL GroupShare Installation Guide.
- File-based translation memories from SDL Trados Studio 2009 and SDL Trados Studio 2011 do not need upgrading and are the same format as translation memories in SDL Trados Studio 2014.

You can also upgrade SDL Trados 2007 or SDLX 2007 translation memory created from translated legacy files using SDL Trados WinAlign and SDL Align. For more information, see Populating Translation Memories from Alignment Result Files on page 8-1.

For information on how to upgrade translation memories using TMX files and bilingual documents, see Populating Translation Memories from TMX Files on page 6-1 and see Populating Translation Memories from Bilingual Documents on page 7-1.
Why Upgrade your Translation Memories?

Upgrading your translation memories allows you to continue to leverage matches from your previous translations. Depending on what type of translation memory and what aspects of the translation memory are user-defined you can choose to upgrade the following information alongside the translation units in the translation memory:

- Data inside a segment pair (For example, leading and trailing tags)
- Custom fields and assigned values
- Language Resources (Including Segmentation Rules, Abbreviation Lists, Variable Lists and Ordinal Follower Lists).
Hints and Tips

Complete the following instructions to help find the best upgrade strategy for your translation memories:

- Upgrade your translation memory and make it a read-only translation memory that is not updated during translation.
- Create a new SDL Trados Studio translation memory that you can update during translation.
- Open both translation memories at the same time when translating in SDL Trados Studio.

You can specify the update settings when you open a document in the Open Document dialog box. Alternatively, if you already have a document open or have created a project, you can specify the update settings in the Project Settings dialog box:

This approach enables you to leverage the data from the old translation memory while creating new translation units in the new translation memory that have the updated segmentation and tag handling that is in SDL Trados Studio.
Upgrade Translation Memory Process

The following diagram shows the steps you need to take to upgrade your translation memories in SDL Trados Studio:
Software Required for Upgrade

When upgrading your translation memories, some types of TMs require you to have the application where the translation memory was created and SDL Trados Studio installed on your computer.

<table>
<thead>
<tr>
<th>To Upgrade</th>
<th>Software Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>SDLX 2007 file-based and server-based TMs</td>
<td>No additional software is required</td>
</tr>
<tr>
<td>SDL Trados 2007 file-based TMs</td>
<td>No additional software is required</td>
</tr>
<tr>
<td>SDL Trados 2007 server-based TMs</td>
<td>SDL Trados Server Manager 2007</td>
</tr>
</tbody>
</table>

Upgrading Segmentation Rules

Segmentation rules can be upgraded along with your translation memories. They are converted to a language resources file which includes segmentation rules, abbreviation lists, ordinal follower lists and variable lists. Segmentation has a significant impact on leverage from legacy resources. If the translation memories you are upgrading are segmented differently, matching against the translation memory will lead to fuzzy matches or return no matches at all.

When segmentation rules are migrated, tag and filter settings are not taken into account as they are not part of the segmentation rules but are part of the corresponding file format filter. Adjustments to tag and filter settings will need to be done manually. For more information about tag and filter settings, see Migrating INI and ANL Tag Settings Files on page 10-1.
The following tables shows what segmentation lists can be upgraded from SDL Trados and SDLX:

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Segmentation Rules</td>
<td>Yes</td>
<td>Only SDL Trados 2007 Suite</td>
</tr>
<tr>
<td>Abbreviations List</td>
<td>No</td>
<td>Yes, only user-defined lists</td>
</tr>
<tr>
<td>Ordinal Followers List</td>
<td>No</td>
<td>Yes, only user-defined lists</td>
</tr>
<tr>
<td>Variables List</td>
<td>No</td>
<td>Yes, only user-defined lists</td>
</tr>
</tbody>
</table>

**NOTE**

- If you want to upgrade your segmentation rules from SDL Trados 2006 or SDL Trados 7.x, you must first install SDL Trados 2007 Suite.
- If you migrate your user-defined abbreviation lists, ordinal follower lists and variable lists, they are merged with the defaults lists in SDL Trados Studio.

**Should you Migrate your Segmentation Rules?**

When you upgrade your translation memories you should decide whether to upgrade your segmentation rules or to use SDL Trados Studio’s default rules.

- If you are working in a supply chain where both SDL Trados 2007 and SDL Trados Studio are used together or a supply chain where SDLX 2005 and SDL Trados Studio are used together, SDL recommends that you upgrade your segmentation rules. However, if you have put significant efforts into rule customizations you may also want to migrate your rules.
- If you are only going to be using SDL Trados Studio, SDL recommends that you select the default segmentation rules in SDL Trados Studio and modify them as needed. This will provide cleaner rules and better default segmentation.

**NOTE**

If you are unsure of whether to migrate your segmentation rules, contact Professional Services.
SDLX Segmentation

It is optional to upgrade the SDLX segmentation rules to a language resource that is contained within the translation memory when you upgrade the translation memory. You may find that SDLX rules representation formalism (SRX) may be a bit harder to read and understand. Therefore, you may find it easier to accept the default segmentation rules (Language Resources) in SDL Trados Studio which provide cleaner rules and an improved user interface for modifying and reading the rules.

Segmentation rules are not stored within the SDLX translation memories but in a separate SRX file. They are stored locally on a user’s machine in their installation folders. Therefore, if you want to upgrade your segmentation rules in your translation memory, the translation memory must be upgraded on the computer where the customized segmentation rules are stored and you must have administrative permission rights on that computer to migrate those rules.

**NOTE**

If you migrate your segmentation rules, they replace the rules in SDL Trados Studio.

There are some key differences between the rules in SDL Trados Studio and SDLX:

- In SDLX, abbreviations and ordinal followers are stored as exceptions, therefore when they are upgraded to SDL Trados Studio, each abbreviation and ordinal follower on the list appears as a separate exception instead of displaying on the abbreviations or ordinal follower lists in SDL Trados Studio. SDL recommends that you remove these exceptions and add them to the appropriate list in SDL Trados Studio.

- SDLX has language-specific rule sets which capture language-specific abbreviations.

- SDLX may not break if the break character is followed by closing punctuation (for example, a closing double quote, or closing parentheses).

SDL Trados 2007 Segmentation

It is optional to upgrade the SDL Trados 2007 segmentation rules and lists to a language resource that is contained within the translation memory when you upgrade the translation memory. Most segmentation rules used in SDL Trados Studio are based on the rules that were used in SDL Trados 2007. If you did not customize your rules in SDL Trados 2007, SDL recommends that you do not migrate your rules and use the defaults in SDL Trados Studio instead.

If you choose to migrate your user-defined segmentation rules and lists the following happens:

- If you migrate your segmentation rules fully, they replace the rules in SDL Trados Studio.

- If you migrate your user-defined abbreviation list, it is merged with the default list in SDL Trados Studio.
If you migrate your user-defined ordinal follower list and there is a default list for that language in SDL Trados Studio, it is merged with the default list.

If you migrate your user-defined variable list and there is no default variable list in SDL Trados Studio, the list is not merged but just copied across to the new translation memory.

NOTE
If you heavily customized your SDL Trados 2007 rules, you may not be able to fully migrate the rules. In this case, SDL recommends you contact Professional Services for more information.

Some constraints defined in SDL Trados 2007 (for example, minimum number of words or characters in a segment) are not migrated, so any customization of such settings will have no effect on segmentation in SDL Trados Studio.

These are some key differences between the rules in SDL Trados Studio and SDL Trados 2007 that could effect leverage in your translation memory during upgrade:

- SDL Trados 2007 did not segment number-only segments and SDL Trados Studio does.
- SDL Trados 2007 abbreviation lists are not case sensitive and SDL Trados Studio’s abbreviation lists are.
- For some languages (such as German), SDL Trados 2007 did not always segment correctly after numbers followed by a full stop, independent of the ordinal followers list. SDL Trados Studio does segment correctly for these languages.
- In SDL Trados 2007, numbers in a segment-initial position were not always included in the segment. In SDL Trados Studio, these numbers are included in the segment but not if they are, for example, a numbered list.
- SDL Trados 2007 has an ‘End of Paragraph’ rule that by design no longer exists in SDL Trados Studio since content is always segmented at paragraph breaks.
Comparison Of Default Rules

This following table summarizes segmentation differences for the default Western languages.

<table>
<thead>
<tr>
<th>Break Character</th>
<th>SDL Trados 2007</th>
<th>SDLX 2007</th>
<th>SDL Trados Studio</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Stop</td>
<td>Breaks: - unless followed by lower case letter. - unless preceding word including the full stop is in the abbreviations list. - unless full stop is preceded by a sequence of digits and the word following the full stop is in the ordinal followers list.</td>
<td>Breaks, - unless full stop follows a digit sequence in segment-initial position. - unless full stop is part of an ellipsis (“…”).</td>
<td>The same as SDL Trados 2007.</td>
</tr>
<tr>
<td>Question and Exclamation Mark</td>
<td>Breaks, - unless followed by lower case letter.</td>
<td>Breaks</td>
<td>The same as SDL Trados 2007.</td>
</tr>
<tr>
<td>Colon</td>
<td>Breaks by default.</td>
<td>Does not break.</td>
<td>Breaks, - unless followed by lower case letter</td>
</tr>
<tr>
<td>Tabulator</td>
<td>Breaks by default.</td>
<td>Does not break.</td>
<td>No break by default.</td>
</tr>
</tbody>
</table>

Additional SDL Trados Studio Segmentation Rules

- When SDL Trados Studio segments your document, it includes punctuation following the break character in the segment in some cases. For example, an exclamation mark that appears within double quotes. The quote marks are included in the segment for translation.

  “double quotes!”

- SDL Trados Studio supports the same type of segment and paragraph-based segmentation that was supported in SDL Trados and SDLX.
Compatibility with SDL Trados 2007 and SDLX 2007 Data

The legacy translation memory engines, SDL Trados Translator’s Workbench and SDLX, applied and stored data associated with a translation unit differently to SDL Trados Studio. In addition, the file format filters worked differently. When you upgrade a translation memory you can specify what data inside a segment pair is removed or retained in your translation memory in order to optimize the leverage from your new upgraded translation memory. This process makes the content of the translation units in your upgraded translation memory closer to what the file format filters in SDL Trados Studio are likely to produce.

For example, depending on your settings, Microsoft Word’s heading numbers and bullet point characters are stored in an SDLX translation memory. In the SDL Trados Studio Microsoft Word filter, it does not allow you to include the heading numbers or bullet point characters in the translation memory. This means that heading information is stored but not the heading number. If you upgrade your translation memory without removing this information from the translation memory, a difference will occur when the translation unit is reused, resulting in penalty or fuzzy match. Eliminating those pieces of data associated with the translation memory should now allow it to result in a 100% match. Although in some situations you may want to retain that data.

For more details about the different options, see the Compatibility options on page 5-24.
Upgrading Fields

Fields and their values can be upgraded along with your translation memories. The translation memories are scanned for their fields and values. If you have multiple translation memories upgrading to the new translation memory, you may find that there are field clashes.

The examples below explain different scenarios that may occur when you have field clashes. Field clashes occur when you have a field with the same name in two different translation memories that are being upgraded to one new translation memory. The clash only occurs if these fields are using the same capitalization.

Example A

If you have two fields with the same name from different translation memories and they are different types (for example, Text and Picklist), one of the fields is renamed automatically when the translation memories are upgraded.

Scenario

- Translation Memory A has a field called Project which is a Text field.
- Translation Memory B has a field called Project which is a Picklist field.

Upgrade Result

- SDL Trados Studio automatically renames the field from Translation Memory B to Project_SinglePicklist. You can change this field name as needed.

Example B

If you have two fields with the same name from different translation memories and they are the same type of field (Text or Picklist) but only allow single values assigned to translation units, only one value will remain assigned to a translation units that are merged in the new translation memory unless you change the field to allow multiple values to be assigned.

Scenario

- Translation Memory A has a field called Project which is a Picklist field that only allows single values assigned to translation units.
- Translation Memory B has a field called Project which is a Picklist field that only allows single values assigned to translation units.
In Translation Memory A and B, there is an identical translation unit. In Translation Memory A it has the value, *Project A* assigned to it. In Translation Memory B it has the value, *Project B* assigned to it.

**Upgrade Result**

- SDL Trados Studio merges the translation units from Translation Memory A and Translation Memory B, and the value from Translation Memory B, *Project B*, is the only value that remains assigned to the merged translation unit.

- If you want both values to remain assigned to the translation unit so that it has *Project A* and *Project B* assigned to it, you must select the **Multiple** check box when you upgrade your translation memories. This changes the field allowing for multiple values to be assigned to translation units.

**Example C**

If you have two fields with the same name from different translation memories and they are the same type of field (Text or Picklist) but one allows single values assigned to translation units and the other one allows multiple values assigned to translation units, both values will remain assigned to translation units that are merged in the new translation memory.

**Scenario**

- Translation Memory A has a field called *Project* which is a **Picklist** field that only allows single values assigned to translation units.

- Translation Memory B has a field called *Project* which is a **Picklist** field that allows multiple values assigned to translation units.

- In Translation Memory A and B, there is an identical translation unit. In Translation Memory A it has the value, *Project A* assigned to it. In Translation Memory B it has the value, *Project B* assigned to it.

**Upgrade Result**

- SDL Trados Studio merges the translation units from Translation Memory A and Translation Memory B, and the values from Translation Memory A and B, *Project A* and *Project B*, remain assigned to the merged translation unit.
UPGRADING YOUR LEGACY TRANSLATION MEMORIES

This section describes how to upgrade your SDLX 2007 and SDL Trados 2007 translation memories to the SDL Trados Studio format (.sdltm) using the Upgrade Translation Memories wizard in SDL Trados Studio.

In SDL Trados Studio,

- File-based translation memories are bilingual and can only have one source language and one target language.

- Server-based translation memories are multilingual and can have multiple source languages and target languages.

Therefore, if you are upgrading a translation memory that is multilingual with more than one target language, you would have to create an SDL Trados Studio server-based translation memory or create multiple SDL Trados Studio file-based translation memories (one for each language direction).

Before you Start

Before you upgrade your translation memories, you may want to do the following:

- Perform maintenance on your translation memories in SDL Trados Translator’s Workbench or in SDL Maintain in SDLX 2007 to ensure you are upgrading quality data.

- Ensure that the correct software is installed on the computer. See Software Required for Upgrade on page 5-6.

- Decide if you want to upgrade your segmentation rules. See Upgrading Segmentation Rules on page 5-6.
How to Upgrade your Legacy Translation Memories

To upgrade your legacy translation memories:

1. Select **Home** tab > **Tools** group > **Upgrade Translation Memories** in the **Translation Memories** group. The **Upgrade Translation Memories** wizard is displayed on the **Input Translation Memories** page.

   ![Upgrade Translation Memories Wizard](image)

2. If you want to add file-based legacy translation memories:

<table>
<thead>
<tr>
<th>To</th>
<th>Click</th>
</tr>
</thead>
<tbody>
<tr>
<td>add a folder containing a group of SDLX 2007 or SDL Trados translation memories,</td>
<td>...<strong>Add File-based TMs from Folder</strong>. The <strong>Browse for Folder</strong> dialog box is displayed. Select the folder and click <strong>OK</strong> to add the contents of the folder.</td>
</tr>
<tr>
<td>add an individual SDLX 2007 or SDL Trados translation memory,</td>
<td>...<strong>Add File-based TMs</strong>. The <strong>Select Input Translation Memories</strong> dialog box is displayed. Select the translation memories and click <strong>Open</strong> to add them.</td>
</tr>
</tbody>
</table>

3. If you want to add an SDL Trados server-based legacy translation memory:
Click **Add Server-based TM** and select **SDL Trados 2007 server-based translation memory** from the drop-down list. The **Log On** dialog box is displayed.

![Log On dialog box](image)

Select the appropriate authentication method and enter your **Login ID** and **Password** if required. Click **OK**. The **Open Server-based Translation Memory** dialog box is displayed.

![Open Server-based Translation Memory dialog box](image)

Expand a database to load the translation memories it contains into the window for selection. To expand a database, double-click the database or click the plus icon preceding the database name. If you are not currently logged in to a TM server, the window remains empty. Select a translation memory and click **OK**.
4 If you want to add an SDLX 2007 server-based legacy translation memory:

- Click **Add Server-based TM** and select **SDLX 2007 server-based translation memory** from the drop-down list. The **Select Data Source** dialog box is displayed.

  ![Select Data Source](image)

- If the server from which you want to retrieve the translation memories is not displayed, click **Add**. Alternatively, if the server from which you want to retrieve translations memories is displayed, select the server and click **Configure**. The **Add/Configure SQL Server Data Source** dialog box is displayed.

  ![Add SQL Server Data Source](image)

- Enter a **Name** that you want to use to refer to the server.
- Select the server from the **Server** drop-down list.
- Select the appropriate authentication method and enter your **User ID** and **Password** if required.
- Select the translation memory that you want to upgrade from the **Database** drop-down list and click **OK**. The **Select Data Source** dialog box is displayed. Click **OK** again to add the translation memory.

5 Click **Next** on the **Input Translation Memories** page.
The **Output Translation Memories** page is displayed.

6 Specify how the translation memories will be created:

- **Create output translation memory for each input translation memory** – When this option is selected, an SDL Trados Studio translation memory is created for each translation memory that was added on the **Input Translation Memories** page. Click **Next** and go to step 8.

- **Create output translation memory for each language pair** – When this option is selected, an SDL Trados Studio translation memory is created for each language pair that exists in the translation memories that were added on the **Input Translation Memories** page. Click **Next** and go to step 8.
Custom - When this option is selected, additional options are displayed where you can customize how the SDL Trados Studio translation memories are created. If you want to change the language direction of the translation memory that you are upgrading, select this option.

NOTE
- If you are upgrading to a server-based translation memory, they can contain multiple language pairs. If you are upgrading to a file-based translation memory, they can only contain one language pair.
- Each translation memory file is displayed twice in Output translation memories box. Once for each language direction. For example, the translation memory master_en_de.tmw file is displayed twice with the language direction as English to German and German to English.

Specify your custom built translation memories:
- Select the translation memory with the language direction for which you want to create the translation memory in the Output translation memories box.
- Select the new translation memory in the Output translation memories box. Use the Rename and Create buttons to create the new translation memories in this box as needed.
Click Add. The translation memory is added to the new selected translation memory. Repeat these steps until you have all of the translation memories in the **Output translation memories** box that you want to create.

Click Next. The **Output Translation Memories Settings** page is displayed.

8 Select the translation memory for which you want to specify settings. The settings for the translation memory are displayed on the right-hand side on the **Location** tab:

- If you want the new upgraded translation memory to be created locally, select **File-based translation memory**. Go to step 10.

**NOTE**

If you selected more than one language pair in your new upgraded translation memory, the option to create a file-based translation memory is disabled because file-based translation memories are bilingual and can only contain one language pair.

- If you want the new upgraded translation memory to be created on a server, select **Server-based translation memory**. Go to step 9.
9 If you selected **Server-based translation memory**, specify the following:

- **Server** - Select the server where you want to create the new translation memory. If the required server does not appear in the list for selection, click **Servers** to display the **Servers** dialog box where you can add the server.

- **Location** - Click **Location** to display the **Select Location** dialog box. This dialog box is where you select the organization or resource library to which you want the new translation memory to belong.

- **Container** - Click **Containers** to display the **Select Translation Memory Container** dialog box. This dialog box is where you select the container where you want the translation memory to be created.

10 Click the **Settings** tab:

![Settings Tab](image)

Specify the following:

- **If you want to add a description**, enter a description in the **Description** box. This will be displayed in the translation memory settings after the translation memory is created.

- **Import translation units as plain text** – When this option is selected, all formatting in the import file is ignored and the translation unit content is imported as plain text. This may be useful if you are importing translation units from an application that handles tags differently to SDL Trados Studio as the imported tag information would not display correctly in SDL Trados Studio.
11 Specify your **Recognition Settings** - These settings are used to identify elements that do not change during translation. These elements include variables, dates, times, numbers, measurements and acronyms. These elements can either be transferred directly from the current source segment to the new target segment or automatically converted to the correct target language format. For example, you can auto-localize date and time elements to the correct target language format.

Which settings are selected varies based on what type of translation memory you are upgrading and what settings were selected in the translation memories you are upgrading. Select or clear the check boxes as needed.

- If you are upgrading an SDLX translation memory, all of the recognition settings are selected.
- If you are upgrading an SDL Trados translation memory, only the recognition settings that were selected in the translation memory you are upgrading from are selected.
- If you are upgrading multiple translation memories to one new translation memory, only the recognition settings that are selected in all of the translation memories are selected.

**NOTE**

For more detailed information on these settings, see the SDL Trados Studio Help that is launched from SDL Trados Studio.
12 Click the **Language Pairs** tab:

![Language Pairs Tab](image)

This is where you can view the source language and target languages in the translation memory. Each row indicates one language pair.

- Server-based translation memories in SDL Trados Studio are multilingual and may have multiple language pairs listed on this page.
- File-based translation memories in SDL Trados Studio are bilingual and can only contain one language pair.
13 Click the **Compatibility** tab:

![Compatibility tab image]

When you upgrade a translation memory you can specify what data inside a segment pair is removed or retained in your translation memory in order to optimize the leverage from your new upgraded translation memory. This process makes the content of the translation units in your upgraded translation memory closer to what the file format filters in SDL Trados Studio are likely to produce. For example, you can remove or leave leading and trailing tags. For more information, see *Compatibility with SDL Trados 2007 and SDLX 2007 Data* on page 5-11.
Select from one of the following compatibility options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>The upgraded TM will be primarily used with new, native source files</strong>&lt;br&gt;or files processed only with SDL Trados Studio</td>
<td>Imports a version of the translation memory that has had some formatting-related data removed. You might want to do this, for example, if you are a translator and you receive files in their original (native) format with a legacy translation memory. In this case, removing the formatting-related data associated with the translation unit will increase the leverage because you are more likely to get a match if the translation units in the translation memory are using the same type of formatting-related data as the document you are translating.</td>
</tr>
<tr>
<td><strong>The upgraded TM will be primarily used with presegmented legacy SDL Trados ITD files and TTX files</strong></td>
<td>Imports a version of the translation memory that retains the legacy translation unit data. You might want to do this, for example, if you are a translator and you receive a pre-segmented legacy bilingual file with a legacy translation memory. In this case, retaining the data associated with the translation unit will increase leverage.</td>
</tr>
<tr>
<td><strong>The upgraded TM will primarily used in mixed scenarios</strong></td>
<td>Imports two versions of the translation unit, one where the data associated with the translation unit will be removed and another one where it retains the data. You might want to do this if:</td>
</tr>
<tr>
<td></td>
<td>- you want to permanently upgrade the translation memory and</td>
</tr>
<tr>
<td></td>
<td>- you are using legacy bilingual files and using bilingual files from SDL Trados Studio.</td>
</tr>
<tr>
<td></td>
<td>Selecting this option will maximize the translation memory leverage in all situations, however, it may also increase the number of multiple 100% matches, causing a penalty to be applied.</td>
</tr>
</tbody>
</table>
14 Click the **Fields** tab:

![Fields Tab](image)

The existing custom fields from the translation memories you are upgrading are listed here. If you have multiple translation memories upgrading to a new translation memory, you may find that there are field clashes. For information about field clashes and what to do, see *Upgrading Fields* on page 5-12.

You can perform the followings actions on this tab:

- Click **Add** to add a new field. When you click **Add** a new row is added to this tab. Click in the **Name** column for this row and type the name. Select the type of field from the drop-down list in the **Type** column. Enter values in the **Picklist** column if you selected **List** as the type of field.

- Click **Remove** to delete a field and all of its corresponding fields values that are assigned to translation units in the translation memory.

- To rename a field, click in the field you want to change in the **Name** column. Type the new name. The corresponding fields values that are assigned to translation units stay assigned to those translation units but with a new field name.

**NOTE**

For more information about fields and the different types of fields, see the SDL Trados Studio Help. You can access the help from the **Help** tab in SDL Trados Studio.
15 Click the **Language Resources** tab:

Language resources control the process of segmenting source document text so that it is ready for a translation memory to be applied to the segments. Language resources are stored in the form of lists and rules. Your input translation memories are scanned and any segmentation rules are copied. For details of what segmentation rules are upgraded, see *Upgrading Segmentation Rules* on page 5-6.

Select one of the following from the drop-down list in the **Language Resources** column for each language pair:

- **Default Language Resources** - Select this to use the default SDL Trados Studio segmentation rules.

- **Upgraded Language Resources** - Select this to use the segmentation rules from your existing translation memories.

**NOTE**

You can change language resources after the translation memory is created in the **Translation Memories** view.

Click **Finish** to upgrade your translation memories.
The 

The **Upgrading Translation Memories** page is displayed. A progress bar is displayed as each task is run.

![Upgrade Translation Memories](image)

16 When the translation memory has been upgraded, you can do the following:

- Click the **Details** link to display the **Import Results** dialog box which contains statistics about what translation units were imported.

![Import Results](image)

- Click the **Open** link to open the translation memory in the **Translation Memories** view where you can view the imported data and modify the segmentation rules.
This chapter describes how to populate translation memories from TMX files. Topics include:

- Overview
- Who Should do this?
- Hints and Tips
- Benefits and Limitations
- Two Methods
- How to Upgrade TMX Files Using the Upgrade Translation Memories Wizard
- How to Import TMX Files into an Existing Translation Memory
OVERVIEW

The purpose of this chapter is to give instructions on how to upgrade your translation memories to the SDL Trados Studio format (*.sdltm) using Translation Memory Exchange Documents (TMX) files. SDL provides support for upgrading the following TMX files:

- Limited support for TMX files generated from a software other than SDL Trados or SDLX. You can upgrade TMX version 1.4b or pre-1.4b.
- SDL Trados TMX (Only version 1.4b)
- SDLX 1.4b TMX (Only version 1.4b).

Who Should do this?

Primarily, the users who should upgrade TMX files are ones where the TMX file was third party generated. That is TMX files generated from software other than SDL Trados or SDLX.

NOTE

SDL recommends that if you have a legacy translation memory in SDLX 2007 or SDL Trados 2007, you use this to upgrade to the new format in SDL Trados Studio. However, if you do not want the setup information to be extracted from the translation memory you may want to upgrade using a TMX file (Only version 1.4b). For more information, see Upgrading Legacy Translation Memories on page 5-1.
Hints and Tips

Users who have 3rd party generated TMX files that are version 1.4b or below should select the option to **Import translation units as plain text**. When this option is selected, all formatting in the import file is ignored and the translation unit content is imported as plain text. This may be useful if you are importing translation units from an application that handles tags differently to SDL Trados Studio as the imported tag information would not display correctly in SDL Trados Studio.

- Use the **Import** wizard to import the 3rd party generated TMX files:

- Select the **Import translation units as plain text** check box on the **General Import Options** page:
Benefits and Limitations

Depending on the type of TMX file, different information can be extracted. TMX files contain limited information (if any) about the setup of the translation memory. For example, it does not contain segmentation rules, abbreviations, recognition settings, ordinal follower lists or variable lists.

If you are upgrading a TMX file that is version 1.4b from SDLX 2007 or SDL Trados 2007 then some setup information can be extracted. If you are upgrading a TMX file from a third party software then there are further limits on what can be upgraded.

The following table shows details of the components that make up a TMX file and what can be extracted from those files during the upgrade process.

<table>
<thead>
<tr>
<th>Component</th>
<th>SDLX 2007 TMX</th>
<th>SDL Trados 2007 TMX</th>
<th>Third Party Generated TMX</th>
</tr>
</thead>
<tbody>
<tr>
<td>Translation Units</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Context Match Information</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Custom Fields and their Values</td>
<td>Yes but with some restrictions</td>
<td>Yes but with some restrictions</td>
<td>No</td>
</tr>
<tr>
<td>System Fields</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Tags</td>
<td>Yes</td>
<td>Yes</td>
<td>See Note</td>
</tr>
</tbody>
</table>

**NOTE**

If you are upgrading a third party generated TMX file, contact professional services to determine if tags from your TMX file can be extracted.
Two Methods

There are two methods you can use to upgrade your TMX file to a translation memory in SDL Trados Studio format (*.sdltm).

About Upgrading TMX Files Using the Upgrade Translation Memories Wizard

This method creates a new upgraded translation memory with the data extracted from the TMX file. The TMX file is scanned to obtain all relevant information:

- Translation Units
- Custom fields and their values (You can only import these from TMX files created by SDL Trados and SDLX)
- System Fields
- Tags

You can then choose which information is included in the new upgraded translation memory and what settings are used. You also have more control over the custom fields and correcting them if they are not imported correctly.

NOTE

Third party TMX files have a limited amount of data that is imported. Contact professional services to determine if tags from your TMX file can be extracted.

The following diagram shows the steps you need to take to upgrade your TMX files using the Upgrade Translation Memories wizard in SDL Trados Studio:
The following diagram shows the steps you need to take to upgrade your TMX files using the **Upgrade Translation Memories** wizard in SDL Trados Studio:

1. **Upgrade Translation Memories Wizard**
2. **Input TMX Files**
3. **Upgrade Custom Fields**
   - For third party TMX files SDL Professional Services should be consulted
   - New Upgraded Translation Memory Created
   - SDL Trados Studio format *.*.sdltm
About Importing TMX Files into an Existing Translation Memory

This method imports the TMX file into a translation memory that already exists in SDL Trados Studio. The imported TMX file is not scanned for custom fields but you can optionally choose to import the custom fields or choose to ignore them. The main difference between using this method as opposed to using the Upgrade Translation Memories wizard is that in this method the translation memory already exists and it may already contain data. This method also allows you to filter out unwanted translation units and apply new field values to the translation units you are importing.

The following diagram shows the steps you need to take to import your TMX files into an existing translation memory in SDL Trados Studio:
Upgrading Fields

SDLX and SDL Trados Fields

Fields and their values can be upgraded along with your TMX files. However, the field values are treated differently than when you upgrade using a translation memory. The custom field information is extracted from the TMX file by extracting the fields and their values from the translation units and not by reading the setup information. Therefore, field values are only retrieved from the translation units as they occur and are not necessarily complete. For example, a TMX file has a picklist field *Content Type* with values *Online, Print, Tutorial*. If one or more of the values is never assigned to any of the translation units, those values not be included in the new translation memory.

If you are upgrading multiple TMX files to the new translation memory, you may find that there are field clashes. Field clashes occur when you have a field with the same names in two different TMX files that are being upgraded to one new translation memory. For examples of different scenarios that might occur, see *Upgrading Fields* on page 5-12.

Other Translation Memory Software Fields

If you are importing your TMX files from another translation memory software, other than SDLX and SDL Trados, then you may not be able to upgrade any custom field information to the new SDL Trados Studio translation memory. The reason for this is that the setup of the fields, field types and their values in TMX files is not standardized and may differ from the setup in SDL Trados and SDLX. Contact professional services to determine if you can upgrade any of your custom fields.

Tag Information

If you are importing your TMX files from another translation memory software other than SDLX and SDL Trados, then you may not be able to upgrade any tag information to the new SDL Trados Studio translation memory. Contact professional services to determine if you can upgrade any of your tag information.
UPGRADING THE TMX FILES USING THE UPGRADE TRANSLATION MEMORIES WIZARD

This section describes how to upgrade TMX files to an SDL Trados Studio translation memory format (*.sdltm) using the Upgrade Translation Memories wizard in SDL Trados Studio.

Before you Start

If you want to import a number of TMX files, place them all in a single folder so that you can import the folder.

How to Upgrade TMX Files Using the Upgrade Translation Memories Wizard

To upgrade your TMX files:

1. Select Home tab > Tools group > Upgrade Translation Memories in the Translation Memories group. The Upgrade Translation Memories wizard is displayed on the Input Translation Memories page
2 Add your TMX file:

- Click Add File-based TMs. The Select Input Translation Memories dialog box is displayed.
- Select the TMX file you want to add and click Open

The TMX file is added to the Input Translation Memories page.

Click Next. The Output Translation Memories page is displayed.

3 Specify how the translation memories will be created:

- Create output translation memory for each input translation memory – When this option is selected, an SDL Trados Studio translation memory is created for each TMX file that was added on the Input Translation Memories page. Click Next and go to step 5.

- Create output translation memory for each language pair – When this option is selected, an SDL Trados Studio translation memory is created for each language pair that exists in the TMX files that were added on the Input Translation Memories page. Click Next and go to step 5.
- **Custom** - When this option is selected, additional options are displayed where you can customize how the SDL Trados Studio translation memories are created. If you want to change the language direction of the TMX file that you are upgrading, select this option.

![Upgrade Translation Memories](image)

**NOTE**

- If you are upgrading to a server-based translation memory, they can contain multiple language pairs. If you are upgrading to a file-based translation memory, they can only contain one language pair.

- Each TMX file is displayed twice in **Output translation memories** box. Once for each language direction. For example, the TMX file `ENUS_DE.tmx` file is displayed twice with the language direction as English to German and German to English.

4 Create your custom built translation memories:

- Select the TMX file with the language direction for which you want to create the translation memory in the **Output translation memories** box.

- Select the new translation memory in the **Output translation memories** box. Use the Rename and Create buttons to create the new translation memories in this box as needed.
Click **Add**. The TMX file is added to the selected translation memory. Repeat these steps until you have all of the translation memories in the **Output translation memories** box that you want to create.

Click **Next**. The **Output Translation Memories Settings** page is displayed.

5 Select the translation memory for which you want to specify settings. The settings for the translation memory are displayed on the right-hand side on the **Location** tab:

- If you want the new upgraded translation memory to be created locally, select **File-based translation memory**. Go to step 7.

**NOTE**

If you selected more than one language pair in your new upgraded translation memory, the option to create a file-based translation memory is disabled because file-based translation memories are bilingual and can only contain one language pair.

- If you want the new upgraded translation memory to be created on a server, select **Server-based translation memory**.
Upgrading the TMX Files Using the Upgrade Translation Memories Wizard

6 If you selected **Server-based translation memory**, specify the following:

- **Server** - Select the server where you want to create the new translation memory. If the required server does not appear in the list for selection, click **Servers** to display the **Servers** dialog box where you can add the server.

- **Location** - Click **Location** to display the **Select Location** dialog box. This dialog box is where you select the organization or resource library to which you want the new translation memory to belong.

- **Container** - Click **Containers** to display the **Select Translation Memory Container** dialog box. This dialog box is where you select the container where you want the translation memory to be created.

7 Click the **Settings** tab:

![Settings Tab](image)

Specify the following:

- If you want to add a description, enter a description in the **Description** box. This will be displayed in the translation memory settings after the translation memory is created.

- **Import translation units as plain text** – When this option is selected, all formatting in the import file is ignored and the translation unit content is imported as plain text. This may be useful if you are importing translation units from an application that handles tags differently to SDL Trados Studio as the imported tag information would not display correctly in SDL Trados Studio. It is also useful if you are importing a TMX file that is from a 3rd party software that is version 1.4B or earlier.
NOTE
If you are unsure about whether to import your TMX file as plain text, contact Professional Services.

Specify your Recognition Settings - These settings are used to identify elements that do not change during translation. These elements include variables, dates, times, numbers, measurements and acronyms. These elements can either be transferred directly from the current source segment to the new target segment or automatically converted to the correct target language format. For example, you can auto-localize date and time elements to the correct target language format.

By default all of these settings are selected when you upgrade a TMX file. Select or clear the check boxes as needed.

NOTE
For more detailed information on these settings, see the SDL Trados Studio Help that is launched from SDL Trados Studio.

Click the Language Pairs tab:

This is where you can view the source language and target languages in the translation memory. Each row indicates one language pair. Server-based translation memories in SDL Trados Studio are multilingual and may have multiple language pairs listed on this page.
Click the **Compatibility** tab:

When you upgrade a TMX file you can specify what data inside a segment pair is removed or retained in your translation memory in order to optimize the leverage from your new upgraded translation memory. This process makes the content of the translation units in your new translation memory closer to what the file format filters in SDL Trados Studio are likely to produce. For example, you can remove or leave leading and trailing tags. For more information, see *Compatibility with SDL Trados 2007 and SDLX 2007 Data* on page 5-11.

Select from one of the following compatibility options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>The upgraded TM will be primarily used with new, native source files or files processed only with SDL Trados Studio</strong></td>
<td>Imports a version of the TMX file that has had some formatting-related data removed. You might want to do this, for example, if you are a translator and you receive files in their original (native) format with a legacy TMX file. In this case, removing the formatting-related data associated with the translation unit will increase the leverage because you are more likely to get a match if the translation units in the translation memory are using the same type of formatting-related data as the document you are translating.</td>
</tr>
</tbody>
</table>
The upgraded TM will be primarily used with presegmented legacy SDL Trados ITD files and TTX files

Imports a version of the TMX file that retains the legacy translation unit data. You might want to do this, for example, if you are a translator and you receive a pre-segmented legacy bilingual file with a legacy TMX file. In this case, retaining the data associated with the translation unit will increase leverage.

The upgraded TM will primarily be used in mixed scenarios

Imports two versions of the translation unit, one where the data associated with the translation unit will be removed and another one where it retains the data. You might want to do this if:

- you want to permanently upgrade the translation memory and
- you are using legacy bilingual files and using bilingual files from SDL Trados Studio.

Selecting this option will maximize the translation memory leverage in all situations, however, it may also increase the number of multiple 100% matches, causing a penalty to be applied.
11 Click the **Fields** tab:

![Image of the Fields tab with a table]

The existing custom fields from the TMX files you are upgrading are listed here. If you have multiple TMX files that you are upgrading to this new translation memory, you may find that there may be field clashes. For information about field clashes and what to do, see *Upgrading Fields* on page 5-12.

You can perform the following actions on this tab:

- Click **Add** to add a new field. When you click **Add** a new row is added to this tab. Click in the **Name** column for this row and type the name. Select the type of field from the drop-down list in the **Type** column. Enter values in the **Picklist** column if you selected **List** as the type of field.

- Click **Remove** to delete a field and all of its corresponding fields values that are assigned to translation units in the translation memory.

- To rename a field, click in the field you want to change in the **Name** column. Type the new name. The corresponding fields values that are assigned to translation units stay assigned to those translation units but with a new field name.

**NOTE**

For more information about fields and the different types of fields, see the SDL Trados Studio Help. You can access this help from the **Help** tab in the SDL Trados Studio.
12 Click the **Language Resources** tab:

Language resources control the process of segmenting source document text so that it is ready for a translation memory to be applied to the segments. Language resources are stored in the form of lists and rules. TMX files do not contain segmentation rules. If you are upgrading a TMX file, default segmentation rules for SDL Trados Studio are automatically selected.

**NOTE**

You can change language resources after the translation memory is created in the Translation Memories view.

Click **Finish** to upgrade your TMX files to a new translation memory.
The **Upgrading Translation Memories** page is displayed. A progress bar is displayed as each task is run.

`13` When the new translation memory is created, you can do the following:

- Click the **Details** link to display the **Import Results** dialog box which contains statistics about what translation units were imported.

- Click the **Open** link to open the translation memory in the **Translation Memories** view where you can view the imported data and modify the segmentation rules.
IMPORTING TMX FILES INTO AN EXISTING TRANSLATION MEMORY

This section describes how to import TMX files into an existing SDL Trados Studio translation memory (*.sdltm) in SDL Trados Studio.

Before you Start

☐ If you want to import a number of TMX files, place them all in a single folder so that you can import the folder.

☐ Make sure that the translation memory you want to import data into, appears in the navigation tree in the Translation Memories view. If the translation memory is not in the navigation tree:

☐ Select File > Open > Open Translation Memory to open a file-based translation memory.

☐ Select File > Open > Server-based Translation Memory to open a server-based translation memory.
How to Import TMX Files into an Existing Translation Memory

To import a TMX file:

If you want to import a number of files, place them all in a single folder so that you can import the folder.

1. If you are not currently working in the Translation Memories view, click the Translation Memories button in the navigation pane to display the Translation Memories view.

2. In the navigation tree, select the translation memory you want to import data into.

   - If the translation memory does not appear in the navigation tree, select File > Open > Open Translation Memory or select File > Open > Server-based Translation Memory from the Ribbon.
3 Select **Home** tab > **Filters** group > **Import** (or you can right-click the translation memory and select **Import** from the shortcut menu).

**NOTE**
If it is a multilingual server-based translation memory, the option to import is only available if you select the language pair to which you want to import underneath the translation memory name on the navigation tree.

The **Import** wizard is displayed on the **Import Files** page.

4 Complete the **Import Files** page by selecting the files to be imported:

- If you want to select a single file, click **Add Files**.
- If you want to select a folder, click **Add Folder**.
- Continue selecting files until the list of files to be imported is complete.

Click **Next**.
The **TMX Import Options** are displayed:

![TMX Import Options dialog box](image)

5. If you want to filter out unwanted translation units from the import, click **Edit** to display the **Filter** dialog box where you create a filter to exclude the unwanted TUs. Only translation units that match the filter are imported.

6. Specify how you want the import to handle fields that exist in the translation unit being imported, but not in the translation memory you are importing to. Select one of the following options from the **Unknown Fields** drop-down list:

- **Add to translation memory** - When this option is selected, the translation unit and the unknown fields are added to the translation memory. The field is added to the translation memory settings and becomes available for all translation units in the translation memory.

- **Ignore** - When this option is selected, the translation unit is added to the translation memory but the unknown fields are not imported.

- **Skip translation unit** - When this option is selected, translation units containing unknown fields are not imported. Skipped translation units are not counted as errors in the import statistics.

- **Fail translation unit import** - When this option is selected, translation units that have unknown fields are not imported. Failed translation units are counted as errors in the import statistics. You can also choose to export these translation units to a separate TMX file, on the **General Import Options** page. See step 8.
When you upgrade a translation memory you can specify what data associated with the translation unit is removed or retained in your translation memory in order to optimize the leverage from your new upgraded translation memory. For more information, see *Compatibility with SDL Trados 2007 and SDLX 2007 Data* on page 5-11.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>The upgraded TM will be primarily used with new, native source files or files processed only with SDL Trados Studio</td>
<td>Imports a version of the translation memory that has had the associated data from a translation unit removed. You might want to do this, for example, if you are a translator and you receive files in their original (native) format with a legacy translation memory. In this case, removing the data associated with the translation unit will increase the leverage.</td>
</tr>
<tr>
<td>The upgraded TM will be primarily used with presegmented legacy SDL Trados ITD files and SDLX TTX files</td>
<td>Imports a version of the translation memory that retains the legacy translation unit data. You might want to do this, for example, if you are a translator and you receive a pre-segmented legacy bilingual file with a legacy translation memory. In this case, retaining the data associated with the translation unit will increase leverage.</td>
</tr>
</tbody>
</table>
| The upgraded TM will primarily used in mixed scenarios | Imports two versions of the translation unit, one where the data associated with the translation unit will be removed and another one where it retains the data. You might want to do this if:
- you want to permanently upgrade the translation memory and
- you are using legacy bilingual files and using bilingual files from SDL Trados Studio.

Selecting this option will maximize the translation memory leverage in all situations. |

Click Next.
The **General Import Options** page is displayed.

8 Complete the **General Import Options** page:

- **Apply Field Values** - If the translation memory you are importing into has custom fields, you can specify what values should be placed in these fields for the imported translation units. Click **Edit** to display the **Field Values** dialog box. For each field, specify or select a value and click **OK**.
Import translation units as plain text - When this option is selected, all formatting in the import file is ignored and the translation unit content is imported as plain text. This may be useful if you are importing translation units from an application that handles tags differently to SDL Trados Studio as the imported tag information would not display correctly in SDL Trados Studio. It is also useful if you are importing a TMX file that is from a third-party software that is version 1.4B or earlier.

Exclude language variants - When this option is selected, translation units for variants of the selected source and target language will not be imported. For example if you are importing into an English (United Kingdom) / German (Germany) translation memory and you select this option, any English (US) / German (Germany) translation units in the import file will not be imported.

Overwrite existing translation units - When this option is selected, translation units that have the same source text as an imported translation unit are replaced with the imported translation unit. This means that only the translated portion of the translation unit is replaced and therefore this prevents there being duplicate translations for the same source segment.

Export invalid translation units - When this option is selected, translation units that do not match the selections you have made on this page are not imported; they are saved to a *.tmx file. The TMX file can be imported later if you want. Click Browse to specify a location and name for the file.

Click Finish to display the Importing page. A progress bar is displayed as each task is run.

9 When data has finished importing into the translation memory. Click Close.
This chapter describes how to populate translation memories from bilingual documents. Topics include:

- Overview
- Why do this?
- Benefits and Limitations
- How to Import Bilingual Files to an Existing Translation Memory
- How to Import Bilingual Files to a Legacy Translation Memory and Upgrade the Translation Memory
OVERVIEW

This chapter gives instructions on how to populate SDL Trados Studio translation memories with content from bilingual documents from SDL Trados 2007 and SDLX 2007. You may want to do this in order to update your translation memory with previous translations to extract context information. It allows you to leverage information from previous translations and apply them to new translations. This chapter describes how to do this with the following bilingual formats:

- SDL Trados 2007 TTX
- SDLX 2007 ITD
- SDL Trados 2007 Bilingual Rich Text Format (RTF) - created when translating in Microsoft Word with SDL Trados Translator’s Workbench.

Why do this?

There are two reasons why you may want to do this:

- You can extract context information from the bilingual documents because of the sequence of the translation units. This can then be used in your translation memory for context matches.

**NOTE**

You can also use reuse the translations from bilingual documents by applying PerfectMatch. For more information, see Reuse Translations From Bilingual Documents in PerfectMatch on page 9-1.

- SDL Trados 2007 Bilingual Rich Text Format documents are created when translating in Microsoft Word with SDL Trados Translator’s Workbench and cannot be processed or opened in SDL Trados Studio. These files must first be cleaned up in SDL Trados Translator’s Workbench to create a legacy translation memory and then upgraded to the new translation memory format.
Benefits and Limitations

The key difference between importing bilingual files as opposed to TMX files is that bilingual files do not contain custom fields. However, a benefit to importing them is that you can extract context information which cannot be migrated in any other way than with bilingual files. This may lead to higher-quality matches. Also, tags and formatting can be extracted from bilingual files much more reliably than from TMX files.

The following table shows details what can be extracted from a bilingual file when populating a translation memory:

<table>
<thead>
<tr>
<th>Component</th>
<th>SDLX ITD Files</th>
<th>SDL Trados TTX Files</th>
<th>SDL Trados Word Bilingual Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>Translation Units</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Context Match Information</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Custom Fields and their Values</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
</tr>
<tr>
<td>System Fields</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
</tr>
<tr>
<td>Tags</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Segmentation Rules</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
</tr>
</tbody>
</table>
Two Methods

There are two different methods you can use to migrate your bilingual files to the SDL Trados Studio translation memory format (*.sdltm).

About Importing Bilingual Files to an Existing Translation Memory

This method can be used to import TTX and ITD files from SDL Trados 2007 and SDLX 2007.

The following diagram shows the steps you need to take to import bilingual files to an existing translation memory in SDL Trados Studio:
About Importing Bilingual Files to a Legacy Translation Memory and Upgrading the Translation Memory

This method is used for bilingual word documents from SDL Trados Translator’s Workbench that cannot be opened in SDL Trados Studio. Bilingual Rich Text Format (RTF) documents are created when translating in Microsoft Word with SDL Trados Translator’s Workbench and cannot be processed or opened directly in SDL Trados Studio. These files must first be cleaned up in SDL Trados Translator’s Workbench to create a legacy translation memory and then upgraded to the new translation memory format.

The following diagram shows the steps you need to take to import bilingual files to a legacy translation memory and upgrade the translation memory:
IMPORTING BILINGUAL FILES TO AN EXISTING TRANSLATION MEMORY

This section describes how to import bilingual files to an existing translation memory in SDL Trados Studio translation memory format (*.sdltm) using the Import wizard in SDL Trados Studio. You can import the following bilingual file formats:

- SDL Trados 2007 TTX
- SDLX 2007 ITD

Before you Start

- If you want to import a number of files, place them all in a single folder so that you can import the folder.
- Make sure that the translation memory you want to import data into, appears in the navigation tree in the Translation Memories view. If the translation memory is not in the navigation tree:
  - Select File > Open > Open Translation Memory to open a file-based translation memory.
  - Select File > Open > Server-based Translation Memory to open a server-based translation memory.
How to Import Bilingual Files to an Existing Translation Memory

To import a bilingual file:

1. If you are not currently working in the Translation Memories view, click the Translation Memories button in the navigation pane to display the Translation Memories view.

2. In the navigation tree, select the translation memory you want to import data into.

   - If the translation memory does not appear in the navigation tree, select File > Open > Open Translation Memory or select File > Open > Server-based Translation Memory.
3 Select Home tab > Filters group > Import (or you can right-click the translation memory and select Import from the shortcut menu).

**NOTE**

If it is a multilingual server-based translation memory, the option to import is only available if you select the language pair to which you want to import underneath the translation memory name on the navigation tree.

The Import wizard is displayed on the Import Files page.

4 Complete the Import Files page by selecting the files to be imported:

- If you want to select a single file, click Add Files.
- If you want to select a folder, click Add Folder.
- Continue selecting files until the list of files to be imported is complete.

Click Next.
The **Bilingual Document Import Options** are displayed:

The **Bilingual Document Import Options** page by identifying the segments you want to import. You do this by selecting the segment confirmation level (status). You can select multiple statuses. The following tables describes what the SDL Trados Studio statuses correspond to in SDL Trados TTX files and SDLX ITD files.

<table>
<thead>
<tr>
<th>SDL Trados Studio Status</th>
<th>SDL Trados (TTX) Status</th>
<th>SDLX (ITD) Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draft</td>
<td>Fuzzy Match, Machine Translated</td>
<td>n/a</td>
</tr>
<tr>
<td>Translated</td>
<td>100% Match, Manually Translated</td>
<td>Confirmed</td>
</tr>
<tr>
<td>Translation Approved</td>
<td>Context Match, PerfectMatch</td>
<td>Unconfirmed</td>
</tr>
</tbody>
</table>

5 Complete the **Bilingual Document Import Options** page by identifying the segments you want to import. You do this by selecting the segment confirmation level (status). You can select multiple statuses. The following tables describes what the SDL Trados Studio statuses correspond to in SDL Trados TTX files and SDLX ITD files.

**NOTE**

- If there is no origin attribute associated with a translation unit in a TTX file and the source and target text are the same, the status is set to Draft.

- For more information about the statuses in SDL Trados Studio, refer to the online help in SDL Trados Studio.
The **General Import Options** page is displayed.

![General Import Options dialog box](image)

6. Complete the **General Import Options** page:

- **Apply Field Values** - If the translation memory you are importing into has custom fields, you can specify what values should be placed in these fields for the imported translation units. Click **Edit** to display the **Field Values** dialog box. For each field, specify or select a value and click **OK**.

![Field Values dialog box](image)
Import translation units as plain text - When this option is selected, all formatting in the import file is ignored and the translation unit content is imported as plain text. This may be useful if you are importing translation units from an application that handles tags differently to SDL Trados Studio as the imported tag information would not display correctly in SDL Trados Studio. It is also useful if you are importing a TMX file that is from a third-party software that is version 1.4B or earlier.

Exclude language variants - When this option is selected, translation units for variants of the selected source and target language will not be imported. Since you are importing bilingual files, if you select this and your existing translation memory does not contain the same language variant, nothing will be imported.

Overwrite existing translation units - When this option is selected, translation units that have the same source text as an imported translation unit are replaced with the imported translation unit. This means that only the translated portion of the translation unit is replaced. This prevents there being duplicate translations for the same source segment.

Export invalid translation units - When this option is selected, translation units that do not match the selections you have made on this page are not imported; they are saved to a *.tmx file. The TMX file can be imported later if you want. Click Browse to specify a location and name for the file.

Click Finish to display the Importing page. A progress bar is displayed as each task is run.
When data has finished importing into the translation memory. Click **Close**.
IMPORTING BILINGUAL FILES TO A LEGACY TRANSLATION MEMORY AND UPGRADING THE TRANSLATION MEMORY

This section describes how to import legacy Bilingual Rich Text Format (RTF) files created when translating in Microsoft Word with SDL Trados Translator’s Workbench to legacy SDL Trados Translator’s Workbench. Then upgrade the translation memory to SDL Trados Studio translation memory format *.sdltm using the Upgrade Translation Memories wizard in SDL Trados Studio.

How to Import Bilingual Files to a Legacy Translation Memory and Upgrade the Translation Memory

To import a bilingual file to a legacy translation memory and upgrade the translation memory:

1. Use the Clean Up command for your bilingual word document in SDL Trados Translator’s Workbench to remove hidden source text, restore the original coloring of your text and to update the legacy translation memory.

   **NOTE**
   For more information, see the SDL Trados Translator’s WorkBench User Guide.

2. Upgrade your translation memory using the Upgrade Translation Memories wizard.
   For more information, see Upgrading Legacy Translation Memories on page 5-1.
This chapter describes how to populate SDL Trados Studio translation memories from legacy alignment result files created in SDL Trados WinAlign and SDL Align SDLX. Topics include:

- Overview
- Software Required for Upgrading Alignment Result Files
- Populating your Translation Memories from SDLX Alignment Results
OVERVIEW

This chapter describes how to populate SDL Trados Studio translation memories from legacy alignment result files. These are *.txt and *.iad files, generated from SDL WinAlign and SDL Align which have to be converted to the *.sdltm format in order to be used in Studio 2009-2014.

Starting with SDL Trados Studio 2014, a new integrated Alignment Tool is available which sends the alignment result directly to an *.sdltm translation memory. However, if you have used SDL WinAlign or SDL Align and you have legacy alignment results, you can use SDL Trados Studio 2014 to upgrade them to the SDL Trados Studio format. This allows you to continue to leverage matches from these files when you translate new documents in SDL Trados Studio 2014.

About Populating Translation Memories using SDL Trados WinAlign Alignment Results

SDL Trados WinAlign is the legacy alignment solution in SDL Trados Studio 2011 and SDL Trados 2007. WinAlign allows you to create translation memory data from existing translated documents but cannot send the segment pairs directly to an *.sdltm translation memory. Instead, it produces an Alignment Results file in a *.txt format which you have to manually convert to the *.sdltm format using the Upgrade Translation Memories wizard in SDL Trados Studio. For step-by-step instructions, see on page 8-3.

NOTE

*tmx files exported from SDL Trados WinAlign can also populate SDL Trados Studio translation memories. However, SDL recommends that you only use *.tmx files from SDL Trados WinAlign if you are working with Unicode only languages, such as Hindi and Maltese.

About Populating Translation Memories using SDLX Alignment Results

SDL Align is the alignment solution for SDLX 2007. It enables you to harvest translations from existing files and add them to an *.mdb translation memory in SDLX. You can upgrade the *.mdb translation memory to an SDL Trados Studio translation memory format (*.sdltm) using the Upgrade Translation Memories wizard in SDL Trados Studio. This means that valuable legacy files can be re-used, and consequently your efficiency and productivity maximized.

For step-by-step instructions, see Populating your Translation Memories from SDLX Alignment Results 8-7.
Software Required for Upgrading Alignment Result Files

The SDL Alignment Tool available in SDL Trados 2014 SP1 and later sends the translation units extracted from the aligned documents directly into an *.sdltm translation memory. You can then use *.sdltm translation memories in Trados Studio 2009, 2011 and 2014.

In contrast, legacy alignment tools like SDL Winalign and SDL Align which are available in older versions of SDL Trados Studio, send the extracted segment pairs to other translation memory formats which then need to be upgraded to the *.sdltm format.

To upgrade legacy alignment result files, make sure you have the application containing the alignment tool and SDL Trados Studio installed on your computer.

<table>
<thead>
<tr>
<th>To Upgrade</th>
<th>Software Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.txt files (exported from SDL WinAlign or WorkBench)</td>
<td>Any version of SDL Trados Studio 2014</td>
</tr>
<tr>
<td>*.mdb translation memories which contain the SDL Align results</td>
<td>SDLX 2007 and any version of SDL Trados Studio</td>
</tr>
</tbody>
</table>
Populating your Translation Memories from SDL Trados WinAlign Alignment Results

This section describes how to populate your SDL Trados Studio translation memories (*.sdltm) with SDL Trados WinAlign Export *.txt files. You may want to do this if you have alignment result files created in WinAlign and you want to use this translation data in SDL Trados Studio 2014.

Upgrade SDL Trados WinAlign Legacy Files Process

The following diagram shows the steps you need to take to populate your SDL Trados Studio translation memories with SDL Trados WinAlign Export *.txt files.
How to Populate your Translation Memories from SDL Trados WinAlign Export TXT Files

1. Open SDL Trados Studio and select Home tab > Tools group > Upgrade Translation Memories. The Upgrade Translation Memories wizard is displayed on the Input Translation Memories page.

![Upgrade Translation Memories Wizard in SDL Trados Studio](image)

2. Select your SDL Trados WinAlign export *.txt files:

   - Click Add File-based TMs. The Select Input Translation Memories dialog box is displayed. Select the SDL Trados WinAlign export *.txt files and click Open.
The TXT Conversion dialog box is displayed. Click OK to convert your *.txt file to the intermediate *.tmw format.

The files are displayed on the Input Translation Memories page as intermediate *.tmw files.

The process of upgrading the intermediate *.tmw files to SDL Trados Studio translation memory format (*.sdltm) is identical to upgrading process described in chapter 5. For more information, see How to Upgrade your Legacy Translation Memories on page 5-15.
POPULATING YOUR TRANSLATION MEMORIES FROM SDLX ALIGNMENT RESULTS

This section describes how to populate your SDL Trados Studio translation memories (*.sdltm) with SDLX 2007 translation memories created from SDL Align (SDLX) alignment results.

Upgrade SDL Align Legacy Files Process

The following diagram shows the steps you need to take to populate your translation memories in SDL Trados Studio using legacy SDL Align files.

Upgrade your translation memories to Studio translation memory format (*.sdltm) using the Upgrade Translation Memories wizard in SDL Trados Studio. This process is identical to upgrading process described in chapter 5. For more information, see How to Upgrade your Legacy Translation Memories on page 5-15.
REUSE TRANSLATIONS FROM BILINGUAL DOCUMENTS IN PERFECTMATCH

This chapter describes how to use translations from bilingual documents for PerfectMatch in SDL Trados Studio. Topics include:

- Overview
- About PerfectMatch
- Why Use PerfectMatch?
- PerfectMatch Process
- PerfectMatch Options
- About Selecting Bilingual Files
- Applying PerfectMatch
OVERVIEW

This chapter gives instructions on how to extract translations from previously translated bilingual documents from SDL Trados 2007 and SDLX 2007 and transfer them to SDL Trados Studio project files. This is accomplished by applying PerfectMatch to your project in SDL Trados Studio. It allows you to leverage information from previous translations and apply them to new translations. This chapter describes how to do this with the following bilingual formats:

- SDL Trados 2007 TTX
- SDLX 2007 ITD
- SDL Trados Studio SDL XLIFF

About PerfectMatch

A PerfectMatch is a form of context match that compares updated source files to a corresponding set of existing bilingual documents rather than to a translation memory. Segment matches, known as PerfectMatches, are checked for context, that is, the surrounding entries are checked to ensure that they are the same. In addition, if your existing bilingual document was segmented differently to the current document or had merged segments, PerfectMatch can dynamically merge up to three consecutive segments in your current document to improve your match results. The translations are then extracted from the existing bilingual documents and transferred to the updated source files.

Because the PerfectMatch segment matching process includes a check for context and segmentation, PerfectMatch units typically need no further translation or editing during translation.

NOTE

Your license for SDL Trados Studio may or may not include this feature. See the About Editions and Licensing topic in the SDL Trados Studio Help for information about your license features.
Why Use PerfectMatch?

You can extract context information from the bilingual documents because of the sequence of the translation units. Since the translations are inserted directly to the new project files as opposed to a translation memory, it completely eliminates the requirement for in-context 100% match review and requires no further editing.

Scenarios

There are several scenarios where you might want to apply PerfectMatch:

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pre-Project</td>
<td><strong>Scenario A:</strong> At the start of a project, you can base a new project on an existing project that has been fully reviewed. This will use the translated bilingual files from the previous project for PerfectMatch. For example, this could be useful if you are starting translation on a technical manual for a second version of a product where the product is almost the same as the first version. <strong>Scenario B:</strong> If you have two sets of previously translated files that you want to use to apply PerfectMatch to the new project, you can do this by running the PerfectMatch task twice. To do this, select one set of translated files for PerfectMatch in the New Project wizard and then PerfectMatch is automatically applied when the project is created. After the project is created, run the Apply PerfectMatch task and add the second set of translated files.</td>
</tr>
</tbody>
</table>

NOTE

To give first priority to the PerfectMatch translations and not overwrite them when you pre-translate, you need to remove the Pre-translate task from the Prepare/Prepare without Project TM task sequence that is run as part of project creation. Then run the Pre-translate task after you apply PerfectMatch for the second time.
<table>
<thead>
<tr>
<th>Scenario</th>
<th>Description</th>
</tr>
</thead>
</table>
| Mid-Project   | **Scenario A:**  
If you are part of the way through translating a project and you receive a new set of source files that have been slightly modified, you can use PerfectMatch to easily apply the work you have already translated to the new set of documents.

This can be accomplished by creating a new project with the new set of files and basing it on the project you are in the middle of translating. PerfectMatch will then automatically apply all of your existing work to the new set of files.

**Scenario B:**  
If you have already created a project and you receive some previously translated files, you can use PerfectMatch to leverage the translations from those files even though you have already started the project.

This can be accomplished by running the **Apply PerfectMatch** task.

**Scenario C:**  
If you have already created a project and applied PerfectMatch, and then you receive additional files that need to be translated, you can apply PerfectMatch to just those files.

This can be accomplished by running the **Prepare/Prepare without Project TM** task sequence and selecting the previously translated files for PerfectMatch.
PerfectMatch Process

This is one example of how PerfectMatch can be used when you create a project. You can also apply PerfectMatch to an existing project. For more information, see Applying PerfectMatch on page 9-10.
PerfectMatch Options

You can specify the translation origin and status that is used for translations taken from previously translated bilingual files. This is specified on the SDL PerfectMatch page in the New Project wizard or the Batch Processing wizard.

Apply PerfectMatch and lock

If you are applying PerfectMatch in the Pre-Project scenario where the translations were taken from a previously reviewed project, you would typically want these to appear as a PerfectMatch and be locked as there would be no need to edit those translations.

Only segments that have a status of Translated, Translation Approved and Signed Off will be applied to the new project files.

Use the original translation origin and status

If you are applying PerfectMatch in the Mid-Project scenario where translations were taken from bilingual files that have not yet been fully translated or reviewed, you would typically want the translations to appear with the original origin, confirmation level and score.

For example, if it was a draft translation with a 95% match, you would not want that translation to be locked as PerfectMatch but to be able to finish translating the segment and confirm the translation.
NOTE

If the files to which you are applying PerfectMatch already have confirmed or edited translations, they will not be overwritten. PerfectMatch will only overwrite the target content if:

- The target has a status of Not Translated.
- The target is a copy of the source and has not been edited manually or confirmed.

About Selecting Bilingual Files

To apply PerfectMatch you need to pair the previously translated bilingual files with the new project files. There are several different methods for doing this.

Selecting Files when you have Matching File Names

If the files in your new project have the same file names and path location within the project as the files in the previous project, you can select files using the following methods. This ensures that the bilingual files are automatically paired with the new project files.

- Base your project on a previous project
- Automatically search a folder for bilingual files

NOTE

If you choose to select your bilingual files by automatically searching a folder, it will only use the first type of bilingual file that it matches to the first project file in the list for all of the project files. For the first project file it searches in this order: SDL XLIFF, TradosTag TTX and then SDL Edit ITD. For example, if there is a matching SDL XLIFF file for the first project file, it will only look for matching SDL XLIFF files for the remaining project files.

Selecting Files when you have Different File Names

If the file names in your new project are different to the file names in the previous project, select the files using the following methods to pair the bilingual files with the new project files.

- Manually add previous bilingual files
- Add files using a bilingual map file
About Map Files

Map files are used when applying PerfectMatch to your project files. The map files allow you to map files in the new project to the translated bilingual files in the previous project. This is useful if you have a large amount of files to which you want to apply PerfectMatch and the file names have changed in the new project. Using map files avoids having to add each previous bilingual file manually for every project file in the new project.

Map File Format

Map files are tab delimited text files (TXT). A separate map file is required for each target language in the project. Each line in the file is made up of two components.

Component 1:

The path relative to the new project folder and the file name of the file in the new project.

For example, if you created the folder structure shown below on the Project Files page of the New Project wizard, the path would be the following:

Samples Folder A\SampleFileAV1.docx

If you did not create a folder structure under the project, then you would just put the file name:

SampleFileAV1.docx
Component 2:

The absolute path and file name of the bilingual translated file from the previous project:

C:\Users\jsmith\Documents\Studio 2014\Projects\Project 7\de-DE\SampleFileAV2.docx.ttx

Map File Example

<table>
<thead>
<tr>
<th>Sample Folder A</th>
<th>Sample File AV1.docx</th>
<th>C:\Users\jsmith\Documents\Studio 2014\Projects\Project 7\de-DE\SampleFileAV2.docx.ttx</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample Folder B</td>
<td>Sample File BV1.docx</td>
<td>C:\Users\jsmith\Documents\Studio 2014\Projects\Project 7\de-DE\SampleFileBV2.docx.ttx</td>
</tr>
<tr>
<td>Sample Folder C</td>
<td>Sample File CV1.docx</td>
<td>C:\Users\jsmith\Documents\Studio 2014\Projects\Project 7\de-DE\SampleFileCV2.docx.ttx</td>
</tr>
</tbody>
</table>

Map File Creation

Bilingual map files can be created in any application that can produce tab delimited files, such as Microsoft Excel or another text editor. You can create the content of the files manually (by typing or copy/pasting the file paths) or you may have another application or script that can automatically generate the content.
APPLYING PERFECTMATCH

PerfectMatch can be applied when a project is created or to files in an existing project. To determine which procedure to follow, see Why Use PerfectMatch? on page 9-3.

- For information on how to create a new project and apply PerfectMatch, see How to Apply PerfectMatch to a New Project on page 9-11
- For information on how to apply PerfectMatch to an existing project, see How to Apply PerfectMatch to an Existing Project on page 9-15

Before you Start

If you are using previously translated TradosTag (TTX) files, you should disable smart tag pairing and use the compatibility mode to improve the leverage you get from the bilingual files. For more information, see Compatibility Setting for TTX on page 11-3.

To use the compatibility mode:

1. Select File > Options from the Ribbon. The Options dialog box is displayed. This is where you can specify your default file type settings.

   **NOTE**
   If you are working with an existing project, you should do this in the Project Settings dialog box.

2. Select File types > TRADOStag > Compatibility from the navigation tree. The Compatibility settings are displayed on the right.
3 Select the **Treat all inline tags as placeholders** option to use compatibility mode.

4 Click **OK** to close this dialog box.

**How to Apply PerfectMatch to a New Project**

If you create a project where the project files are closely related files that have been translated previously, for example previous versions of the same file, and you have the bilingual files that were produced at that time, PerfectMatch can extract translations from the bilingual files and apply them to the new project files. You can select these files by basing the project on a previous project on the Project Type page or by explicitly selecting the files on the SDL PerfectMatch page of the New Project wizard.

**Step 1: Display the New Project Wizard**

1 Click the **New Project** button. The **New Project** wizard is displayed.

2 Follow the on screen instructions to create the project and follow the instructions below in steps 2 and 3 to set up PerfectMatch in the **New Project** wizard.
Step 2: Select the Previously Translated Bilingual Files

To apply PerfectMatch, you need to pair the previously translated bilingual files with the new project files.

Selecting Files when you have Matching File Names

If the files in your new project have the same file names and path location within the project as the files in the previous project, you can select files using the following methods.

Method 1: Base your Project on a Previous Project

1. Display the Project Type page of the New Project wizard.

2. Select the Create a project based on a previous project option and then select the previous project from the drop-down list.

Method 2: Automatically Search a Folder for Bilingual Files

1. Display the SDL PerfectMatch page of the New Project wizard.
2 Select the target language to which you want to add previous bilingual files, click Add and then select Matching Previous Documents from Folder.

3 Browse to the required location, select the folder and click OK. The New Project wizard searches the folder and all sub-folders for matching previous bilingual files automatically and adds these to your project.

**NOTE**

- Even though you have selected a specific target language, the wizard will still add any matching bilingual files that it finds for the other target languages in your folder.
- If the wizard finds other bilingual files that do not match the file names in your project, it displays an error message stating the number of files it has been unable to add out of the number of files found.

**Selecting Files when you have Different File Names**

If the file names in your new project are different to the file names in the previous project, select the files using the following methods to pair the bilingual files with the new project files.

**Method 1: Manually Add Previous Documents**

1 Display the SDL PerfectMatch page of the New Project wizard.
2 Select the target language to which you want to add previous bilingual files.

3 Select the file under the Project File column for which you want to add a previous bilingual file, click Add and then select Specific Previous Document.

4 Browse to the required location, select the previous bilingual file and click Open.

The previous bilingual file is displayed in the Previous Document column next to the corresponding project file.

**Method 2: Add Previous Documents Using a Map File**

1 Display the SDL PerfectMatch page of the New Project wizard.

2 Select the target language to which you want to add previous bilingual files, click Add and then select Previous Documents from Map.

3 Browse to the required location, select the map file and click Open.

The previous bilingual files are displayed in the Previous Document column next to the corresponding project file.

**Step 3: Select your PerfectMatch options:**

Decide what translation origin and status to use for the translations that are extracted from the previously translated files and applied to the new project files. For more information about these options and the scenarios in which you would use them, see Scenarios on page 9-3.

1 Display the SDL PerfectMatch page of the New Project wizard.

2 Under Translation transfer options, select one of the following options:

- **Apply PerfectMatch and lock**: Use this option if you are applying PerfectMatch from a project that has fully reviewed translations. This will mark all approved translations as PerfectMatch with a status of Signed Off.

- **Use the original translation origin and status**: Use this option if you want to use the same status and translation origin as the original document.

The previously translated bilingual files are displayed in the Previously Translated File column next to the corresponding project file.
How to Apply PerfectMatch to an Existing Project

If you have already created a project which has project files that are closely related files that have been translated previously, for example previous versions of the same file, and you have the bilingual files that were produced at that time, PerfectMatch can extract translations from the bilingual files and apply them to the new project files.

Step 1: Display the Batch Processing Wizard

1. Select the project files to which you want to apply PerfectMatch in the Files view, and right-click and select Batch Tasks > Apply PerfectMatch. The Batch Processing wizard is displayed.

2. Click Next to display the SDL PerfectMatch page.

Step 2: Select the Previously Translated Files

To apply PerfectMatch, pair the previously translated files with the new project files.

Selecting Files when you have Matching File Names

If the files in your new project have the same file names and path location within the project as the files in the previous project, you can select files by automatically searching for them.

1. On the SDL PerfectMatch page, select the target language to which you want to add previous bilingual files, click Add and then select Matching Previous Documents from Folder.

2. Browse to the required location, select the folder and click OK. The Batch Processing wizard searches the folder and all sub-folders for matching previous bilingual files automatically and adds these to your project.
NOTE

- Even though you have selected a specific target language, the wizard will still add any matching bilingual files that it finds for the other target languages in your folder.

- If the wizard finds other bilingual files that do not match the file names in your project, it displays an error message stating the number of files it has been unable to add out of the number of files found.

Selecting Files when you have Different File Names

If the file names in your new project are different to the file names in the previous project, select the files by manually adding them.

1. On the SDL PerfectMatch page, select the target language to which you want to add previous bilingual files.
2. Select the file under the Project File column for which you want to add a previous bilingual file, click Add and then select Specific Previous Document.
3. Browse to the required location, select the previous bilingual file and click Open.

The previous bilingual file is displayed in the Previous Document column next to the corresponding project file.

Step 3: Select your PerfectMatch options:

Decide what translation origin and status to use for the translations that are extracted from the previously translated files and applied to the new project files. For more information about these options and the scenarios in which you would use them, see Scenarios on page 9-3.

1. Display the SDL PerfectMatch page of the New Project wizard.
2. Under Translation transfer options, select one of the following options:
   - Apply PerfectMatch and lock: Use this option if you are applying PerfectMatch from a project that has fully reviewed translations. This will mark all approved translations as PerfectMatch with a status of Signed Off.
   - Use the original translation origin and status: Use this option if you want to use the same status and translation origin as the original document.

The previously translated bilingual files are displayed in the Previous Document column next to the corresponding project file.
This chapter describes how to migrate tag settings (INI) and analysis (ANL) files from SDL Trados and SDLX to SDL Trados Studio. Topics include:

- Overview
- Why Migrate your Tag Settings and Analysis Files?
- What Types of Files can you Migrate?
- What is Migrated?
- How to Migrate INI and ANL Files for XML
- How to Migrate INI Files for HTML
OVERVIEW

This chapter describes how to migrate your SDL Trados INI and SDLX ANL files to SDL Trados Studio. These files contain information about the elements and entities in the file, and how these should be handled during the translation process. They enable SDL Trados Studio to format documents appropriately, separating tag content from translatable text, classifying tags as inline or structure, and converting specified entities.

These tag and filter settings are migrated by importing the INI and ANL files into an existing file type or a new file type in SDL Trados Studio. The file type format used in SDL Trados Studio is *.sdlfiletype. This provides one consistent format for all tag and filter settings.

Why Migrate your Tag Settings and Analysis Files?

Migrating these settings will allow you to reuse the rules you previously had about translatable and untranslatable content for your XML and HTML files.

What Types of Files can you Migrate?

- Tag Settings Files (SDL Trados INI)
- SDLX Analysis Files (ANL) - (Only supported for migrating to XML and not HTML file types)

NOTE

This chapter only describes how to migrate legacy tag settings and analysis files. For information on general XML support including defining settings based on XSD, XML and other files, refer to the online Help in SDL Trados Studio.

The following table describes what versions of INI and ANL files are supported in SDL Trados Studio:

<table>
<thead>
<tr>
<th>Version</th>
<th>INI</th>
<th>ANL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trados 2007 Suite</td>
<td>Yes</td>
<td>n/a</td>
</tr>
<tr>
<td>Trados 2007 SP2</td>
<td>Yes</td>
<td>n/a</td>
</tr>
<tr>
<td>Trados 2006 (7.x)</td>
<td>Yes</td>
<td>n/a</td>
</tr>
<tr>
<td>SDLX 2007</td>
<td>n/a</td>
<td>Yes</td>
</tr>
<tr>
<td>SDLX 2006</td>
<td>n/a</td>
<td>No</td>
</tr>
<tr>
<td>SDLX 2005</td>
<td>n/a</td>
<td>No</td>
</tr>
</tbody>
</table>
What is Migrated?

The components that are imported from ANL and INI files can vary depending on if you are importing to an XML file type or HTML file type. In addition, you cannot import ANL files to an HTML file type.

About Migrating INI and ANL Files for XML

When you migrate settings for XML files, SDL recommends creating a new file type and then importing the INI or ANL file. The following table describes the individual components that are imported from your ANL and INI files:

<table>
<thead>
<tr>
<th>Component</th>
<th>SDLX ANL Files</th>
<th>SDL Trados INI Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parser Rules</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Formatting</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Customized Tag Toolbar Settings</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Root Elements and DOCTYPE Declarations for File Detection</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Entity Conversion Settings</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Namespace Declarations</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>xml:lang Settings</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>UTF-8 BOM Settings</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>
When you import a settings file for XML, the following settings are affected by the import:

- **Parser rules** - The parser rules specify the structure of XML files for SDL Trados Studio. For example, they determine what content is translatable text and what is non-translatable. SDL Trados Studio uses the parser rules to process XML files. Each XML file type has a different set of parser rules.

- **Writer settings** - This specifies the META charset and the UTF-8 BOM handling in the target file.

- **File detection** - When SDL Trados Studio opens an XML file, it matches the file detection settings and the file contents to determine the type of XML of the open file.

**About Migrating INI Files for HTML**

To migrate settings for HTML files, create a new HTML file type and import the settings to it. You can only migrate settings from SDL Trados INI files.

**NOTE**

The default HTML settings are the same as default settings defined in the INI files in SDL Trados 2007. You only need to migrate these settings if you have made changes to them in SDL Trados 2007.

The following table describes the individual components that are imported in your INI files:

<table>
<thead>
<tr>
<th>Component</th>
<th>SDL Trados INI Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parser Rules</td>
<td>Yes</td>
</tr>
<tr>
<td>Formatting</td>
<td>No</td>
</tr>
<tr>
<td>Customized Tag Toolbar Settings</td>
<td>Yes</td>
</tr>
<tr>
<td>DOCTYPE Declarations for File Detection</td>
<td>Yes</td>
</tr>
<tr>
<td>Entity Conversion Settings</td>
<td>Yes</td>
</tr>
</tbody>
</table>

- **Element and attributes** - Rules that manage how SDL Trados Studio manages HTML elements and attributes. It defines for each element, what sort of element it is, and what attributes, if any, of the element are translatable.
- **Entity conversion** - This specifies how character entities are displayed during translation. If a character entity is selected for conversion, SDL Trados Studio displays the character during translation, then re-encodes the character into its entity reference form, which it inserts into the translated file. For example if the character entity is `&gt;`, then the translator sees the character `>`, and the translated character is encoded as entity `&gt;`. If a character entity is not selected for conversion, the entity reference, rather than the character, is displayed as a placeholder tag.

- **Writer** - This specifies the META charset in the target file.

- **File detection** - When SDL Trados Studio opens an HTML file, it matches the file detection settings and the file contents to determine the type of HTML of the open file.
MIGRATING INI AND ANL FILES FOR XML

This section describes how to migrate your SDL Trados INI files and SDLX ANL files to SDL Trados Studio for XML. You can migrate these settings by creating a new XML file type into which you can then import the files containing the rules.

Use the Options dialog box to set up your default file type settings. These settings are used every time you create a new project.

NOTE

You can also import INI and ANL settings to an existing XML file type. For more information, refer to the online Help in SDL Trados Studio.

How to Migrate INI and ANL Files for XML

To migrate INI and ANL files for XML you need to perform the following steps:

1. Step 1: Display the Options Dialog Box
2. Step 2: Create a New XML File Type
3. Step 3: Choose the File Order
4. Step 4: Modify the Imported Settings
Step 1: Display the Options Dialog Box

1. Select File > Options from the Ribbon. The Options dialog box is displayed.

2. Select File Types from the navigation tree. The File Types page is displayed on the right.
Step 2: Create a New XML File Type

1. On the File Types page, click New. The Select Type dialog box is displayed:

2. Select XML and click OK. The Create File Type wizard is displayed on the File Type Information page.

3. Complete the File Type Information page.

   - File type name - This is a mandatory setting. Change the file type name and enter a suitable description.
Optionally, complete the other settings on this page. For more information, refer to the online Help in SDL Trados Studio.

4. Click **Next**. The **XML Settings Import** page is displayed:

![XML Settings Import dialog box](image)

5. Select your INI or ANL file to import:
   - Select **Define settings based on INI, ANL, XML, XSD, ITS or DTD rule file**.
   - Click **Browse**. The **Import settings** dialog box is displayed.
   - Select the INI or ANL file and click **Open**. The **XML Settings Import** page is displayed again with the settings file selected.
6 Click **Next**. The **Parser Rules** page is displayed. All of the rules from the imported INI or ANL file are displayed on this page:

![Parser Rules page](image)

7 Check the **Parser Rules** page to ensure your rules imported correctly.

- If you want to edit any of the rules, select the rule and click **Edit**. The **Edit Rule** dialog is displayed. You can modify the rules here.

- Make the required changes and click **OK** to close the **Edit Rule** dialog box. The **Parser Rules** page is displayed again.

**NOTE**

You can also modify rules after you create the XML file type.
In SDL Trados Studio, structure tags are not visible to the translator. Therefore you need to provide context information that allows translators to see where in a document the text they are translating exists. For example, that a structure tag is a heading or list item.

8 Specify the context information for your structure tag rules:

- Select a rule on the Parser Rules page that has a tag type of Structure and click Edit. The Edit Rule dialog is displayed.

- Click the Edit button located next to the Structure info box. The Structure Information Properties dialog box is displayed.
10 Click **Add**. The **Add Structure Information** dialog box is displayed:

![Add Structure Information dialog box](image)

- From the **Standard** drop-down list, select the context of the structure tag. For example, select **Heading**.
- Click **OK** three times to close the dialog boxes and return to the **Parser Rules** page of the **Create File Type** dialog box.

9 Click **Next**. The **File Detection** page is displayed. The settings here determine what criteria is used for XML documents to be recognized as this file type.

![File Detection dialog box](image)

10 Edit the settings on this page as needed and click **Next**.
NOTE

For more information about the different settings, refer to the online Help in SDL Trados Studio.

Step 3: Choose the File Order

On the File Types page the order of the files is important. Your new file type will be added to the top of the page under SDL XLIFF. When you add a file to a project or open a file for translation, SDL Trados Studio searches this list starting at the top, and working its way downwards. It processes a file as the first file of the type which matches.

1. Click File Types on the navigation tree. Your new file type is displayed in the list on the Files Types page on the right-hand side of the Options dialog box.

2. Select the new XML file type and use the Move Up and Move Down buttons to specify where the file type should be located on the list.
Step 4: Modify the Imported Settings

The settings you imported can be viewed on pages under the new file type on the navigation tree:

![Image of settings page]

1. Modify the imported settings on the following pages as needed:

   - **Detection** - The imported settings on how SDL Trados Studio identifies when a file is this file type.
   - **Parser rules** - The imported rules checks each XML element in the document against the specified conditions to determine what content should be extracted for translation.
   - **Writer** - The imported settings on how Studio saves the target XML file.
   - **Entities** - The imported settings on how Studio displays character entities to translators.
   - **Namespaces** - The imported namespace declarations for the XML file type.
   - **Whitespace** - The imported settings on how Studio handles the extra whitespace characters found inside the XML elements.
- **Preview** - The imported settings on how Studio handles adding style sheets for previewing XML documents.

- **Validation** - The imported schemas and DTDs used for validation, and for specifying when Studio performs the validation (during the file detection stage, or when the translator requests it).

- **Embedded content** - The imported settings for extracting and converting embedded content into tags in the output document. These settings also specify whether these tags are translatable or non-translatable.

- **QuickInsert** - The imported QuickInsert items available the XML file type. These settings are only imported from INI files and not ANL files. On the QuickInsert page, you can modify the QuickInsert group which is available in the Editor view. The QuickInsert group contains buttons that you can use to quickly add formatting or insert special characters, into the target XML documents.

**NOTE**

- For more information on exactly what is imported, see *About Migrating INI and ANL Files for XML* on page 10-3.

- For more information on what file type settings you can specify, refer to the online Help in SDL Trados Studio.
MIGRATING INI FILES FOR HTML

This section describes how to migrate your SDL Trados INI files to SDL Trados Studio for HTML. You can migrate these settings by creating a new HTML file type into which you can then import the files containing the rules.

Use the Options dialog box to set up your default file type settings. These settings are used every time you create a new project.

NOTE
The default HTML settings are the same as default settings defined in the INI files in SDL Trados 2007. You only need to migrate these settings if you have made changes to them in SDL Trados 2007.

How to Migrate INI Files for HTML

To migrate INI files for HTML you need to perform the following steps:

1. Step 1: Display the Options Dialog Box
2. Step 2: Create a New HTML File Type
3. Step 3: Choose the File Order
4. Step 4: Modify the Settings
Step 1: Display the Options Dialog Box

1. Select **File > Options**. The **Options** dialog box is displayed:
Step 2: Create a New HTML File Type

1. On the File Types page, click New. The Select Type dialog box is displayed:

![Select Type dialog box]

2. Select HTML and click OK. The Create File Type wizard is displayed on the File Type Information page:

![Create File Type wizard]

3. Complete the File Type Information page.

- **File type name** - This is a mandatory setting. Change the file type name and enter a suitable description.
Optionally, complete the other settings on this page. For more information, refer to the online Help in SDL Trados Studio.

4 Click Next. The HTML Elements Import page is displayed:

5 Select your INI file to import:
   - Select Define HTML elements based on SGML, HTML, XML, XSD, DTD or INI rule file.
   - Click Browse. The Open dialog box is displayed.
   - Select the INI file and click Open. The HTML Elements Import page is displayed again with the settings file selected.
6 Click **Next**. The **Parser settings** page is displayed with all the rules from the imported INI file:

![Parser settings page](image)

7 Check the **Parser settings** page to make sure your rules are imported correctly.

- If you want to edit any of the rules, select the rule and click **Edit**. The **Edit Rule** dialog is displayed. You can modify the rules here.

- Make the required changes and click **OK** to close the **Edit Rule** dialog box. The **Parser settings** page is displayed again.

   **NOTE**
   You can also modify rules after you create the HTML file type.

8 Click **Next** and edit the settings for the HTML file type on the pages of the **Create File Type Wizard** as needed.

   **NOTE**
   For more information about the different settings, refer to the online Help in SDL Trados Studio.
9  Click **Finish** to create the new HTML file type with your migrated INI file.

The file type is added to the list of file types in the navigation tree in the **Options** dialog box and list of files on the **File Types** page.
Step 3: Choose the File Order

On the File Types page the order of the files is important. Your new file type will be added to the top of the page under SDL XLIFF. When you add a file to a project or open a file for translation, SDL Trados Studio searches this list starting at the top, and working its way downwards. It processes a file as the first file type which matches. The new file type is added to the list.

1. Select your new HTML file type on the File Types page and use the Move Up and Move Down buttons to specify where the file type should be located on the list.
Step 4: Modify the Settings

The settings you imported can be viewed on pages under the new file type on the navigation tree:

1. Modify the imported settings on the following pages as needed:

   - **Detection** - The imported setting detects the documents to which Studio should apply the HTML file type settings.
Migrating INI Files for HTML

- **Parser** - The imported settings check each HTML element in the document against your specified conditions to determine what content should be extracted for translation.

- **Writer** - The imported settings on how Studio saves the target HTML file.

- **Entities** - The imported settings on how Studio displays character entities found inside HTML elements.

- **Whitespace** - The imported settings on how Studio handles the extra whitespace characters found inside the HTML elements.

- **Preview** - The imported settings on how Studio handles adding style sheets for previewing HTML documents.

- **QuickInsert** - The imported QuickInsert items available the HTML file type. On this page, you can modify the QuickInsert group in the Editor view. The QuickInsert group contains buttons that you can use to quickly add formatting or insert special characters, into the target HTML documents.

**NOTE**

- For more information on exactly what is imported, see *About Migrating INI Files for HTML* on page 10-4.

- For more information on what file type settings you can specify, refer to the online Help in SDL Trados Studio.
HOW TO WORK WITH THE TRANSLATION SUPPLY CHAIN WITH STUDIO 2014 SP2 (TTX AND BILINGUAL DOC FILES)

This chapter describes how to work in a workflow with some users using SDL Trados Studio and some using SDL Trados 2007. Topics include:

- Overview
- TTX Files, Bilingual Microsoft Word Files vs. SDL XLIFF Files
- Compatibility Setting for TTX
- Scenarios
OVERVIEW

This chapter provides information about the best practices to use in SDL Trados Studio when working with the legacy TradosTag (TTX) and bilingual RTF formats produced by previous SDL Trados versions.

It explains the various scenarios that may occur and provides extensive information on how to make use of the many new SDL Trados Studio features whilst still being able to satisfy your customer requirements by providing backward compatible TTX files and translation memories for as long as these legacy formats are still required.

TTX Files, Bilingual Microsoft Word Files vs. SDL XLIFF Files

SDL Trados 2007 featured two main ways of working:

- When pre-translating files in SDL Trados Translator’s Workbench or SDL Trados Synergy, or when opening files for translation in SDL Trados TagEditor, the file was converted to a bilingual format for translation. This file format was referred to as TTX (TradosTag XML).

- When using SDL Trados Translator’s Workbench with Microsoft Word, all files were converted to bilingual Rich Text Format (RTF). If the file was in native Microsoft Word *.doc format, this process happened behind the scenes.

When you open a document for translation or create a project in SDL Trados Studio, files are converted to SDL XLIFF, a new generation of a bilingual format that is more powerful, flexible and standards-based than TTX. SDL XLIFF stands for SDL XML Localization Interchange File Format. It is an XML-based bilingual file format, specially developed for use in localization. SDL XLIFF files are compliant with version 1.2 of the XLIFF standard. For more information on XLIFF files, refer to:

http://xml.coverpages.org/xliff.html
BEFORE YOU START: OPTIONS FOR TTX SUPPORT

There are two settings that you can specify prior to working with TTX files in SDL Trados Studio:

- Compatibility Setting
- Tag Verification Settings

Compatibility Setting for TTX

SDL Trados Studio 2014 can work with TTX using two modes:

- Smart tag pairing mode
- Compatibility mode

In smart tag pairing mode, SDL Trados Studio attempts to convert tags in the TTX so that they have an opening and closing tag in the TTX file and become a tag pair in SDL Trados Studio. It also attempts to preserve the semi-WYSIWYG formatting from TTX. In addition, an opening tag in a TTX file may not have a closing tag in the same segment. This is no longer supported in SDL Trados Studio, so in these cases SDL Trados Studio inserts an extra closing tag to ensure the integrity of all tag pairs.

Figure 11.1 - Smart Tag Pairing Mode: Tag pairs in a TTX file in SDL Trados Studio
This smart tag pairing approach will work in most cases, providing for more user-friendly translation of TTX files. However, occasionally in instances where you have used smart tag pairing, the conversion back to TTX files may fail. If this happens, SDL recommends that you activate the compatibility mode for TTX as shown below. In this mode, all tags from the TTX files become placeholder tags ( ) during translation in SDL Trados Studio. Each tag in the TTX file will correspond to exactly one tag in SDL Trados Studio, with no extra tags inserted. In addition, formatting from the source file will not be shown in SDL Trados Studio. This approach ensures the maximum possible tag integrity and maximum legacy support for TTX:

Figure 11.2 - Compatibility Mode: Placeholder tags and no formatting in a TTX file in SDL Trados Studio

The TTX compatibility setting can also affect translation memory matching when tag pairs start or end outside a segment. With smart tag pairing, a matching start or end tag is included in the segment in SDL Trados Studio. This results in better translation memory reuse across file formats when using other SDL Trados Studio file types, and also ensures safe tag pair handling (a starting bold tag will always have a matching end bold tag). These matching tags are not created in compatibility mode as the new safe tag pairing feature was not available in SDL Trados Translator’s Workbench and SDL Trados TagEditor. Choosing compatibility mode may therefore result in better reuse with translation memories originating from SDL Trados 2007.

How to Determine What Compatibility Setting to Select

Before you start work on TTX files, it is useful to test TTX compatibility to determine whether to enable or disable smart tag pairing by doing a translation test of a representative TTX file from your project. To do this:

1. Click File > Open > Translate Single Document in any view to open the TTX file in SDL Trados Studio.

2. In the Editor view, press [Alt]+[Shift]+[InsCopy] to copy all source segments to target segments in SDL Trados Studio.
3 Select **File > Save As Target**. The **Select File Type** dialog box is displayed. Save the target version in its native format (original file format) and a TRADOStag (TTX) file. This works for all file formats that are supported in SDL Trados 2007, including customizable file formats, such as XML or SGML. If you are working with SGML, you should import the tag settings files (.INI) in SDL Trados 2007 to ensure a smooth translation.

![Figure 11.3 - Options for saving TTX as target](image)

If saving both output file formats is possible, you can use smart tag pairing mode. If not, disable smart tag pairing and use compatibility mode. You can also open the generated TTX file in SDL Trados TagEditor, use the **Save Target As** command to save it in its original format and review the document to ensure it generated correctly.

**How to Specify your Compatibility Setting**

To specify if you want to use the smart tag pairing mode or compatibility mode:

1 Select **File > Options** from the Ribbon. The **Options** dialog box is displayed. This is where you can specify your default file type settings.

**NOTE**

If you want to specify these settings for the active project or active document instead, select **Home tab > Project Settings** in any view.
2. Select File types > TRADOSTag > Compatibility from the navigation tree. The Compatibility settings are displayed on the right.

Figure 11.4 - Compatibility Settings for TradosTag

3. Select your mode:
   - Select the Treat all inline tags as placeholders option to disable smart tag pairing and use compatibility mode.
   - Clear the option to enable smart tag pairing.

4. Click OK to close this dialog box.
Tag Verification Settings

You can fine-tune the way tags are checked in a TTX file.

How to Specify your Tag Verification Settings

1. Select File > Options > Verification > Tag Verifier > Common from the navigation tree. The Tag Verification settings are displayed on the right.

Figure 11.5 - Tag Verification Settings

2. Specify your tag verification settings and click OK to close this dialog box.
SCENARIOS

These scenarios provide information on how to plug into the SDL Trados 2007 (and earlier) supply chain from SDL Trados Studio by explaining how to provide TTX files and translation memories to users of legacy SDL Trados product generations wherever required.

For information on which options to select before you start, see Before You Start: Options for TTX Support on page 11-3.

Scenario 1: Client Sends TTX Files and Wants TTX Files Back

SDL Trados Studio provides full support for TTX files as input and output, so you can easily return TTX files sent to you after translation in SDL Trados Studio.

- Standard projects (using the New Project command). Use this if you want to work with multiple TTX files in a bigger project. This also allows you to analyze and pre-translate before working on the files in SDL Trados Studio.

The basic workflow is as follows:

1. Receive TTX files from customer.
2. In SDL Trados Studio, decide if you want to use smart tag pairing or full compatibility mode for TTX files and define the tag verification settings for TTX (see Before You Start: Options for TTX Support on page 11-3).
3 In SDL Trados Studio, do one of the following:

- Click **File > Open > Translate Single Document** to open a single TTX file for translation.
- Click **File > New > New Project** if you want to use the project preparation options available in SDL Trados Studio and if you are dealing with several TTX files. This allows you to use the project automation features, such as, analysis prior to translation and pre-translation. All relevant project automation features are supported not only for source files, but also bilingual input files in TTX format.

4 Translate the file(s) in the **Editor** view.

*Figure 11.6 - Translating TTX files in SDL Trados Studio*
After translation is finished, use one of the following:

- Select **File > Save Target As** if you want to generate the target translated document for a single file. The **Select File Type** dialog box is displayed. You can select to save it in its native (original) format, a TTX file or both.

  Figure 11.7 - Options for saving TTX as target in SDL Trados Studio

- If you are working with projects, select **Projects view > Home tab > Batch Tasks > Finalize**. The **Finalize** task generates TTX files as target files and places them into the target language folder of your project.

6 Deliver the translated TTX files back to your customer.
Scenario 2: Client Sends New Source Files and Wants Translated Files and TTX Files Back

In this scenario, you can use SDL TTX IT to batch convert files to the TTX format, then translate, save and finalize the files in SDL Trados Studio. TTX IT is an OpenExchange App that is installed with your installation of SDL Trados Studio 2014.

1. Receive new source files from customer.

2. Batch convert the files to TTX format in SDL TTX IT:
   - Open TTX IT from the Start menu under SDL > SDL Trados Studio 2014 > OpenExchange Apps > SDL TTX IT.
   - Select your source language from the Source language box.
   - Click Browse for file(s) and select the files that you want to convert to TTX.

   Figure 11.8 - Batch Convert in TTX IT
1. Click **Convert**. The files are converted to TTX.

**NOTE**

Click **View folder** to see the files in that format.

3. In SDL Trados Studio, decide if you want to use smart tag pairing or full compatibility mode for TTX files and define the tag verification settings for TTX (see *Before You Start: Options for TTX Support* on page 11-3).

4. In SDL Trados Studio, do one of the following:

   - Click **File > Translate Single Document** to open a single TTX file for translation. Select the target language in the **Open Document** dialog.

   - Click **New Project** option on the **Home** tab of the **Projects** view you want to use the project preparation options available in SDL Trados Studio and if you are dealing with several TTX files. This allows you to use the project automation features, such as, analysis prior to translation and pre-translation. All relevant project automation features are supported not only for source files, but also bilingual input files in TTX format.

5. Translate the file(s) in the **Editor** view.

**Figure 11.9 - Translating TTX files in SDL Trados Studio**
After translation is finished, use one of the following:

1. Select **File > Save Target As** if you want to generate the target translated document for a single file. The **Select File Type** dialog box is displayed. You can select to save it in its native (original) format, a TTX file or both.

   **Figure 11.10 - Options for saving TTX as target in SDL Trados Studio**

2. If you are working with projects, select **Projects view > Home tab > Batch Tasks > Finalize**. The **Finalize** task generates TTX files as target files and places them into the target language folder of your project.
If you want to batch create native target documents from the TTX files, you can now run a batch clean up in SDL Trados Translator’s Workbench in SDL Trados 2007. Select Tools > Clean Up from the menu bar. If you select the Update TM option, then any new translations you created in SDL Trados Studio are also imported into your legacy SDL Trados translation memories, effectively keeping both your new SDL Trados Studio and old SDL Trados translation memories up-to-date. For more information, see Tip: Keeping Both Studio (.sdltm) and Legacy SDL Trados (.tmw) Translation Memories Up-to-Date on page 11-23.

Figure 11.11 - Clean Up in SDL Trados Translator’s Workbench

You can now deliver the translated TTX files and target files back to your customer.

NOTE

Scenario 2 can also be used when a client sends source files and wants to have extra reassurance that the translation can be done successfully even if a translator cannot complete the job and it has to be passed over to another translator to finish. In such a scenario, TTX can be used as a document format to work with as the translator who finishes the job may not yet have SDL Trados Studio and so can then work on the TTX file in SDL Trados 2007.
Scenario 3: Client Wants Bilingual TTX for Review Purposes

This scenario is similar to scenarios 1 and 2 in that you can deliver TTX files for reviewing purposes before converting the files back to their native format. However, if you choose to review the files in legacy SDL Trados versions, the SDL Trados Studio reviewing features are not available. Reviewing TTX files in SDL Trados Studio, works as well as reviewing new source files that are converted to SDL XLIFF. Below are instructions about how to follow a SDL Trados Studio-based process for reviewing TTX files:

1. Follow the steps in scenario 1 until you have fully translated TTX files.

2. In SDL Trados Studio, create a project package:
   - Click the Projects button in the navigation pane. The Projects view is displayed.
   - Select your project, right-click and select Create Project Package from the shortcut menu. The Create Project Package wizard is displayed.

Figure 11.12 - Creating a review project package with TTX files in SDL Trados Studio
Follow the on-screen instructions to create a package. On the Review Project Packages page, select Review from the Task drop-down list.

When the wizard is complete and the project package has been created, send the package to the team member who will review the files.

3 The reviewer can open the files for review from the project package in SDL Trados Studio. For more information, see Open a File for Review on page 2-43.

4 When the review is finished, the reviewer can create a return package with the completed work and send it back to you.

5 When you receive the return package, open it and then use one of the following methods to create your target documents:

- Select File > Save Target As if you want to generate the target translated document for a single file. The Select File Type dialog box is displayed. You can select to save it in its native (original) format, a TTX file or both.

  Figure 11.13 - Options for saving TTX as target in SDL Trados Studio

- If you are working with projects, select Projects view > Home tab > Batch Tasks > Finalize from the menu bar. The Finalize task generates TTX files as target files and places them into the target language folder of your project.
If you want to batch create native target documents from the TTX files, you can now run a batch clean up in SDL Trados Translator’s Workbench in SDL Trados 2007. Select **Tools > Clean Up** from the menu bar. If you select the **Update TM** option, then any new translations you created in SDL Trados Studio are also imported into your legacy SDL Trados translation memories, effectively keeping both your new SDL Trados Studio and old SDL Trados translation memories up-to-date. For more information, see *Tip: Keeping Both Studio (.sdltm) and Legacy SDL Trados (.tmw) Translation Memories Up-to-Date* on page 11-23.

![Figure 11.14 - Clean Up in SDL Trados Translator’s Workbench](image)

6 You can now deliver the translated TTX files and target files back to your customer.

**NOTE**

In SDL Trados Studio, it is possible to work with project and return packages, as described in steps 2 through 5 above. SDL recommends this way of working as it ensures that all relevant settings and project resources (such as, documents, translation memories, termbases and AutoSuggest dictionaries) can all be packaged up into one single file, making it easy and safe to pass project work on to the next project participant. However, similar to what was possible with TTX and ITD, it is also still possible to send SDL XLIFF files without creating project packages first. These SDL XLIFF are self-sufficient and can be opened in SDL Trados Studio in the same way as any other document. However, in this case, the project participant needs to manually open other resources belonging to the project, such as the translation memory or termbase.
Tip: Use HTML-Based Bilingual Preview for Review Purposes:

Even without using the package process described above, there are useful new review features in SDL Trados Studio which you can use to optimize the review process. For instance, if you want to review a translated document on paper, you can use the Print Preview feature in SDL Trados Studio to print the currently open document using your browser. A wide range of options are available to fine-tune what will be printed and how. For more information, see the *SDL Trados Studio Help*.

Figure 11.15 - Bilingual TTX document using Print Preview feature in SDL Trados Studio

Scenario 4: Client Wants Bilingual TTX Files to Update Their TM

This scenario is an extension to Scenario 2. See *Scenario 2: Client Sends New Source Files and Wants Translated Files and TTX Files Back* on page 11-11 and *Tip: Keeping Both Studio (.sdltm) and Legacy SDL Trados (.tmw) Translation Memories Up-to-Date* on page 11-23 for more information on how to ensure that both SDL Trados Studio and legacy SDL Trados translation memories can be kept up-to-date.
Scenario 5: Client Sends Sources File in Word Format (.doc) and Wants Bilingual .doc and Target.doc Files Back

1. Convert the files to bilingual word format using SDL Trados 2007. To do this, open SDL Trados Translator’s Workbench and do one of the following:

- Create a new translation memory with a source and target language that match the language direction with which you want to convert the files.
- Select File > Open from the Ribbon to open an existing translation memory with a matching language pair. This not only converts the files to TTX format but also partially translates your files during batch conversion.

2. Select a workflow for bilingual word files:

- Select Options > Translation Memory Options from the menu bar. The Translation Memory Options dialog box is displayed.

Figure 11.16 - Bilingual Word Workflow in SDL Trados Translator’s Workbench
On the Tools tab, clear the check box next to the TRADOStag XML workflow for Word .doc files option. This will ensure that documents are not converted to TTX during the batch conversion. For more information on file type support in SDL Trados 2007, refer to the SDL Trados File Formats Reference Guide shipped with SDL Trados 2007.

3. Select Tools > Translate from the menu bar. The Translate Files dialog box is displayed.

Figure 11.17 - Batch Translate in SDL Trados Translator’s Workbench

4. Select Segment unknown sentences to ensure the file is fully segmented even where no match is found from the 2007 TM. If you do not select this option and use a new translation memory, a clean TTX document that contains only the source document converted to TTX is created.

**NOTE**

If you plan to keep both legacy translation memories from SDL Trados 2007 and new translation memories in SDL Trados Studio in sync (because you intend to work with both product generations in the transition phase), SDL recommends that you ensure that the segmentation rules of the SDL Trados 2007 translation memory match the settings in the SDL Trados Studio translation memory. This will ensure that you get the same or very similar leverage from the translation memories in both products.
5. Click **Add**. The **Files to Translate** dialog box is displayed.

6. Select your files and click **Open**.

7. Click **Translate**. Your files are converted to a bilingual word format and the correct source and target language is set for translation in SDL Trados Studio later. If you have applied a translation memory that contains data, your files are also pre-translated.

8. Translate the files in SDL Trados Studio. For more information about translating bilingual word documents in Studio, refer to the following:

   [http://blog.sdl.com](http://blog.sdl.com)

9. After translation is finished, use one of the following to convert the files back to the bilingual .doc format:

   - Select **File > Save Target As** if you want to generate the target translated document for a single file. The **Select File Type** dialog box is displayed. You can select to save it in its native (original) format, a bilingual file or both.

   ![Figure 11.18 - Saving as Bilingual Doc Files in SDL Trados Studio](image)

   - If you are working with projects, select **Projects view > Home tab > Batch Tasks > Finalize** from the menu bar. The **Finalize** task generates bilingual doc files as target files and places them into the target language folder of your project.
Clean up the translated bilingual doc files in SDL Trados 2007. Select **Tools > Clean Up** from the menu bar. The **Clean Up Files** dialog box is displayed.

**Figure 11.19 - Cleaning Up Files in SDL Trados Translator’s Workbench**

11 Click **Add** and select the translated bilingual .doc files.

12 Click **Clean Up**. When you do this, the following happens:

- A backup copy of the document is created that contains the source and translated material (*BAK),
- A copy of the target document with no source is created (the "clean" file - *.DOC)
- The translation memory is updated (*.TMW).

**NOTE**

For more information, see *Tip: Keeping Both Studio (.sdltm) and Legacy SDL Trados (.tmw) Translation Memories Up-to-Date* on page 11-23. This adds the translations to your legacy translation memories for use in SDL Trados 2007.
Tip: Keeping Both Studio (.sdltm) and Legacy SDL Trados (.tmw) Translation Memories Up-to-Date

The best approach to keeping both SDL Trados Studio and legacy SDL Trados translation memories up-to-date is to complete the following two steps:

1. SDL Trados Studio TM (.sdltm): Translate the TTX documents in SDL Trados Studio and run the **Finalize** batch task at the end of translation. This will ensure that the SDL Trados Studio translation memory will be kept up-to-date at all times.

   **NOTE**
   If you work with the master translation memory throughout the project lifecycle, (this is the case if you do not use project translation memories or you work with single document translation only using the **Translate Single Document** command rather than the **New Project** command) then it is not necessary to run the **Finalize** task, as the translation memory is already up-to-date based on your work in the **Editor** view in SDL Trados Studio.

2. SDL Trados Translator’s Workbench TM (.tmw): After finalizing the files in SDL Trados Studio, the final version of the TTX files are automatically placed in the target language folder of your project location in SDL Trados Studio. In SDL Trados Translator’s Workbench, open the legacy translation memory you want to update. Select **Tools > Clean Up** from the menu bar. The **Clean Up** dialog box is displayed.

   ![Clean Up in SDL Trados Translator’s Workbench](image)

   **Figure 11.20 - Clean Up in SDL Trados Translator’s Workbench**
Click **Add** and select the final TTX files.

Select the **Update TM** option.

Click **Clean Up**. SDL Trados Translator’s Workbench updates the translation memory based on the latest version of the TTX file and also produces the final target language version.

Optionally, you can also run an analysis on the original (initial untranslated) files using the SDL Trados 2007 translation memory and fix (re-translate) any segments that do not match.

**TIP**

If you plan to keep translation memories in both 2007 and 2014 in sync as much as possible, use the mixed scenario option in the **Upgrade Translation Memories** wizard when upgrading your translation memories from 2007 to 2014. This will ensure that your 2014 translation memories are best suited for use with both new (SDL XLIFF) and old (TTX or ITD) based projects.

**Figure 11.21 - Advanced Translation Memory Upgrade Options for Mixed Scenarios**

![Upgrade Translation Memories](image)
SDL enables global businesses to enrich their customers’ experience through the entire customer journey. SDL’s technology and services help brands to predict what their customers want and engage with them across multiple languages, cultures, channels and devices.

SDL has over 1,500 enterprise customers, 400 partners and a global infrastructure of 70 offices in 38 countries. 42 out of the top 50 brands work with SDL. For more information, visit www.sdl.com.